Bug 295682 - Software Center crash after restart
Summary: Software Center crash after restart
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-10 14:26 UTC by Ray
Modified: 2012-03-11 08:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.63 KB, text/plain)
2012-03-11 08:21 UTC, token
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ray 2012-03-10 14:26:59 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
No other applications running. Sysytem had just been Restarted after upgrades.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb776d930 (LWP 2090))]

Thread 2 (Thread 0xb59f9b70 (LWP 2091)):
#0  0x00b76416 in __kernel_vsyscall ()
#1  0x006957ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0859434b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x08585896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x08585c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00d0bb37 in QEventDispatcherGlib::processEvents (this=0x94a3910, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00cdc1dd in QEventLoop::processEvents (this=0xb59f92b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00cdc421 in QEventLoop::exec (this=0xb59f92b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00bdf90b in QThread::exec (this=0x94a8478) at thread/qthread.cpp:498
#9  0x00cbce2d in QInotifyFileSystemWatcherEngine::run (this=0x94a8478) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00be27b3 in QThreadPrivate::start (arg=0x94a8478) at thread/qthread_unix.cpp:331
#11 0x00e1ed31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x006a446e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb776d930 (LWP 2090)):
[KCrash Handler]
#7  0x00c36e11 in QtPrivate::QStringList_contains (that=0xbfccf034, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfccf034) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9451b48) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9451b48, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfccf254) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00ce3b7d in metacall (argv=0xbfccf254, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9451b48) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9451b48, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfccf254) at kernel/qmetaobject.cpp:232
#13 0x00cf2a6a in QMetaObject::activate (sender=0x95aa900, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x95aa900) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x95aa900, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfccf398) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00ce3b7d in metacall (argv=0xbfccf398, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x95aa900) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x95aa900, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfccf398) at kernel/qmetaobject.cpp:232
#18 0x00cf2a6a in QMetaObject::activate (sender=0x9451b48, m=0x80950c0, local_signal_index=0, argv=0xbfccf398) at kernel/qobject.cpp:3278
#19 0x0077c7c5 in MuonMainWindow::backendReady (this=0x9451b48, _t1=0x94666b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0077c933 in MuonMainWindow::initObject (this=0x9451b48) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9451b48) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9451b48, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfccf4c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00ce3b7d in metacall (argv=0xbfccf4c4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9451b48) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9451b48, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfccf4c4) at kernel/qmetaobject.cpp:232
#25 0x00cf2a6a in QMetaObject::activate (sender=0x94c2808, m=0xe13238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00cfa375 in QSingleShotTimer::timeout (this=0x94c2808) at .moc/release-shared/qtimer.moc:82
#27 0x00cfa42c in QSingleShotTimer::timerEvent (this=0x94c2808) at kernel/qtimer.cpp:308
#28 0x00cf5994 in QObject::event (this=0x94c2808, e=0xbfccf8bc) at kernel/qobject.cpp:1181
#29 0x02078d84 in notify_helper (e=0xbfccf8bc, receiver=0x94c2808, this=0x9391b58) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9391b58, receiver=0x94c2808, e=0xbfccf8bc) at kernel/qapplication.cpp:4458
#31 0x0207e133 in QApplication::notify (this=0xbfccf8bc, receiver=0x94c2808, e=0xbfccf8bc) at kernel/qapplication.cpp:3886
#32 0x01058971 in KApplication::notify (this=0xbfccfbd0, receiver=0x94c2808, event=0xbfccf8bc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00cdd19e in QCoreApplication::notifyInternal (this=0xbfccfbd0, receiver=0x94c2808, event=0xbfccf8bc) at kernel/qcoreapplication.cpp:787
#34 0x00d0dc10 in sendEvent (event=0xbfccf8bc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x938e274) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00d0b122 in timerSourceDispatch (source=0x938e240) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0858525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x08585990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x08585c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00d0bada in QEventDispatcherGlib::processEvents (this=0x936f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02130e7a in QGuiEventDispatcherGlib::processEvents (this=0x936f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00cdc1dd in QEventLoop::processEvents (this=0xbfccfb34, flags=...) at kernel/qeventloop.cpp:149
#43 0x00cdc421 in QEventLoop::exec (this=0xbfccfb34, flags=...) at kernel/qeventloop.cpp:201
#44 0x00ce119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02076924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295215, bug 295188, bug 295179, bug 295163, bug 295127.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-10 16:23:29 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 token 2012-03-11 08:21:56 UTC
Created attachment 69485 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed: I'm simply launch muon after restart system.

-- Backtrace (Reduced):
#7  0x005b4e11 in QtPrivate::QStringList_contains (that=0xbfc24ab4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc24ab4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8fc3660) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8fc3660, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc24cd4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00661b7d in metacall (argv=0xbfc24cd4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8fc3660) at kernel/qmetaobject.cpp:237