Bug 295188 - muan package handler has never worked.
Summary: muan package handler has never worked.
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-02 03:05 UTC by doug.gallinger
Modified: 2012-04-19 22:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.70 KB, text/plain)
2012-03-10 19:47 UTC, walker
Details
New crash information added by DrKonqi (5.22 KB, text/plain)
2012-04-19 22:11 UTC, Stian Berger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description doug.gallinger 2012-03-02 03:05:19 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:Nothing else was running, crashes even after a fresh reboot.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb771d930 (LWP 2245))]

Thread 2 (Thread 0xb55b8b70 (LWP 2249)):
#0  0x00b95dbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00591f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x050f870b in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x050f9637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x050f9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00e2cb37 in QEventDispatcherGlib::processEvents (this=0x9d7ef58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00dfd1dd in QEventLoop::processEvents (this=0xb55b82b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00dfd421 in QEventLoop::exec (this=0xb55b82b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00d0090b in QThread::exec (this=0x9e3f570) at thread/qthread.cpp:498
#9  0x00ddde2d in QInotifyFileSystemWatcherEngine::run (this=0x9e3f570) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00d037b3 in QThreadPrivate::start (arg=0x9e3f570) at thread/qthread_unix.cpp:331
#11 0x00b93d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x005840ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb771d930 (LWP 2245)):
[KCrash Handler]
#7  0x00d57e11 in QtPrivate::QStringList_contains (that=0xbfe8db24, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe8db24) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9ceb808) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9ceb808, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe8dd44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00e04b7d in metacall (argv=0xbfe8dd44, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9ceb808) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9ceb808, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe8dd44) at kernel/qmetaobject.cpp:232
#13 0x00e13a6a in QMetaObject::activate (sender=0x9d5cec8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9d5cec8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9d5cec8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe8de88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00e04b7d in metacall (argv=0xbfe8de88, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9d5cec8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9d5cec8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe8de88) at kernel/qmetaobject.cpp:232
#18 0x00e13a6a in QMetaObject::activate (sender=0x9ceb808, m=0x80950c0, local_signal_index=0, argv=0xbfe8de88) at kernel/qobject.cpp:3278
#19 0x00c647c5 in MuonMainWindow::backendReady (this=0x9ceb808, _t1=0x9c06ca0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00c64933 in MuonMainWindow::initObject (this=0x9ceb808) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9ceb808) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9ceb808, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe8dfb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00e04b7d in metacall (argv=0xbfe8dfb4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9ceb808) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9ceb808, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe8dfb4) at kernel/qmetaobject.cpp:232
#25 0x00e13a6a in QMetaObject::activate (sender=0x9d639e0, m=0xf34238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00e1b375 in QSingleShotTimer::timeout (this=0x9d639e0) at .moc/release-shared/qtimer.moc:82
#27 0x00e1b42c in QSingleShotTimer::timerEvent (this=0x9d639e0) at kernel/qtimer.cpp:308
#28 0x00e16994 in QObject::event (this=0x9d639e0, e=0xbfe8e3ac) at kernel/qobject.cpp:1181
#29 0x05f16d84 in notify_helper (e=0xbfe8e3ac, receiver=0x9d639e0, this=0x9bfd6b0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9bfd6b0, receiver=0x9d639e0, e=0xbfe8e3ac) at kernel/qapplication.cpp:4458
#31 0x05f1c133 in QApplication::notify (this=0xbfe8e3ac, receiver=0x9d639e0, e=0xbfe8e3ac) at kernel/qapplication.cpp:3886
#32 0x01120971 in KApplication::notify (this=0xbfe8e6c0, receiver=0x9d639e0, event=0xbfe8e3ac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00dfe19e in QCoreApplication::notifyInternal (this=0xbfe8e6c0, receiver=0x9d639e0, event=0xbfe8e3ac) at kernel/qcoreapplication.cpp:787
#34 0x00e2ec10 in sendEvent (event=0xbfe8e3ac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9bfe934) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00e2c122 in timerSourceDispatch (source=0x9bfe900) at kernel/qeventdispatcher_glib.cpp:184
#37 0x050f925f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x050f9990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x050f9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00e2cada in QEventDispatcherGlib::processEvents (this=0x9be0238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05fcee7a in QGuiEventDispatcherGlib::processEvents (this=0x9be0238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00dfd1dd in QEventLoop::processEvents (this=0xbfe8e624, flags=...) at kernel/qeventloop.cpp:149
#43 0x00dfd421 in QEventLoop::exec (this=0xbfe8e624, flags=...) at kernel/qeventloop.cpp:201
#44 0x00e0219d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05f14924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295179, bug 295163, bug 295127, bug 295114, bug 295100.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-02 03:56:35 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 walker 2012-03-10 19:47:03 UTC
Created attachment 69469 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:fresh install, installed all updates and muon software center crashs instantly when started

-- Backtrace (Reduced):
#7  0x004b5e11 in QtPrivate::QStringList_contains (that=0xbf99aba4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf99aba4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x98698c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x98698c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf99adc4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00562b7d in metacall (argv=0xbf99adc4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x98698c0) at kernel/qmetaobject.cpp:237
Comment 3 Stian Berger 2012-04-19 22:11:11 UTC
Created attachment 70518 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
Does not matter what I do and what I run when I start it. Crashes no matter what. Fresh Ubuntu install fails before and after updates and drivers are installed.

-- Backtrace (Reduced):
#6  0x00007f2cdcaf6a5e in QtPrivate::QStringList_contains (that=0x7fff4c14b150, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff4c14b150) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x254e160) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x254e160, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4c14b720) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x25d4020, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4c14b880) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109