Bug 295179 - Muon Program manager crashed
Summary: Muon Program manager crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-01 21:47 UTC by Thomas
Modified: 2012-03-01 22:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas 2012-03-01 21:47:40 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
It said that there is too less memory.
Maybe that's the reason why it crashed?
I am a totally newbie at linux, hope it helps anyway to improve kubuntu! :)

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77ad930 (LWP 1865))]

Thread 2 (Thread 0xb40fab70 (LWP 1871)):
#0  0x080f7f26 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x080f88f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x080f8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00cb9b37 in QEventDispatcherGlib::processEvents (this=0x8944848, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00c8a1dd in QEventLoop::processEvents (this=0xb40fa2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00c8a421 in QEventLoop::exec (this=0xb40fa2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00b8d90b in QThread::exec (this=0x891c5d0) at thread/qthread.cpp:498
#7  0x00c6ae2d in QInotifyFileSystemWatcherEngine::run (this=0x891c5d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00b907b3 in QThreadPrivate::start (arg=0x891c5d0) at thread/qthread_unix.cpp:331
#9  0x004e9d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x003540ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77ad930 (LWP 1865)):
[KCrash Handler]
#7  0x00be4e11 in QtPrivate::QStringList_contains (that=0xbffa2914, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffa2914) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x88e3ae0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x88e3ae0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffa2b34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00c91b7d in metacall (argv=0xbffa2b34, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x88e3ae0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x88e3ae0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbffa2b34) at kernel/qmetaobject.cpp:232
#13 0x00ca0a6a in QMetaObject::activate (sender=0x8956738, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8956738) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8956738, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffa2c78) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00c91b7d in metacall (argv=0xbffa2c78, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8956738) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8956738, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbffa2c78) at kernel/qmetaobject.cpp:232
#18 0x00ca0a6a in QMetaObject::activate (sender=0x88e3ae0, m=0x80950c0, local_signal_index=0, argv=0xbffa2c78) at kernel/qobject.cpp:3278
#19 0x0024e7c5 in MuonMainWindow::backendReady (this=0x88e3ae0, _t1=0x88e3968) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0024e933 in MuonMainWindow::initObject (this=0x88e3ae0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x88e3ae0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x88e3ae0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffa2da4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00c91b7d in metacall (argv=0xbffa2da4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x88e3ae0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x88e3ae0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbffa2da4) at kernel/qmetaobject.cpp:232
#25 0x00ca0a6a in QMetaObject::activate (sender=0x893fdb8, m=0xdc1238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00ca8375 in QSingleShotTimer::timeout (this=0x893fdb8) at .moc/release-shared/qtimer.moc:82
#27 0x00ca842c in QSingleShotTimer::timerEvent (this=0x893fdb8) at kernel/qtimer.cpp:308
#28 0x00ca3994 in QObject::event (this=0x893fdb8, e=0xbffa319c) at kernel/qobject.cpp:1181
#29 0x0287dd84 in notify_helper (e=0xbffa319c, receiver=0x893fdb8, this=0x87c7220) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x87c7220, receiver=0x893fdb8, e=0xbffa319c) at kernel/qapplication.cpp:4458
#31 0x02883133 in QApplication::notify (this=0xbffa319c, receiver=0x893fdb8, e=0xbffa319c) at kernel/qapplication.cpp:3886
#32 0x010fb971 in KApplication::notify (this=0xbffa34b0, receiver=0x893fdb8, event=0xbffa319c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00c8b19e in QCoreApplication::notifyInternal (this=0xbffa34b0, receiver=0x893fdb8, event=0xbffa319c) at kernel/qcoreapplication.cpp:787
#34 0x00cbbc10 in sendEvent (event=0xbffa319c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x87c950c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00cb9122 in timerSourceDispatch (source=0x87c94d8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x080f825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x080f8990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x080f8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00cb9ada in QEventDispatcherGlib::processEvents (this=0x87a9238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02935e7a in QGuiEventDispatcherGlib::processEvents (this=0x87a9238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00c8a1dd in QEventLoop::processEvents (this=0xbffa3414, flags=...) at kernel/qeventloop.cpp:149
#43 0x00c8a421 in QEventLoop::exec (this=0xbffa3414, flags=...) at kernel/qeventloop.cpp:201
#44 0x00c8f19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0287b924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295163, bug 295127, bug 295114, bug 295100, bug 295080.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-01 22:00:08 UTC

*** This bug has been marked as a duplicate of bug 291262 ***