Bug 295163 - Muon crasches by start
Summary: Muon crasches by start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-01 18:11 UTC by Master-of-honor
Modified: 2012-03-02 14:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.68 KB, text/plain)
2012-03-02 14:11 UTC, ph
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Master-of-honor 2012-03-01 18:11:31 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
at every start it crashes on a new installed Kubuntu 11.10

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd572b46780 (LWP 2096))]

Thread 2 (Thread 0x7fd55e01d700 (LWP 2097)):
#0  0x00007fd56f70c773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd56bf81f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd56bf82429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd5718caf3e in QEventDispatcherGlib::processEvents (this=0x2614cf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fd57189ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd57189eef7 in QEventLoop::exec (this=0x7fd55e01cdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fd5717b627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fd571881cbf in QInotifyFileSystemWatcherEngine::run (this=0x25acf60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd5717b8d05 in QThreadPrivate::start (arg=0x25acf60) at thread/qthread_unix.cpp:331
#9  0x00007fd56ca63efc in start_thread (arg=0x7fd55e01d700) at pthread_create.c:304
#10 0x00007fd56f71889d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd572b46780 (LWP 2096)):
[KCrash Handler]
#6  0x00007fd571806a5e in QtPrivate::QStringList_contains (that=0x7fffcd9f21d0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffcd9f21d0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x25b32e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x25b32e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcd9f27a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fd5718b2eba in QMetaObject::activate (sender=0x26744f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x26744f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcd9f2900) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fd5718b2eba in QMetaObject::activate (sender=0x25b32e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffcd9f2900) at kernel/qobject.cpp:3278
#13 0x00007fd572728e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x2590030) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fd572728f8e in MuonMainWindow::initObject (this=0x25b32e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x25b32e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x25b32e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcd9f29d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fd5718b2eba in QMetaObject::activate (sender=0x2638740, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fd5718baf7f in QSingleShotTimer::timerEvent (this=0x2638740) at kernel/qtimer.cpp:308
#19 0x00007fd5718b6789 in QObject::event (this=0x2638740, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fd56fed9474 in notify_helper (e=0x7fffcd9f2f40, receiver=0x2638740, this=0x244b2d0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x244b2d0, receiver=0x2638740, e=0x7fffcd9f2f40) at kernel/qapplication.cpp:4458
#22 0x00007fd56fede2e1 in QApplication::notify (this=0x7fffcd9f3240, receiver=0x2638740, e=0x7fffcd9f2f40) at kernel/qapplication.cpp:4365
#23 0x00007fd5710be466 in KApplication::notify (this=0x7fffcd9f3240, receiver=0x2638740, event=0x7fffcd9f2f40) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fd57189fafc in QCoreApplication::notifyInternal (this=0x7fffcd9f3240, receiver=0x2638740, event=0x7fffcd9f2f40) at kernel/qcoreapplication.cpp:787
#25 0x00007fd5718ccd62 in sendEvent (event=0x7fffcd9f2f40, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x2448190) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fd5718ca514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fd56bf81a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fd56bf82258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fd56bf82429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fd5718caed6 in QEventDispatcherGlib::processEvents (this=0x24246f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fd56ff8110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fd57189ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fd57189eef7 in QEventLoop::exec (this=0x7fffcd9f31d0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fd5718a3789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffcd9f34b8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295127, bug 295114, bug 295100, bug 295080, bug 295079.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-01 18:32:29 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 ph 2012-03-02 14:11:00 UTC
Created attachment 69239 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

nothing. i bootup system and run muon software center

-- Backtrace (Reduced):
#7  0x005bde11 in QtPrivate::QStringList_contains (that=0xbfc98054, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc98054) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9738398) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9738398, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc98274) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0066ab7d in metacall (argv=0xbfc98274, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9738398) at kernel/qmetaobject.cpp:237