Bug 294270 - Plasma crashes on exit
Summary: Plasma crashes on exit
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-16 21:54 UTC by Alex Dănilă
Modified: 2012-08-17 04:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.66 KB, text/plain)
2012-08-17 04:32 UTC, theotyflos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Dănilă 2012-02-16 21:54:47 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.2.0-1-amd64 x86_64
Distribution: Debian GNU/Linux 5.0.9 (lenny)

-- Information about the crash:
- What I was doing when the application crashed:
The crash happens most of the time when logging out. The are no special settings: the style is Skulpture with QtCurve style, few widgets and very few effects.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa8ef260780 (LWP 3994))]

Thread 2 (Thread 0x7fa8c8efa700 (LWP 3995)):
#0  0x00007fa8eeb5ccc3 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa8e280c5d8 in g_main_context_poll (n_fds=1, fds=0x26719c0, timeout=-1, context=0x266fe00, priority=<optimized out>) at /tmp/buildd/glib2.0-2.30.2/./glib/gmain.c:3391
#2  g_main_context_iterate (context=0x266fe00, block=<optimized out>, dispatch=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.30.2/./glib/gmain.c:3071
#3  0x00007fa8e280ca99 in g_main_context_iteration (context=0x266fe00, may_block=1) at /tmp/buildd/glib2.0-2.30.2/./glib/gmain.c:3139
#4  0x00007fa8ebc93df6 in QEventDispatcherGlib::processEvents (this=0x266f8f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fa8ebc635f2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa8ebc63847 in QEventLoop::exec (this=0x7fa8c8ef9dd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fa8ebb63307 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fa8ebc433af in QInotifyFileSystemWatcherEngine::run (this=0x2674d90) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fa8ebb6632b in QThreadPrivate::start (arg=0x2674d90) at thread/qthread_unix.cpp:298
#10 0x00007fa8e3521b50 in start_thread (arg=<optimized out>) at pthread_create.c:304
#11 0x00007fa8eeb6790d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa8ef260780 (LWP 3994)):
[KCrash Handler]
#6  0x00007fa8eb1e54d9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x2a40200, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007fa8eb1e5559 in QRasterWindowSurface::~QRasterWindowSurface (this=0x2a40200, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007fa8eb1fdc1e in QWidgetBackingStore::~QWidgetBackingStore (this=0x2a596c0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007fa8eb0318b9 in QWidgetBackingStoreTracker::destroy (this=0x2a58c20) at kernel/qwidget.cpp:217
#10 0x00007fa8eb031a0e in QWidgetPrivate::deleteExtra (this=0x3045440) at kernel/qwidget.cpp:1829
#11 0x00007fa8eb031c3c in QWidgetPrivate::~QWidgetPrivate (this=0x3045440, __in_chrg=<optimized out>) at kernel/qwidget.cpp:356
#12 0x00007fa8eb031f49 in QWidgetPrivate::~QWidgetPrivate (this=0x3045440, __in_chrg=<optimized out>) at kernel/qwidget.cpp:361
#13 0x00007fa8ebc7d540 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x3008d08, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x3008d00, __in_chrg=<optimized out>) at kernel/qobject.cpp:817
#16 0x00007fa8eb033c8d in QWidget::~QWidget (this=0x3008d00, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1550
#17 0x00007fa8edc5c129 in XSyncBasedPoller::~XSyncBasedPoller (this=0x3008d00, __in_chrg=<optimized out>) at ../../kutils/kidletime/xsyncbasedpoller.cpp:102
#18 0x00007fa8edc5c05d in ~XSyncBasedPollerHelper (this=0x30f53f0, __in_chrg=<optimized out>) at ../../kutils/kidletime/xsyncbasedpoller.cpp:33
#19 destroy () at ../../kutils/kidletime/xsyncbasedpoller.cpp:38
#20 0x00007fa8eeac5df2 in __run_exit_handlers (status=0, listp=0x7fa8eee104c8, run_list_atexit=true) at exit.c:78
#21 0x00007fa8eeac5e45 in *__GI_exit (status=44302848) at exit.c:100
#22 0x00007fa8eeaadeb4 in __libc_start_main (main=<optimized out>, argc=<optimized out>, ubp_av=<optimized out>, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffeee7eaa8) at libc-start.c:260
#23 0x00000000004006c1 in _start ()

Possible duplicates by query: bug 294229, bug 294100, bug 294033, bug 292398, bug 292252.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-16 22:20:31 UTC

*** This bug has been marked as a duplicate of bug 261539 ***
Comment 2 theotyflos 2012-08-17 04:32:32 UTC
Created attachment 73247 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.8.4 (4.8.4) using Qt 4.8.1

- What I was doing when the application crashed:
few seconds earlier i was browsing the web

-- Backtrace (Reduced):
#7  0xb5ad103b in QRasterWindowSurface::~QRasterWindowSurface (this=0x9623d90, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#8  0xb5ad10d2 in QRasterWindowSurface::~QRasterWindowSurface (this=0x9623d90, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#9  0xb5aec424 in QWidgetBackingStore::~QWidgetBackingStore (this=0x9629e00, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#10 0xb58f4cec in QWidgetBackingStoreTracker::destroy (this=0x9629d88) at kernel/qwidget.cpp:217
#11 0xb58f4e48 in QWidgetPrivate::deleteExtra (this=0x8cd4fd0) at kernel/qwidget.cpp:1830