Bug 292252 - Plasma crashes when logging out
Summary: Plasma crashes when logging out
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-23 07:28 UTC by Yvan Broccard
Modified: 2012-01-23 07:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yvan Broccard 2012-01-23 07:28:44 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I can't logout properly. Everytimes Plasma crashes with a segmentation fault. Even if the session is fresh.
kde 4.7.3
kernel 3.0.0.15 on kubuntu 11.10

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f59a91287a0 (LWP 3496))]

Thread 4 (Thread 0x7f598c089700 (LWP 3505)):
#0  pthread_mutex_unlock (mutex=0x7f59840009a8) at forward.c:184
#1  0x00007f599cf94fe4 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f599cf95dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f599cf96429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f59a5bfcf3e in QEventDispatcherGlib::processEvents (this=0x7f59840008b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f59a5bd0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f59a5bd0ef7 in QEventLoop::exec (this=0x7f598c088db0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f59a5ae827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f59a5bb3cbf in QInotifyFileSystemWatcherEngine::run (this=0x2a603e0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f59a5aead05 in QThreadPrivate::start (arg=0x2a603e0) at thread/qthread_unix.cpp:331
#10 0x00007f599daa2efc in start_thread (arg=0x7f598c089700) at pthread_create.c:304
#11 0x00007f59a8a1789d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5989584700 (LWP 3508)):
#0  0x00007f59a8a0b773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f599cf95f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f599cf96429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f59a5bfcf3e in QEventDispatcherGlib::processEvents (this=0x2c772e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f59a5bd0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f59a5bd0ef7 in QEventLoop::exec (this=0x7f5989583db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f59a5ae827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f59a5bb3cbf in QInotifyFileSystemWatcherEngine::run (this=0x2c765c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f59a5aead05 in QThreadPrivate::start (arg=0x2c765c0) at thread/qthread_unix.cpp:331
#9  0x00007f599daa2efc in start_thread (arg=0x7f5989584700) at pthread_create.c:304
#10 0x00007f59a8a1789d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f597cd83700 (LWP 3530)):
#0  0x00007f59a8a0b773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f599cf95f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f599cf96792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f597d861516 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f599cfbb2b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f599daa2efc in start_thread (arg=0x7f597cd83700) at pthread_create.c:304
#6  0x00007f59a8a1789d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f59a91287a0 (LWP 3496)):
[KCrash Handler]
#6  0x00007f59a5174c09 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3429960, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007f59a5174c89 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3429960, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007f59a518e26e in QWidgetBackingStore::~QWidgetBackingStore (this=0x343cc20, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f59a4fcba29 in QWidgetBackingStoreTracker::destroy (this=0x3451e70) at kernel/qwidget.cpp:210
#10 0x00007f59a4fcbb7e in QWidgetPrivate::deleteExtra (this=0x2c44220) at kernel/qwidget.cpp:1796
#11 0x00007f59a4fcbdac in QWidgetPrivate::~QWidgetPrivate (this=0x2c44220, __in_chrg=<optimized out>) at kernel/qwidget.cpp:341
#12 0x00007f59a4fcc0b9 in QWidgetPrivate::~QWidgetPrivate (this=0x2c44220, __in_chrg=<optimized out>) at kernel/qwidget.cpp:346
#13 0x00007f59a5be939b in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x25e3198, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x25e3190, __in_chrg=<optimized out>) at kernel/qobject.cpp:818
#16 0x00007f59a4fce162 in QWidget::~QWidget (this=0x25e3190, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#17 0x00007f59a4fce379 in QWidget::~QWidget (this=0x25e3190, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#18 0x00007f59a5538c55 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=<optimized out>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1825
#19 0x00007f59a8971821 in __run_exit_handlers (status=0, listp=0x7f59a8cce5a8, run_list_atexit=true) at exit.c:78
#20 0x00007f59a89718a5 in __GI_exit (status=<optimized out>) at exit.c:100
#21 0x00007f59a8957314 in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff620dcf58, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff620dcf48) at libc-start.c:258
#22 0x0000000000400671 in _start ()

Possible duplicates by query: bug 291235, bug 291175, bug 291079, bug 290079, bug 290007.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-23 07:39:26 UTC

*** This bug has been marked as a duplicate of bug 261539 ***