Bug 294024 - Muon Software loader Crashes on startup
Summary: Muon Software loader Crashes on startup
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-13 21:55 UTC by Kelley Castleberry
Modified: 2012-02-14 00:32 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.11 KB, text/plain)
2012-02-14 00:32 UTC, Rod MacKinnon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kelley Castleberry 2012-02-13 21:55:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Attempting to load additional applications thru the Muon software loader system, It starts then immediately crashes into the bug reporting system		

- Unusual behavior I noticed:  During first upgrade of system files the Muon system got stuck at 49 percent on identity or login updating info.  I force shutdown and restarted pc, and now the Muon System will not start up.  I have tried going into Kate and going in as su or root to update it manually with aptitude but it gives me authentication error.

- Custom settings of the application: first instatallation.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb479c930 (LWP 3645))]

Thread 2 (Thread 0xb22e4b70 (LWP 3649)):
#0  0xb7727424 in __kernel_vsyscall ()
#1  0xb5d5440e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb523f34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb5230896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5230c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb7297b37 in QEventDispatcherGlib::processEvents (this=0xb1900468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb72681dd in QEventLoop::processEvents (this=0xb22e42b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb7268421 in QEventLoop::exec (this=0xb22e42b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb716b90b in QThread::exec (this=0xa229108) at thread/qthread.cpp:498
#9  0xb7248e2d in QInotifyFileSystemWatcherEngine::run (this=0xa229108) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb716e7b3 in QThreadPrivate::start (arg=0xa229108) at thread/qthread_unix.cpp:331
#11 0xb5316d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5d630ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb479c930 (LWP 3645)):
[KCrash Handler]
#7  0xb71c2e11 in QtPrivate::QStringList_contains (that=0xbf948aa4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf948aa4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa18d040) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa18d040, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf948cc4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb726fb7d in metacall (argv=0xbf948cc4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa18d040) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa18d040, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf948cc4) at kernel/qmetaobject.cpp:232
#13 0xb727ea6a in QMetaObject::activate (sender=0xa097650, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa097650) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa097650, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf948e08) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb726fb7d in metacall (argv=0xbf948e08, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa097650) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa097650, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf948e08) at kernel/qmetaobject.cpp:232
#18 0xb727ea6a in QMetaObject::activate (sender=0xa18d040, m=0x80950c0, local_signal_index=0, argv=0xbf948e08) at kernel/qobject.cpp:3278
#19 0xb76df7c5 in MuonMainWindow::backendReady (this=0xa18d040, _t1=0xa18da98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb76df933 in MuonMainWindow::initObject (this=0xa18d040) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa18d040) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa18d040, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf948f34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb726fb7d in metacall (argv=0xbf948f34, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa18d040) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa18d040, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf948f34) at kernel/qmetaobject.cpp:232
#25 0xb727ea6a in QMetaObject::activate (sender=0xa1fc600, m=0xb739f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7286375 in QSingleShotTimer::timeout (this=0xa1fc600) at .moc/release-shared/qtimer.moc:82
#27 0xb728642c in QSingleShotTimer::timerEvent (this=0xa1fc600) at kernel/qtimer.cpp:308
#28 0xb7281994 in QObject::event (this=0xa1fc600, e=0xbf94932c) at kernel/qobject.cpp:1181
#29 0xb604fd84 in notify_helper (e=0xbf94932c, receiver=0xa1fc600, this=0xa09bdf0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0xa09bdf0, receiver=0xa1fc600, e=0xbf94932c) at kernel/qapplication.cpp:4458
#31 0xb6055133 in QApplication::notify (this=0xbf94932c, receiver=0xa1fc600, e=0xbf94932c) at kernel/qapplication.cpp:3886
#32 0xb6e6e971 in KApplication::notify (this=0xbf949640, receiver=0xa1fc600, event=0xbf94932c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb726919e in QCoreApplication::notifyInternal (this=0xbf949640, receiver=0xa1fc600, event=0xbf94932c) at kernel/qcoreapplication.cpp:787
#34 0xb7299c10 in sendEvent (event=0xbf94932c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0xa0980ac) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb7297155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0xa09f090) at kernel/qeventdispatcher_glib.cpp:231
#38 0xb523025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb5230990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb5230c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0xb7297ada in QEventDispatcherGlib::processEvents (this=0xa07a238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0xb6107e7a in QGuiEventDispatcherGlib::processEvents (this=0xa07a238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0xb72681dd in QEventLoop::processEvents (this=0xbf9495a4, flags=...) at kernel/qeventloop.cpp:149
#44 0xb7268421 in QEventLoop::exec (this=0xbf9495a4, flags=...) at kernel/qeventloop.cpp:201
#45 0xb726d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0xb604d924 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293940, bug 293938, bug 293911, bug 293910, bug 293904.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-13 22:03:11 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Rod MacKinnon 2012-02-14 00:32:40 UTC
Created attachment 68778 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
First update crashed at 51% running DPKG, rebooted and MUON will still not run properly

-- Backtrace (Reduced):
#6  0x00007f0a7d9cba5e in QtPrivate::QStringList_contains (that=0x7fff487470e0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff487470e0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x150dc60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x150dc60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff487476b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x16f0d40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff48747810) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109