Bug 293940 - Muon software center da errore e non si avvia mai
Summary: Muon software center da errore e non si avvia mai
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-12 21:57 UTC by simone
Modified: 2012-02-12 22:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description simone 2012-02-12 21:57:11 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Tentato di avviare muon software center. Non si avvia mai. si pianta sempre.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7833930 (LWP 1892))]

Thread 2 (Thread 0xb5b23b70 (LWP 1893)):
#0  0x00c1dd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x004e97d5 in do_gettime (frac=0xb5b23020, sec=0xb5b23018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x005bc4b6 in QTimerInfoList::updateCurrentTime (this=0x9a40dcc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x005bc80a in QTimerInfoList::timerWait (this=0x9a40dcc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x005bb053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5b2312c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x005bb0ed in timerSourcePrepare (source=0x9a40d98, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x06a6288c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x06a63637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x06a63c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x005bbb37 in QEventDispatcherGlib::processEvents (this=0x9b27638, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x0058c1dd in QEventLoop::processEvents (this=0xb5b232b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x0058c421 in QEventLoop::exec (this=0xb5b232b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0048f90b in QThread::exec (this=0x9b1d3b8) at thread/qthread.cpp:498
#14 0x0056ce2d in QInotifyFileSystemWatcherEngine::run (this=0x9b1d3b8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x004927b3 in QThreadPrivate::start (arg=0x9b1d3b8) at thread/qthread_unix.cpp:331
#16 0x00826d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00d5a0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7833930 (LWP 1892)):
[KCrash Handler]
#7  0x004e6e11 in QtPrivate::QStringList_contains (that=0xbfa7c404, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfa7c404) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9b1bec0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9b1bec0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa7c624) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00593b7d in metacall (argv=0xbfa7c624, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9b1bec0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9b1bec0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfa7c624) at kernel/qmetaobject.cpp:232
#13 0x005a2a6a in QMetaObject::activate (sender=0x9b76a60, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9b76a60) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9b76a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa7c768) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00593b7d in metacall (argv=0xbfa7c768, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9b76a60) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9b76a60, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfa7c768) at kernel/qmetaobject.cpp:232
#18 0x005a2a6a in QMetaObject::activate (sender=0x9b1bec0, m=0x80950c0, local_signal_index=0, argv=0xbfa7c768) at kernel/qobject.cpp:3278
#19 0x007617c5 in MuonMainWindow::backendReady (this=0x9b1bec0, _t1=0x9b765f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00761933 in MuonMainWindow::initObject (this=0x9b1bec0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9b1bec0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9b1bec0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa7c894) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00593b7d in metacall (argv=0xbfa7c894, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9b1bec0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9b1bec0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfa7c894) at kernel/qmetaobject.cpp:232
#25 0x005a2a6a in QMetaObject::activate (sender=0x9b7c818, m=0x6c3238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x005aa375 in QSingleShotTimer::timeout (this=0x9b7c818) at .moc/release-shared/qtimer.moc:82
#27 0x005aa42c in QSingleShotTimer::timerEvent (this=0x9b7c818) at kernel/qtimer.cpp:308
#28 0x005a5994 in QObject::event (this=0x9b7c818, e=0xbfa7cc8c) at kernel/qobject.cpp:1181
#29 0x04ac4d84 in notify_helper (e=0xbfa7cc8c, receiver=0x9b7c818, this=0x9a0a0d0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9a0a0d0, receiver=0x9b7c818, e=0xbfa7cc8c) at kernel/qapplication.cpp:4458
#31 0x04aca133 in QApplication::notify (this=0xbfa7cc8c, receiver=0x9b7c818, e=0xbfa7cc8c) at kernel/qapplication.cpp:3886
#32 0x011a3971 in KApplication::notify (this=0xbfa7cfa0, receiver=0x9b7c818, event=0xbfa7cc8c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0058d19e in QCoreApplication::notifyInternal (this=0xbfa7cfa0, receiver=0x9b7c818, event=0xbfa7cc8c) at kernel/qcoreapplication.cpp:787
#34 0x005bdc10 in sendEvent (event=0xbfa7cc8c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9a05904) at kernel/qeventdispatcher_unix.cpp:603
#36 0x005bb122 in timerSourceDispatch (source=0x9a058d0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x06a6325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06a63990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06a63c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x005bbada in QEventDispatcherGlib::processEvents (this=0x99e7238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x04b7ce7a in QGuiEventDispatcherGlib::processEvents (this=0x99e7238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0058c1dd in QEventLoop::processEvents (this=0xbfa7cf04, flags=...) at kernel/qeventloop.cpp:149
#43 0x0058c421 in QEventLoop::exec (this=0xbfa7cf04, flags=...) at kernel/qeventloop.cpp:201
#44 0x0059119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x04ac2924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293938, bug 293911, bug 293910, bug 293904, bug 293896.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-12 22:03:12 UTC

*** This bug has been marked as a duplicate of bug 291262 ***