Bug 294023 - central muon bug
Summary: central muon bug
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-13 21:52 UTC by andredecarvalho
Modified: 2012-02-13 22:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andredecarvalho 2012-02-13 21:52:19 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

in portuguese:
A central de programas muon simplesmente trava e retorna um erro ao abrir. isso depois de realizar as atualizações de rotina do sistema operacional.

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f984432b780 (LWP 22419))]

Thread 2 (Thread 0x7f982d189700 (LWP 22425)):
#0  0x00007f9840ef6773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f983d76bf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f983d76c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f98430b4f3e in QEventDispatcherGlib::processEvents (this=0xec6ff0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9843088cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9843088ef7 in QEventLoop::exec (this=0x7f982d188dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9842fa027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f984306bcbf in QInotifyFileSystemWatcherEngine::run (this=0xea0660) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9842fa2d05 in QThreadPrivate::start (arg=0xea0660) at thread/qthread_unix.cpp:331
#9  0x00007f983e24defc in start_thread (arg=0x7f982d189700) at pthread_create.c:304
#10 0x00007f9840f0289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f984432b780 (LWP 22419)):
[KCrash Handler]
#6  0x00007f9842ff0a5e in QtPrivate::QStringList_contains (that=0x7fffffdc0800, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffffdc0800) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xe316e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xe316e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffffdc0dd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f984309ceba in QMetaObject::activate (sender=0xcdfc60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xcdfc60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffffdc0f30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f984309ceba in QMetaObject::activate (sender=0xe316e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffffdc0f30) at kernel/qobject.cpp:3278
#13 0x00007f9843f12e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xe544d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f9843f12f8e in MuonMainWindow::initObject (this=0xe316e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xe316e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xe316e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffffdc1000) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f984309ceba in QMetaObject::activate (sender=0xee9210, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f98430a4f7f in QSingleShotTimer::timerEvent (this=0xee9210) at kernel/qtimer.cpp:308
#19 0x00007f98430a0789 in QObject::event (this=0xee9210, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f98416c3474 in notify_helper (e=0x7fffffdc1570, receiver=0xee9210, this=0xcf20f0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xcf20f0, receiver=0xee9210, e=0x7fffffdc1570) at kernel/qapplication.cpp:4458
#22 0x00007f98416c82e1 in QApplication::notify (this=0x7fffffdc1870, receiver=0xee9210, e=0x7fffffdc1570) at kernel/qapplication.cpp:4365
#23 0x00007f98428a8466 in KApplication::notify (this=0x7fffffdc1870, receiver=0xee9210, event=0x7fffffdc1570) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f9843089afc in QCoreApplication::notifyInternal (this=0x7fffffdc1870, receiver=0xee9210, event=0x7fffffdc1570) at kernel/qcoreapplication.cpp:787
#25 0x00007f98430b6d62 in sendEvent (event=0x7fffffdc1570, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xcf3340) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f98430b4538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f983d76ba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f983d76c258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f983d76c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f98430b4ed6 in QEventDispatcherGlib::processEvents (this=0xcc96f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f984176b10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f9843088cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f9843088ef7 in QEventLoop::exec (this=0x7fffffdc1800, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f984308d789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=1, argv=0x7fffffdc1ae8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293940, bug 293938, bug 293911, bug 293910, bug 293904.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-13 22:02:26 UTC

*** This bug has been marked as a duplicate of bug 291262 ***