Bug 278141 - Switch off comp
Summary: Switch off comp
Status: RESOLVED DUPLICATE of bug 314544
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: libsolid (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
: 281285 281903 285340 285850 286434 286583 287326 287413 289429 289526 289976 290045 294324 298881 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-20 12:53 UTC by jbasko
Modified: 2013-03-02 00:01 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jbasko 2011-07-20 12:53:07 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.5 (4.6.5) (Compiled from sources)
Qt Version: 4.7.3
Operating System: Linux 2.6.38.8-35.fc15.i686.PAE i686
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
- What I was doing when the application crashed: switch off computer.
 Try to install php modul, libxml too. dont know more

-- Backtrace:
Application: Shell plochy Plasma (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#7  0x00000008 in ?? ()
#8  0x41f53297 in ~QExplicitlySharedDataPointer (this=0x9e44f04, __in_chrg=<optimized out>) at /usr/include/QtCore/qshareddata.h:161
#9  Solid::Device::~Device (this=0x9e44f04, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.6.5/solid/solid/device.cpp:85
#10 0x005cb2f6 in ~QHashNode (this=0x9e44ef8, __in_chrg=<optimized out>) at /usr/include/QtCore/qhash.h:216
#11 QHash<QString, Solid::Device>::deleteNode2 (node=0x9e44ef8) at /usr/include/QtCore/qhash.h:519
#12 0x417df93a in QHashData::free_helper (this=0x9ddd4f0, node_delete=0x5cb2d0 <QHash<QString, Solid::Device>::deleteNode2(QHashData::Node*)>) at tools/qhash.cpp:271
#13 0x005c7b1b in freeData (x=<optimized out>, this=0x9de33dc) at /usr/include/QtCore/qhash.h:568
#14 ~QHash (this=0x9de33dc, __in_chrg=<optimized out>) at /usr/include/QtCore/qhash.h:284
#15 ~QHash (this=0x9de33dc, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/generic/dataengines/hotplug/hotplugengine.cpp:52
#16 HotplugEngine::~HotplugEngine (this=0x9de33c8, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/generic/dataengines/hotplug/hotplugengine.cpp:52
#17 0x005c7b93 in HotplugEngine::~HotplugEngine (this=0x9de33c8, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/generic/dataengines/hotplug/hotplugengine.cpp:55
#18 0x4419ba4a in Plasma::DataEngineManager::unloadEngine (this=0x9bbbe58, name=...) at /usr/src/debug/kdelibs-4.6.5/plasma/dataenginemanager.cpp:151
#19 0x441d4c9c in Plasma::DataEngineConsumer::~DataEngineConsumer (this=0x9db15e0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/private/dataengineconsumer.cpp:88
#20 0x44160aee in Plasma::AppletPrivate::~AppletPrivate (this=0x9db15e0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/applet.cpp:2553
#21 0x4416a5fb in Plasma::Applet::~Applet (this=0x9d9cf50, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/applet.cpp:223
#22 0x441c8b77 in Plasma::PopupApplet::~PopupApplet (this=0x9d9cf50, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/popupapplet.cpp:70
#23 0x00880acb in Notifier::DeviceNotifier::~DeviceNotifier (this=0x9d9cf50, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/generic/applets/devicenotifier/devicenotifier.cpp:180
#24 0x00880b23 in Notifier::DeviceNotifier::~DeviceNotifier (this=0x9d9cf50, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/generic/applets/devicenotifier/devicenotifier.cpp:183
#25 0x45361dd8 in QGraphicsItem::~QGraphicsItem (this=0x9b4dd88, __in_chrg=<optimized out>) at graphicsview/qgraphicsitem.cpp:1481
#26 0x453b82b4 in ~QGraphicsObject (this=<optimized out>, __in_chrg=<optimized out>) at ../../src/gui/graphicsview/qgraphicsitem.h:546
#27 QGraphicsWidget::~QGraphicsWidget (this=0x9b4dd80, __in_chrg=<optimized out>) at graphicsview/qgraphicswidget.cpp:232
#28 0x453b8443 in QGraphicsWidget::~QGraphicsWidget (this=0x9b4dd80, __in_chrg=<optimized out>) at graphicsview/qgraphicswidget.cpp:277
#29 0x418d0b52 in QObjectPrivate::deleteChildren (this=0x9baa938) at kernel/qobject.cpp:1955
#30 0x418d6469 in QObject::~QObject (this=0x9b15da8, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#31 0x453b82bc in ~QGraphicsObject (this=<optimized out>, __in_chrg=<optimized out>) at ../../src/gui/graphicsview/qgraphicsitem.h:546
#32 QGraphicsWidget::~QGraphicsWidget (this=0x9b15da8, __in_chrg=<optimized out>) at graphicsview/qgraphicswidget.cpp:232
#33 0x0066d354 in SystemTray::TaskArea::~TaskArea (this=0x9b15da8, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/generic/applets/systemtray/ui/taskarea.cpp:146
#34 0x0066d3f3 in SystemTray::TaskArea::~TaskArea (this=0x9b15da8, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/generic/applets/systemtray/ui/taskarea.cpp:153
#35 0x006638a1 in SystemTray::Applet::~Applet (this=0x9b9c870, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/generic/applets/systemtray/ui/applet.cpp:125
#36 0x00663ad3 in SystemTray::Applet::~Applet (this=0x9b9c870, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/generic/applets/systemtray/ui/applet.cpp:143
#37 0x4417a796 in qDeleteAll<QList<Plasma::Applet*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#38 qDeleteAll<QList<Plasma::Applet*> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#39 ~ContainmentPrivate (this=0x9b13978, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/private/containment_p.h:70
#40 Plasma::Containment::~Containment (this=0x9b80010, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/containment.cpp:148
#41 0x00865eb6 in DefaultDesktop::~DefaultDesktop (this=0x9b80010, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/containments/desktop/desktop.cpp:53
#42 0x00865f03 in DefaultDesktop::~DefaultDesktop (this=0x9b80010, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/containments/desktop/desktop.cpp:55
#43 0x4418f26e in qDeleteAll<QList<Plasma::Containment*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#44 qDeleteAll<QList<Plasma::Containment*> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#45 ~CoronaPrivate (this=0x9960188, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/corona.cpp:84
#46 Plasma::Corona::~Corona (this=0x98fcaf0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/corona.cpp:316
#47 0x42778de8 in DesktopCorona::~DesktopCorona (this=0x98fcaf0, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/shell/desktopcorona.cpp:70
#48 0x42778e33 in DesktopCorona::~DesktopCorona (this=0x98fcaf0, __in_chrg=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/shell/desktopcorona.cpp:73
#49 0x4279ea8a in PlasmaApp::cleanup (this=0x98e1688) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/shell/plasmaapp.cpp:375
#50 0x427a3ba1 in PlasmaApp::qt_metacall (this=0x98e1688, _c=QMetaObject::InvokeMetaMethod, _id=19, _a=0xbfdfcdc4) at /usr/src/debug/kdebase-workspace-4.6.5/i686-redhat-linux-gnu/plasma/desktop/shell/plasmaapp.moc:156
#51 0x418c3e9e in metacall (argv=0xbfdfcdc4, idx=46, cl=QMetaObject::InvokeMetaMethod, object=0x98e1688) at kernel/qmetaobject.cpp:237
#52 QMetaObject::metacall (object=0x98e1688, cl=QMetaObject::InvokeMetaMethod, idx=46, argv=0xbfdfcdc4) at kernel/qmetaobject.cpp:232
#53 0x418d1d6a in QMetaObject::activate (sender=0x98e1688, m=0x419f2940, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#54 0x419218e6 in QCoreApplication::aboutToQuit (this=0x98e1688) at .moc/release-shared/moc_qcoreapplication.cpp:131
#55 0x418c1418 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1013
#56 0x44cf4245 in QApplication::exec () at kernel/qapplication.cpp:3736
#57 0x42785ed6 in kdemain (argc=1, argv=0xbfdfd034) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/shell/main.cpp:120
#58 0x0804876c in main (argc=1, argv=0xbfdfd034) at /usr/src/debug/kdebase-workspace-4.6.5/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 277964, bug 276944, bug 276585, bug 276453, bug 273589.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-10-31 02:41:39 UTC
*** Bug 281285 has been marked as a duplicate of this bug. ***
Comment 2 Lamarque V. Souza 2011-10-31 02:41:51 UTC
*** Bug 281300 has been marked as a duplicate of this bug. ***
Comment 3 Lamarque V. Souza 2011-10-31 02:42:02 UTC
*** Bug 285340 has been marked as a duplicate of this bug. ***
Comment 4 Lamarque V. Souza 2011-11-06 00:27:08 UTC
*** Bug 285850 has been marked as a duplicate of this bug. ***
Comment 5 Lamarque V. Souza 2011-11-06 00:28:30 UTC
*** Bug 281903 has been marked as a duplicate of this bug. ***
Comment 6 Beat Wolf 2011-11-13 18:47:37 UTC
*** Bug 286434 has been marked as a duplicate of this bug. ***
Comment 7 Beat Wolf 2011-11-20 21:22:05 UTC
*** Bug 286583 has been marked as a duplicate of this bug. ***
Comment 8 Beat Wolf 2011-11-23 07:46:19 UTC
*** Bug 287326 has been marked as a duplicate of this bug. ***
Comment 9 Beat Wolf 2011-11-24 08:00:14 UTC
*** Bug 287413 has been marked as a duplicate of this bug. ***
Comment 10 Anne-Marie Mahfouf 2011-12-20 14:35:55 UTC
*** Bug 289429 has been marked as a duplicate of this bug. ***
Comment 11 Anne-Marie Mahfouf 2011-12-21 21:07:18 UTC
*** Bug 289526 has been marked as a duplicate of this bug. ***
Comment 12 Anne-Marie Mahfouf 2011-12-28 08:53:10 UTC
*** Bug 289976 has been marked as a duplicate of this bug. ***
Comment 13 Anne-Marie Mahfouf 2011-12-28 21:24:32 UTC
*** Bug 290045 has been marked as a duplicate of this bug. ***
Comment 14 Jekyll Wu 2012-02-17 23:47:37 UTC
*** Bug 294324 has been marked as a duplicate of this bug. ***
Comment 15 Jekyll Wu 2012-04-27 01:09:27 UTC
*** Bug 298881 has been marked as a duplicate of this bug. ***
Comment 16 Alex Fiestas 2013-03-02 00:01:36 UTC

*** This bug has been marked as a duplicate of bug 314544 ***