Bug 293401 - Muon Crashes Everytime
Summary: Muon Crashes Everytime
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-06 00:11 UTC by Shemp
Modified: 2012-02-06 04:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shemp 2012-02-06 00:11:33 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
I have discovered my crashes happen everytime. My system will not update at all.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3f0c0d3780 (LWP 3129))]

Thread 2 (Thread 0x7f3ef7821700 (LWP 3130)):
#0  0x00007f3f05ff803e in __pthread_mutex_lock (mutex=0xbf9188) at pthread_mutex_lock.c:62
#1  0x00007f3f055138c2 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3f05514258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3f05514429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f3f0ae5cf3e in QEventDispatcherGlib::processEvents (this=0xbf5260, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f3f0ae30cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f3f0ae30ef7 in QEventLoop::exec (this=0x7f3ef7820dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f3f0ad4827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f3f0ae13cbf in QInotifyFileSystemWatcherEngine::run (this=0xb83d90) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f3f0ad4ad05 in QThreadPrivate::start (arg=0xb83d90) at thread/qthread_unix.cpp:331
#10 0x00007f3f05ff5efc in start_thread (arg=0x7f3ef7821700) at pthread_create.c:304
#11 0x00007f3f08caa89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3f0c0d3780 (LWP 3129)):
[KCrash Handler]
#6  0x00007f3f0ad98a5e in QtPrivate::QStringList_contains (that=0x7fff34a9f900, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff34a9f900) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xb9e760) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xb9e760, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff34a9fed0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f3f0ae44eba in QMetaObject::activate (sender=0xc17380, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xc17380, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff34aa0030) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f3f0ae44eba in QMetaObject::activate (sender=0xb9e760, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff34aa0030) at kernel/qobject.cpp:3278
#13 0x00007f3f0bcbae7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xbe6d60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f3f0bcbaf8e in MuonMainWindow::initObject (this=0xb9e760) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xb9e760) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xb9e760, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff34aa0100) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f3f0ae44eba in QMetaObject::activate (sender=0xc19550, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f3f0ae4cf7f in QSingleShotTimer::timerEvent (this=0xc19550) at kernel/qtimer.cpp:308
#19 0x00007f3f0ae48789 in QObject::event (this=0xc19550, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f3f0946b474 in notify_helper (e=0x7fff34aa0670, receiver=0xc19550, this=0x9eef90) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x9eef90, receiver=0xc19550, e=0x7fff34aa0670) at kernel/qapplication.cpp:4458
#22 0x00007f3f094702e1 in QApplication::notify (this=0x7fff34aa0970, receiver=0xc19550, e=0x7fff34aa0670) at kernel/qapplication.cpp:4365
#23 0x00007f3f0a650466 in KApplication::notify (this=0x7fff34aa0970, receiver=0xc19550, event=0x7fff34aa0670) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f3f0ae31afc in QCoreApplication::notifyInternal (this=0x7fff34aa0970, receiver=0xc19550, event=0x7fff34aa0670) at kernel/qcoreapplication.cpp:787
#25 0x00007f3f0ae5ed62 in sendEvent (event=0x7fff34aa0670, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x9f2a70) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f3f0ae5c514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f3f05513a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f3f05514258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f3f05514429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f3f0ae5ced6 in QEventDispatcherGlib::processEvents (this=0x9c96f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f3f0951310e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f3f0ae30cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f3f0ae30ef7 in QEventLoop::exec (this=0x7fff34aa0900, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f3f0ae35789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff34aa0be8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293400, bug 293373, bug 293372, bug 293364, bug 293349.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-06 04:50:39 UTC

*** This bug has been marked as a duplicate of bug 291262 ***