Bug 293349 - Muon Programmverwaltung
Summary: Muon Programmverwaltung
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-05 08:54 UTC by andregallus-andreas
Modified: 2012-02-05 10:20 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.24 KB, text/plain)
2012-02-05 09:13 UTC, luca.came93
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andregallus-andreas 2012-02-05 08:54:42 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I' ve started Muon Programmverwaltung and it crashed immidatly. I reinstalled kubuntu 11.10 one week ago. since this time it won't work.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77e9930 (LWP 3205))]

Thread 2 (Thread 0xb575fb70 (LWP 3206)):
#0  0x00babf39 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0x07dba87f in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x07dbb637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x07dbbc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0058cb37 in QEventDispatcherGlib::processEvents (this=0x96493c8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x0055d1dd in QEventLoop::processEvents (this=0xb575f2b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x0055d421 in QEventLoop::exec (this=0xb575f2b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x0046090b in QThread::exec (this=0x964a4a0) at thread/qthread.cpp:498
#8  0x0053de2d in QInotifyFileSystemWatcherEngine::run (this=0x964a4a0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x004637b3 in QThreadPrivate::start (arg=0x964a4a0) at thread/qthread_unix.cpp:331
#10 0x00856d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x00b9e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77e9930 (LWP 3205)):
[KCrash Handler]
#7  0x004b7e11 in QtPrivate::QStringList_contains (that=0xbfacd4c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfacd4c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x964b840) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x964b840, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfacd6e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00564b7d in metacall (argv=0xbfacd6e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x964b840) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x964b840, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfacd6e4) at kernel/qmetaobject.cpp:232
#13 0x00573a6a in QMetaObject::activate (sender=0x9791360, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9791360) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9791360, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfacd828) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00564b7d in metacall (argv=0xbfacd828, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9791360) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9791360, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfacd828) at kernel/qmetaobject.cpp:232
#18 0x00573a6a in QMetaObject::activate (sender=0x964b840, m=0x80950c0, local_signal_index=0, argv=0xbfacd828) at kernel/qobject.cpp:3278
#19 0x00cec7c5 in MuonMainWindow::backendReady (this=0x964b840, _t1=0x964c000) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00cec933 in MuonMainWindow::initObject (this=0x964b840) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x964b840) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x964b840, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfacd954) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00564b7d in metacall (argv=0xbfacd954, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x964b840) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x964b840, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfacd954) at kernel/qmetaobject.cpp:232
#25 0x00573a6a in QMetaObject::activate (sender=0x96996a8, m=0x694238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0057b375 in QSingleShotTimer::timeout (this=0x96996a8) at .moc/release-shared/qtimer.moc:82
#27 0x0057b42c in QSingleShotTimer::timerEvent (this=0x96996a8) at kernel/qtimer.cpp:308
#28 0x00576994 in QObject::event (this=0x96996a8, e=0xbfacdd4c) at kernel/qobject.cpp:1181
#29 0x033ebd84 in notify_helper (e=0xbfacdd4c, receiver=0x96996a8, this=0x953ef68) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x953ef68, receiver=0x96996a8, e=0xbfacdd4c) at kernel/qapplication.cpp:4458
#31 0x033f1133 in QApplication::notify (this=0xbfacdd4c, receiver=0x96996a8, e=0xbfacdd4c) at kernel/qapplication.cpp:3886
#32 0x00f07971 in KApplication::notify (this=0xbface060, receiver=0x96996a8, event=0xbfacdd4c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0055e19e in QCoreApplication::notifyInternal (this=0xbface060, receiver=0x96996a8, event=0xbfacdd4c) at kernel/qcoreapplication.cpp:787
#34 0x0058ec10 in sendEvent (event=0xbfacdd4c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x953a534) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0058c122 in timerSourceDispatch (source=0x953a500) at kernel/qeventdispatcher_glib.cpp:184
#37 0x07dbb25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x07dbb990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x07dbbc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0058cada in QEventDispatcherGlib::processEvents (this=0x951c238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x034a3e7a in QGuiEventDispatcherGlib::processEvents (this=0x951c238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0055d1dd in QEventLoop::processEvents (this=0xbfacdfc4, flags=...) at kernel/qeventloop.cpp:149
#43 0x0055d421 in QEventLoop::exec (this=0xbfacdfc4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0056219d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x033e9924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293341, bug 293328, bug 293322, bug 293258, bug 293257.

Reported using DrKonqi
Comment 1 luca.came93 2012-02-05 09:13:56 UTC
Created attachment 68519 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

The Muon Software Centre crashed when I opened it. I can't open it anymore.

-- Backtrace (Reduced):
#7  0xb71f7e11 in QtPrivate::QStringList_contains (that=0xbf827c74, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf827c74) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8a7aed8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8a7aed8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf827e94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb72a4b7d in metacall (argv=0xbf827e94, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8a7aed8) at kernel/qmetaobject.cpp:237
Comment 2 Jekyll Wu 2012-02-05 10:20:51 UTC

*** This bug has been marked as a duplicate of bug 291262 ***