Bug 293364 - Muon software installer crashes every time opened
Summary: Muon software installer crashes every time opened
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-05 14:17 UTC by Bill Alexander
Modified: 2012-02-14 22:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.25 KB, text/plain)
2012-02-14 22:37 UTC, ghouliass
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Alexander 2012-02-05 14:17:36 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
No further information available as doing nothing else at the time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb784b930 (LWP 10077))]

Thread 2 (Thread 0xb5b38b70 (LWP 10078)):
#0  0x00b03d9c in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x01ef0f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x01242933 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01242c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x00301b37 in QEventDispatcherGlib::processEvents (this=0x9a537d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x002d21dd in QEventLoop::processEvents (this=0xb5b382b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x002d2421 in QEventLoop::exec (this=0xb5b382b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x001d590b in QThread::exec (this=0x9a1bf88) at thread/qthread.cpp:498
#8  0x002b2e2d in QInotifyFileSystemWatcherEngine::run (this=0x9a1bf88) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x001d87b3 in QThreadPrivate::start (arg=0x9a1bf88) at thread/qthread_unix.cpp:331
#10 0x00b01d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x01ee30ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb784b930 (LWP 10077)):
[KCrash Handler]
#7  0x0022ce11 in QtPrivate::QStringList_contains (that=0xbfb0d184, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb0d184) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9a16e10) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9a16e10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb0d3a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x002d9b7d in metacall (argv=0xbfb0d3a4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9a16e10) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9a16e10, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb0d3a4) at kernel/qmetaobject.cpp:232
#13 0x002e8a6a in QMetaObject::activate (sender=0x9b5da00, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9b5da00) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9b5da00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb0d4e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x002d9b7d in metacall (argv=0xbfb0d4e8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9b5da00) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9b5da00, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb0d4e8) at kernel/qmetaobject.cpp:232
#18 0x002e8a6a in QMetaObject::activate (sender=0x9a16e10, m=0x80950c0, local_signal_index=0, argv=0xbfb0d4e8) at kernel/qobject.cpp:3278
#19 0x00c7c7c5 in MuonMainWindow::backendReady (this=0x9a16e10, _t1=0x9a1d3e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00c7c933 in MuonMainWindow::initObject (this=0x9a16e10) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9a16e10) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9a16e10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb0d614) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x002d9b7d in metacall (argv=0xbfb0d614, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9a16e10) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9a16e10, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb0d614) at kernel/qmetaobject.cpp:232
#25 0x002e8a6a in QMetaObject::activate (sender=0x9a78a18, m=0x409238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x002f0375 in QSingleShotTimer::timeout (this=0x9a78a18) at .moc/release-shared/qtimer.moc:82
#27 0x002f042c in QSingleShotTimer::timerEvent (this=0x9a78a18) at kernel/qtimer.cpp:308
#28 0x002eb994 in QObject::event (this=0x9a78a18, e=0xbfb0da0c) at kernel/qobject.cpp:1181
#29 0x057a3d84 in notify_helper (e=0xbfb0da0c, receiver=0x9a78a18, this=0x99169e0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x99169e0, receiver=0x9a78a18, e=0xbfb0da0c) at kernel/qapplication.cpp:4458
#31 0x057a9133 in QApplication::notify (this=0xbfb0da0c, receiver=0x9a78a18, e=0xbfb0da0c) at kernel/qapplication.cpp:3886
#32 0x00fac971 in KApplication::notify (this=0xbfb0dd20, receiver=0x9a78a18, event=0xbfb0da0c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x002d319e in QCoreApplication::notifyInternal (this=0xbfb0dd20, receiver=0x9a78a18, event=0xbfb0da0c) at kernel/qcoreapplication.cpp:787
#34 0x00303c10 in sendEvent (event=0xbfb0da0c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9911904) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00301122 in timerSourceDispatch (source=0x99118d0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0124225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01242990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01242c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00301ada in QEventDispatcherGlib::processEvents (this=0x98f2238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0585be7a in QGuiEventDispatcherGlib::processEvents (this=0x98f2238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x002d21dd in QEventLoop::processEvents (this=0xbfb0dc84, flags=...) at kernel/qeventloop.cpp:149
#43 0x002d2421 in QEventLoop::exec (this=0xbfb0dc84, flags=...) at kernel/qeventloop.cpp:201
#44 0x002d719d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x057a1924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293349, bug 293341, bug 293328, bug 293322, bug 293258.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-05 14:19:42 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 ghouliass 2012-02-14 22:37:29 UTC
Created attachment 68804 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

crash on start, but not when offline

-- Backtrace (Reduced):
#7  0x004f4e11 in QtPrivate::QStringList_contains (that=0xbffa8d04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffa8d04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x91fa748) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x91fa748, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffa8f24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x005a1b7d in metacall (argv=0xbffa8f24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x91fa748) at kernel/qmetaobject.cpp:237