Bug 293400 - Muon Software Crashing
Summary: Muon Software Crashing
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-05 23:52 UTC by Shemp
Modified: 2012-02-06 04:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shemp 2012-02-05 23:52:35 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I just installed Kubuntu. I had not installed video drivers yet, I forgot. I changed some effects settings, specifically Dim When Asking for Admin or something to that effect. The software update was running in the background. This hung. It never resumed. I tried to restart, it would not. I had to power down to get my system to go again.

- Custom settings of the application: See above. Nvidia driver now installed, the recommended one, not beta.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f16ebb0d780 (LWP 2451))]

Thread 2 (Thread 0x7f16d70e6700 (LWP 2454)):
#0  0x00007f16e86d8773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f16e4f4df68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f16e4f4e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f16ea896f3e in QEventDispatcherGlib::processEvents (this=0xde3740, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f16ea86acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f16ea86aef7 in QEventLoop::exec (this=0x7f16d70e5dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f16ea78227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f16ea84dcbf in QInotifyFileSystemWatcherEngine::run (this=0xdcc240) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f16ea784d05 in QThreadPrivate::start (arg=0xdcc240) at thread/qthread_unix.cpp:331
#9  0x00007f16e5a2fefc in start_thread (arg=0x7f16d70e6700) at pthread_create.c:304
#10 0x00007f16e86e489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f16ebb0d780 (LWP 2451)):
[KCrash Handler]
#6  0x00007f16ea7d2a5e in QtPrivate::QStringList_contains (that=0x7fff9d511810, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff9d511810) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xd66250) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xd66250, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9d511de0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f16ea87eeba in QMetaObject::activate (sender=0xe1aa70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xe1aa70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9d511f40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f16ea87eeba in QMetaObject::activate (sender=0xd66250, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9d511f40) at kernel/qobject.cpp:3278
#13 0x00007f16eb6f4e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xdd4d70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f16eb6f4f8e in MuonMainWindow::initObject (this=0xd66250) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xd66250) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xd66250, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9d512010) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f16ea87eeba in QMetaObject::activate (sender=0xe040d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f16ea886f7f in QSingleShotTimer::timerEvent (this=0xe040d0) at kernel/qtimer.cpp:308
#19 0x00007f16ea882789 in QObject::event (this=0xe040d0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f16e8ea5474 in notify_helper (e=0x7fff9d512580, receiver=0xe040d0, this=0xc2e660) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xc2e660, receiver=0xe040d0, e=0x7fff9d512580) at kernel/qapplication.cpp:4458
#22 0x00007f16e8eaa2e1 in QApplication::notify (this=0x7fff9d512880, receiver=0xe040d0, e=0x7fff9d512580) at kernel/qapplication.cpp:4365
#23 0x00007f16ea08a466 in KApplication::notify (this=0x7fff9d512880, receiver=0xe040d0, event=0x7fff9d512580) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f16ea86bafc in QCoreApplication::notifyInternal (this=0x7fff9d512880, receiver=0xe040d0, event=0x7fff9d512580) at kernel/qcoreapplication.cpp:787
#25 0x00007f16ea898d62 in sendEvent (event=0x7fff9d512580, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xc29bc0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f16ea896538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f16e4f4da5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f16e4f4e258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f16e4f4e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f16ea896ed6 in QEventDispatcherGlib::processEvents (this=0xc066f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f16e8f4d10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f16ea86acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f16ea86aef7 in QEventLoop::exec (this=0x7fff9d512810, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f16ea86f789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fff9d512af8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293373, bug 293372, bug 293364, bug 293349, bug 293341.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-06 04:50:02 UTC

*** This bug has been marked as a duplicate of bug 291262 ***