Bug 293373 - Muon crash at startup
Summary: Muon crash at startup
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-05 16:17 UTC by Jarl Friis
Modified: 2012-02-05 16:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jarl Friis 2012-02-05 16:17:11 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Just started the application.

I have justed installed Kubuntu 11.10

The crash can be reproduced every time.

-- Backtrace:
Application: Muon softwarecenter (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3e6a9b8780 (LWP 3577))]

Thread 2 (Thread 0x7f3e55ec5700 (LWP 3578)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f3e55ec4af0 in ?? ()
#2  0x00007fffa09fd7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f3e6a9b8780 (LWP 3577)):
[KCrash Handler]
#6  0x00007f3e6967ca5e in QtPrivate::QStringList_contains (that=0x7fffa08911a0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffa08911a0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xb9d150) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xb9d150, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa0891770) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f3e69728eba in QMetaObject::activate (sender=0xc628e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xc628e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa08918d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f3e69728eba in QMetaObject::activate (sender=0xb9d150, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa08918d0) at kernel/qobject.cpp:3278
#13 0x00007f3e6a59ee7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xc018e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f3e6a59ef8e in MuonMainWindow::initObject (this=0xb9d150) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xb9d150) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xb9d150, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa08919a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f3e69728eba in QMetaObject::activate (sender=0xc06360, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f3e69730f7f in QSingleShotTimer::timerEvent (this=0xc06360) at kernel/qtimer.cpp:308
#19 0x00007f3e6972c789 in QObject::event (this=0xc06360, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f3e67d4f474 in notify_helper (e=0x7fffa0891f10, receiver=0xc06360, this=0xa3d310) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xa3d310, receiver=0xc06360, e=0x7fffa0891f10) at kernel/qapplication.cpp:4458
#22 0x00007f3e67d542e1 in QApplication::notify (this=0x7fffa0892210, receiver=0xc06360, e=0x7fffa0891f10) at kernel/qapplication.cpp:4365
#23 0x00007f3e68f34466 in KApplication::notify (this=0x7fffa0892210, receiver=0xc06360, event=0x7fffa0891f10) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f3e69715afc in QCoreApplication::notifyInternal (this=0x7fffa0892210, receiver=0xc06360, event=0x7fffa0891f10) at kernel/qcoreapplication.cpp:787
#25 0x00007f3e69742d62 in sendEvent (event=0x7fffa0891f10, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xa40df0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f3e69740514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f3e63df7a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f3e63df8258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f3e63df8429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f3e69740ed6 in QEventDispatcherGlib::processEvents (this=0xa186f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f3e67df710e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f3e69714cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f3e69714ef7 in QEventLoop::exec (this=0x7fffa08921a0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f3e69719789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffa0892488) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 293372.

Possible duplicates by query: bug 293372, bug 293364, bug 293349, bug 293341, bug 293328.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-05 16:24:09 UTC

*** This bug has been marked as a duplicate of bug 291262 ***