Bug 293372 - Crash of Muon Programmverwaltung
Summary: Crash of Muon Programmverwaltung
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-05 16:12 UTC by comphei11
Modified: 2012-02-05 16:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description comphei11 2012-02-05 16:12:30 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Just started the programm, as wanted to look for a nother programm to install. I never could start the above mentioned program.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d0930 (LWP 3517))]

Thread 2 (Thread 0xb55e1b70 (LWP 3520)):
#0  0x00333d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00ad77d5 in do_gettime (frac=0xb55e1020, sec=0xb55e1018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00baa4b6 in QTimerInfoList::updateCurrentTime (this=0xb4c00abc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00baa80a in QTimerInfoList::timerWait (this=0xb4c00abc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00ba9053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb55e112c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00ba90ed in timerSourcePrepare (source=0xb4c00a88, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0635188c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x06352637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x06352c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00ba9b37 in QEventDispatcherGlib::processEvents (this=0x9b940d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00b7a1dd in QEventLoop::processEvents (this=0xb55e12b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00b7a421 in QEventLoop::exec (this=0xb55e12b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00a7d90b in QThread::exec (this=0x9c4d680) at thread/qthread.cpp:498
#14 0x00b5ae2d in QInotifyFileSystemWatcherEngine::run (this=0x9c4d680) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00a807b3 in QThreadPrivate::start (arg=0x9c4d680) at thread/qthread_unix.cpp:331
#16 0x07808d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x005130ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77d0930 (LWP 3517)):
[KCrash Handler]
#7  0x00ad4e11 in QtPrivate::QStringList_contains (that=0xbf8fc484, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8fc484) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9b06320) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9b06320, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8fc6a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00b81b7d in metacall (argv=0xbf8fc6a4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9b06320) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9b06320, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8fc6a4) at kernel/qmetaobject.cpp:232
#13 0x00b90a6a in QMetaObject::activate (sender=0x9b54c40, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9b54c40) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9b54c40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8fc7e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00b81b7d in metacall (argv=0xbf8fc7e8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9b54c40) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9b54c40, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8fc7e8) at kernel/qmetaobject.cpp:232
#18 0x00b90a6a in QMetaObject::activate (sender=0x9b06320, m=0x80950c0, local_signal_index=0, argv=0xbf8fc7e8) at kernel/qobject.cpp:3278
#19 0x0066b7c5 in MuonMainWindow::backendReady (this=0x9b06320, _t1=0x9b046c0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0066b933 in MuonMainWindow::initObject (this=0x9b06320) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9b06320) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9b06320, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8fc914) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00b81b7d in metacall (argv=0xbf8fc914, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9b06320) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9b06320, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf8fc914) at kernel/qmetaobject.cpp:232
#25 0x00b90a6a in QMetaObject::activate (sender=0x9b541d8, m=0xcb1238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00b98375 in QSingleShotTimer::timeout (this=0x9b541d8) at .moc/release-shared/qtimer.moc:82
#27 0x00b9842c in QSingleShotTimer::timerEvent (this=0x9b541d8) at kernel/qtimer.cpp:308
#28 0x00b93994 in QObject::event (this=0x9b541d8, e=0xbf8fcd0c) at kernel/qobject.cpp:1181
#29 0x04c8dd84 in notify_helper (e=0xbf8fcd0c, receiver=0x9b541d8, this=0x9a04188) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9a04188, receiver=0x9b541d8, e=0xbf8fcd0c) at kernel/qapplication.cpp:4458
#31 0x04c93133 in QApplication::notify (this=0xbf8fcd0c, receiver=0x9b541d8, e=0xbf8fcd0c) at kernel/qapplication.cpp:3886
#32 0x00e9d971 in KApplication::notify (this=0xbf8fd020, receiver=0x9b541d8, event=0xbf8fcd0c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00b7b19e in QCoreApplication::notifyInternal (this=0xbf8fd020, receiver=0x9b541d8, event=0xbf8fcd0c) at kernel/qcoreapplication.cpp:787
#34 0x00babc10 in sendEvent (event=0xbf8fcd0c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9a06634) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00ba9155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x9a06668) at kernel/qeventdispatcher_glib.cpp:231
#38 0x0635225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06352990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x06352c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x00ba9ada in QEventDispatcherGlib::processEvents (this=0x99e2238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0x04d45e7a in QGuiEventDispatcherGlib::processEvents (this=0x99e2238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00b7a1dd in QEventLoop::processEvents (this=0xbf8fcf84, flags=...) at kernel/qeventloop.cpp:149
#44 0x00b7a421 in QEventLoop::exec (this=0xbf8fcf84, flags=...) at kernel/qeventloop.cpp:201
#45 0x00b7f19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0x04c8b924 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293364, bug 293349, bug 293341, bug 293328, bug 293322.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-05 16:19:58 UTC

*** This bug has been marked as a duplicate of bug 291262 ***