Bug 293341 - Не работает muon-installer
Summary: Не работает muon-installer
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-05 03:31 UTC by Eugene
Modified: 2012-02-05 04:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene 2012-02-05 03:31:51 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

После установки системы, приложение muon зависло при первом же обновлении системы. После аварийного завершения работы приложения, не работает muon-installer . При его запуске на некоторое время появляется пустое окно программы, после чего оно закрывается и появляется окно мастреа сообщения об ошибке.

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f72bcd7e780 (LWP 6102))]

Thread 2 (Thread 0x7f72a804e700 (LWP 6106)):
#0  0x00007f72b9954773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f72b61c9f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f72b61ca429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f72bbb12f3e in QEventDispatcherGlib::processEvents (this=0x1101be0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f72bbae6cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f72bbae6ef7 in QEventLoop::exec (this=0x7f72a804ddd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f72bb9fe27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f72bbac9cbf in QInotifyFileSystemWatcherEngine::run (this=0x10ecad0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f72bba00d05 in QThreadPrivate::start (arg=0x10ecad0) at thread/qthread_unix.cpp:331
#9  0x00007f72b6cabefc in start_thread (arg=0x7f72a804e700) at pthread_create.c:304
#10 0x00007f72b996089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f72bcd7e780 (LWP 6102)):
[KCrash Handler]
#6  0x00007f72bba4ea5e in QtPrivate::QStringList_contains (that=0x7fff68d73e90, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff68d73e90) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1079a60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1079a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff68d74460) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f72bbafaeba in QMetaObject::activate (sender=0x109cc80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x109cc80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff68d745c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f72bbafaeba in QMetaObject::activate (sender=0x1079a60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff68d745c0) at kernel/qobject.cpp:3278
#13 0x00007f72bc970e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1070a30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f72bc970f8e in MuonMainWindow::initObject (this=0x1079a60) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1079a60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1079a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff68d74690) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f72bbafaeba in QMetaObject::activate (sender=0x1104330, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f72bbb02f7f in QSingleShotTimer::timerEvent (this=0x1104330) at kernel/qtimer.cpp:308
#19 0x00007f72bbafe789 in QObject::event (this=0x1104330, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f72ba121474 in notify_helper (e=0x7fff68d74c00, receiver=0x1104330, this=0xf08170) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xf08170, receiver=0x1104330, e=0x7fff68d74c00) at kernel/qapplication.cpp:4458
#22 0x00007f72ba1262e1 in QApplication::notify (this=0x7fff68d74f00, receiver=0x1104330, e=0x7fff68d74c00) at kernel/qapplication.cpp:4365
#23 0x00007f72bb306466 in KApplication::notify (this=0x7fff68d74f00, receiver=0x1104330, event=0x7fff68d74c00) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f72bbae7afc in QCoreApplication::notifyInternal (this=0x7fff68d74f00, receiver=0x1104330, event=0x7fff68d74c00) at kernel/qcoreapplication.cpp:787
#25 0x00007f72bbb14d62 in sendEvent (event=0x7fff68d74c00, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xf0d860) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f72bbb12538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f72b61c9a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f72b61ca258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f72b61ca429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f72bbb12ed6 in QEventDispatcherGlib::processEvents (this=0xee36f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f72ba1c910e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f72bbae6cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f72bbae6ef7 in QEventLoop::exec (this=0x7fff68d74e90, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f72bbaeb789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=1, argv=0x7fff68d75178) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 293328.

Possible duplicates by query: bug 293328, bug 293322, bug 293258, bug 293257, bug 293256.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-05 04:06:45 UTC

*** This bug has been marked as a duplicate of bug 291262 ***