Bug 293328 - Muon Software Center crashes at launch
Summary: Muon Software Center crashes at launch
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 22:27 UTC by pablo.barton
Modified: 2012-02-05 04:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pablo.barton 2012-02-04 22:27:35 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Before and after rebooting, Muon Software Center crashes when launched, before the contents of the window have been displayed. Other notable applications running were Dropbox, Chromium, Okular, and LibreOffice Impress.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76dd930 (LWP 3006))]

Thread 2 (Thread 0xb4450b70 (LWP 3012)):
#0  socketNotifierSourceCheck (source=0xa0daaa0) at kernel/qeventdispatcher_glib.cpp:83
#1  0x07c66f24 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x07c678f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x07c67c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0093eb37 in QEventDispatcherGlib::processEvents (this=0xa0cff90, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x0090f1dd in QEventLoop::processEvents (this=0xb44502b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x0090f421 in QEventLoop::exec (this=0xb44502b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x0081290b in QThread::exec (this=0xa0e7048) at thread/qthread.cpp:498
#8  0x008efe2d in QInotifyFileSystemWatcherEngine::run (this=0xa0e7048) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x008157b3 in QThreadPrivate::start (arg=0xa0e7048) at thread/qthread_unix.cpp:331
#10 0x00dddd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x00b1d0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76dd930 (LWP 3006)):
[KCrash Handler]
#7  0x00869e11 in QtPrivate::QStringList_contains (that=0xbfe0c6d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe0c6d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa05d9d8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa05d9d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe0c8f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00916b7d in metacall (argv=0xbfe0c8f4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa05d9d8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa05d9d8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe0c8f4) at kernel/qmetaobject.cpp:232
#13 0x00925a6a in QMetaObject::activate (sender=0x9fd79f0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9fd79f0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9fd79f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe0ca38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00916b7d in metacall (argv=0xbfe0ca38, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9fd79f0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9fd79f0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe0ca38) at kernel/qmetaobject.cpp:232
#18 0x00925a6a in QMetaObject::activate (sender=0xa05d9d8, m=0x80950c0, local_signal_index=0, argv=0xbfe0ca38) at kernel/qobject.cpp:3278
#19 0x007767c5 in MuonMainWindow::backendReady (this=0xa05d9d8, _t1=0xa0a8e88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00776933 in MuonMainWindow::initObject (this=0xa05d9d8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa05d9d8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa05d9d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe0cb64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00916b7d in metacall (argv=0xbfe0cb64, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa05d9d8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa05d9d8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe0cb64) at kernel/qmetaobject.cpp:232
#25 0x00925a6a in QMetaObject::activate (sender=0xa0d9a88, m=0xa46238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0092d375 in QSingleShotTimer::timeout (this=0xa0d9a88) at .moc/release-shared/qtimer.moc:82
#27 0x0092d42c in QSingleShotTimer::timerEvent (this=0xa0d9a88) at kernel/qtimer.cpp:308
#28 0x00928994 in QObject::event (this=0xa0d9a88, e=0xbfe0cf5c) at kernel/qobject.cpp:1181
#29 0x0475cd84 in notify_helper (e=0xbfe0cf5c, receiver=0xa0d9a88, this=0x9f753f0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9f753f0, receiver=0xa0d9a88, e=0xbfe0cf5c) at kernel/qapplication.cpp:4458
#31 0x04762133 in QApplication::notify (this=0xbfe0cf5c, receiver=0xa0d9a88, e=0xbfe0cf5c) at kernel/qapplication.cpp:3886
#32 0x01020971 in KApplication::notify (this=0xbfe0d270, receiver=0xa0d9a88, event=0xbfe0cf5c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0091019e in QCoreApplication::notifyInternal (this=0xbfe0d270, receiver=0xa0d9a88, event=0xbfe0cf5c) at kernel/qcoreapplication.cpp:787
#34 0x00940c10 in sendEvent (event=0xbfe0cf5c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9f73bb4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0093e122 in timerSourceDispatch (source=0x9f73b80) at kernel/qeventdispatcher_glib.cpp:184
#37 0x07c6725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x07c67990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x07c67c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0093eada in QEventDispatcherGlib::processEvents (this=0x9f53238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x04814e7a in QGuiEventDispatcherGlib::processEvents (this=0x9f53238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0090f1dd in QEventLoop::processEvents (this=0xbfe0d1d4, flags=...) at kernel/qeventloop.cpp:149
#43 0x0090f421 in QEventLoop::exec (this=0xbfe0d1d4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0091419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0475a924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 293322, bug 293258, bug 293257, bug 293256, bug 293245.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-05 04:09:23 UTC

*** This bug has been marked as a duplicate of bug 291262 ***