Bug 293322 - Crash of application
Summary: Crash of application
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 20:36 UTC by Jan Prekop
Modified: 2012-02-04 21:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Prekop 2012-02-04 20:36:24 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
I installed Kubuntu on my laptop, I updated the system by command "sudo apt-get update" and when I want to use Muon software center, the application crash. I tried to start this application several times but I had equal behaviour

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78ae930 (LWP 1993))]

Thread 2 (Thread 0xb5a8db70 (LWP 1994)):
#0  0x006eed10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00cd47d5 in do_gettime (frac=0xb5a8d020, sec=0xb5a8d018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00da74b6 in QTimerInfoList::updateCurrentTime (this=0x86b2eb4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00da780a in QTimerInfoList::timerWait (this=0x86b2eb4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00da6053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5a8d12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00da60ed in timerSourcePrepare (source=0x86b2e80, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x06ed888c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x06ed9637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x06ed9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00da6b37 in QEventDispatcherGlib::processEvents (this=0x868dcd0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00d771dd in QEventLoop::processEvents (this=0xb5a8d2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00d77421 in QEventLoop::exec (this=0xb5a8d2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00c7a90b in QThread::exec (this=0x8632710) at thread/qthread.cpp:498
#14 0x00d57e2d in QInotifyFileSystemWatcherEngine::run (this=0x8632710) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00c7d7b3 in QThreadPrivate::start (arg=0x8632710) at thread/qthread_unix.cpp:331
#16 0x00678d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x003520ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78ae930 (LWP 1993)):
[KCrash Handler]
#7  0x00cd1e11 in QtPrivate::QStringList_contains (that=0xbffcceb4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffcceb4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8622fb8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8622fb8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffcd0d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00d7eb7d in metacall (argv=0xbffcd0d4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8622fb8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8622fb8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbffcd0d4) at kernel/qmetaobject.cpp:232
#13 0x00d8da6a in QMetaObject::activate (sender=0x86b02a0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x86b02a0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x86b02a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffcd218) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00d7eb7d in metacall (argv=0xbffcd218, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x86b02a0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x86b02a0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbffcd218) at kernel/qmetaobject.cpp:232
#18 0x00d8da6a in QMetaObject::activate (sender=0x8622fb8, m=0x80950c0, local_signal_index=0, argv=0xbffcd218) at kernel/qobject.cpp:3278
#19 0x0024c7c5 in MuonMainWindow::backendReady (this=0x8622fb8, _t1=0x865a2d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0024c933 in MuonMainWindow::initObject (this=0x8622fb8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8622fb8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8622fb8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffcd344) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00d7eb7d in metacall (argv=0xbffcd344, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8622fb8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8622fb8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbffcd344) at kernel/qmetaobject.cpp:232
#25 0x00d8da6a in QMetaObject::activate (sender=0x8687f70, m=0xeae238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00d95375 in QSingleShotTimer::timeout (this=0x8687f70) at .moc/release-shared/qtimer.moc:82
#27 0x00d9542c in QSingleShotTimer::timerEvent (this=0x8687f70) at kernel/qtimer.cpp:308
#28 0x00d90994 in QObject::event (this=0x8687f70, e=0xbffcd73c) at kernel/qobject.cpp:1181
#29 0x0756ed84 in notify_helper (e=0xbffcd73c, receiver=0x8687f70, this=0x851e8f8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x851e8f8, receiver=0x8687f70, e=0xbffcd73c) at kernel/qapplication.cpp:4458
#31 0x07574133 in QApplication::notify (this=0xbffcd73c, receiver=0x8687f70, e=0xbffcd73c) at kernel/qapplication.cpp:3886
#32 0x010bb971 in KApplication::notify (this=0xbffcda50, receiver=0x8687f70, event=0xbffcd73c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00d7819e in QCoreApplication::notifyInternal (this=0xbffcda50, receiver=0x8687f70, event=0xbffcd73c) at kernel/qcoreapplication.cpp:787
#34 0x00da8c10 in sendEvent (event=0xbffcd73c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8525b04) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00da6122 in timerSourceDispatch (source=0x8525ad0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x06ed925f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06ed9990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06ed9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00da6ada in QEventDispatcherGlib::processEvents (this=0x8501238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x07626e7a in QGuiEventDispatcherGlib::processEvents (this=0x8501238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00d771dd in QEventLoop::processEvents (this=0xbffcd9b4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00d77421 in QEventLoop::exec (this=0xbffcd9b4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00d7c19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0756c924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293258, bug 293257, bug 293256, bug 293245, bug 293238.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-04 21:17:29 UTC

*** This bug has been marked as a duplicate of bug 291262 ***