Bug 293015 - Muon crashes every time
Summary: Muon crashes every time
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-01 02:28 UTC by Denis
Modified: 2012-02-01 02:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis 2012-02-01 02:28:15 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-13-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- Unusual behavior I noticed: I have a plasmoid that used to connect to Internet eache time I start Kubuntu but since a few days, it reports that it takes too long to connect, which it never did before

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7743930 (LWP 2707))]

Thread 2 (Thread 0xb5517b70 (LWP 2708)):
#0  0x07509de3 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00b89f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x04e4ff53 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x04e508f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x04e50c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00865b37 in QEventDispatcherGlib::processEvents (this=0x9f89008, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x008361dd in QEventLoop::processEvents (this=0xb55172b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00836421 in QEventLoop::exec (this=0xb55172b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0073990b in QThread::exec (this=0x9f6faf8) at thread/qthread.cpp:498
#9  0x00816e2d in QInotifyFileSystemWatcherEngine::run (this=0x9f6faf8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0073c7b3 in QThreadPrivate::start (arg=0x9f6faf8) at thread/qthread_unix.cpp:331
#11 0x07507d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00b7c0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7743930 (LWP 2707)):
[KCrash Handler]
#7  0x00790e11 in QtPrivate::QStringList_contains (that=0xbffe40c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffe40c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9f28300) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9f28300, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffe42e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0083db7d in metacall (argv=0xbffe42e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9f28300) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9f28300, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbffe42e4) at kernel/qmetaobject.cpp:232
#13 0x0084ca6a in QMetaObject::activate (sender=0x9f733d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9f733d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9f733d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffe4428) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0083db7d in metacall (argv=0xbffe4428, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9f733d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9f733d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbffe4428) at kernel/qmetaobject.cpp:232
#18 0x0084ca6a in QMetaObject::activate (sender=0x9f28300, m=0x80950c0, local_signal_index=0, argv=0xbffe4428) at kernel/qobject.cpp:3278
#19 0x0014b7c5 in MuonMainWindow::backendReady (this=0x9f28300, _t1=0x9e97430) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0014b933 in MuonMainWindow::initObject (this=0x9f28300) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9f28300) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9f28300, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffe4554) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0083db7d in metacall (argv=0xbffe4554, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9f28300) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9f28300, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbffe4554) at kernel/qmetaobject.cpp:232
#25 0x0084ca6a in QMetaObject::activate (sender=0x9f8ca98, m=0x96d238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00854375 in QSingleShotTimer::timeout (this=0x9f8ca98) at .moc/release-shared/qtimer.moc:82
#27 0x0085442c in QSingleShotTimer::timerEvent (this=0x9f8ca98) at kernel/qtimer.cpp:308
#28 0x0084f994 in QObject::event (this=0x9f8ca98, e=0xbffe494c) at kernel/qobject.cpp:1181
#29 0x02599d84 in notify_helper (e=0xbffe494c, receiver=0x9f8ca98, this=0x9e194f0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9e194f0, receiver=0x9f8ca98, e=0xbffe494c) at kernel/qapplication.cpp:4458
#31 0x0259f133 in QApplication::notify (this=0xbffe494c, receiver=0x9f8ca98, e=0xbffe494c) at kernel/qapplication.cpp:3886
#32 0x01161971 in KApplication::notify (this=0xbffe4c60, receiver=0x9f8ca98, event=0xbffe494c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0083719e in QCoreApplication::notifyInternal (this=0xbffe4c60, receiver=0x9f8ca98, event=0xbffe494c) at kernel/qcoreapplication.cpp:787
#34 0x00867c10 in sendEvent (event=0xbffe494c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9e15734) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00865122 in timerSourceDispatch (source=0x9e15700) at kernel/qeventdispatcher_glib.cpp:184
#37 0x04e5025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x04e50990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x04e50c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00865ada in QEventDispatcherGlib::processEvents (this=0x9df6238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02651e7a in QGuiEventDispatcherGlib::processEvents (this=0x9df6238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x008361dd in QEventLoop::processEvents (this=0xbffe4bc4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00836421 in QEventLoop::exec (this=0xbffe4bc4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0083b19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02597924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292987, bug 292984, bug 292980, bug 292920, bug 292901.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-01 02:38:26 UTC

*** This bug has been marked as a duplicate of bug 291262 ***