Bug 292818 - muon crash after start
Summary: muon crash after start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-29 19:21 UTC by Marc
Modified: 2012-01-30 06:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.73 KB, text/plain)
2012-01-30 06:41 UTC, Ehs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc 2012-01-29 19:21:53 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: open for 5 second the application-window then crash the window and the programm

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc221d0f780 (LWP 2009))]

Thread 2 (Thread 0x7fc20d1d6700 (LWP 2010)):
#0  0x00007fc21b11fe30 in g_ptr_array_set_size () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fc21b14af06 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc21b14bdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc21b14c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc220a94f3e in QEventDispatcherGlib::processEvents (this=0x16c5b80, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fc220a68cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fc220a68ef7 in QEventLoop::exec (this=0x7fc20d1d5dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fc22098027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007fc220a4bcbf in QInotifyFileSystemWatcherEngine::run (this=0x1669530) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fc220982d05 in QThreadPrivate::start (arg=0x1669530) at thread/qthread_unix.cpp:331
#10 0x00007fc21bc2defc in start_thread (arg=0x7fc20d1d6700) at pthread_create.c:304
#11 0x00007fc21e8e289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc221d0f780 (LWP 2009)):
[KCrash Handler]
#6  0x00007fc2209d0a5e in QtPrivate::QStringList_contains (that=0x7fff602b5e50, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff602b5e50) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1653230) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1653230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff602b6420) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fc220a7ceba in QMetaObject::activate (sender=0x1811a60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1811a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff602b6580) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fc220a7ceba in QMetaObject::activate (sender=0x1653230, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff602b6580) at kernel/qobject.cpp:3278
#13 0x00007fc2218f2e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x164a670) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fc2218f2f8e in MuonMainWindow::initObject (this=0x1653230) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1653230) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1653230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff602b6650) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fc220a7ceba in QMetaObject::activate (sender=0x16b96f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fc220a84f7f in QSingleShotTimer::timerEvent (this=0x16b96f0) at kernel/qtimer.cpp:308
#19 0x00007fc220a80789 in QObject::event (this=0x16b96f0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fc21f0a3474 in notify_helper (e=0x7fff602b6bc0, receiver=0x16b96f0, this=0x14e8c10) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x14e8c10, receiver=0x16b96f0, e=0x7fff602b6bc0) at kernel/qapplication.cpp:4458
#22 0x00007fc21f0a82e1 in QApplication::notify (this=0x7fff602b6ec0, receiver=0x16b96f0, e=0x7fff602b6bc0) at kernel/qapplication.cpp:4365
#23 0x00007fc220288466 in KApplication::notify (this=0x7fff602b6ec0, receiver=0x16b96f0, event=0x7fff602b6bc0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fc220a69afc in QCoreApplication::notifyInternal (this=0x7fff602b6ec0, receiver=0x16b96f0, event=0x7fff602b6bc0) at kernel/qcoreapplication.cpp:787
#25 0x00007fc220a96d62 in sendEvent (event=0x7fff602b6bc0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x14e5820) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fc220a94514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fc21b14ba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fc21b14c258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fc21b14c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fc220a94ed6 in QEventDispatcherGlib::processEvents (this=0x14c06f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fc21f14b10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fc220a68cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fc220a68ef7 in QEventLoop::exec (this=0x7fff602b6e50, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fc220a6d789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff602b7138) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292793, bug 292769, bug 292748, bug 292734, bug 292671.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-29 19:28:20 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Ehs 2012-01-30 06:41:12 UTC
Created attachment 68328 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Opened Muon Software centre and it crashed immediately

-- Backtrace (Reduced):
#6  0x00007f6e40b38a5e in QtPrivate::QStringList_contains (that=0x7fff65d3f690, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff65d3f690) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xa9a4c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xa9a4c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff65d3fc60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x936a10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff65d3fdc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109