Bug 292793 - l'application Muon logitheque ne demarre pas, plantage permanent
Summary: l'application Muon logitheque ne demarre pas, plantage permanent
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-29 13:27 UTC by e_touitou
Modified: 2012-01-29 13:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description e_touitou 2012-01-29 13:27:08 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Apres mise à jour linux en 3.0016 j'ai constaté que Muon ne démarre plus.
Le probleme est constant.

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4844930 (LWP 11656))]

Thread 2 (Thread 0xb1e2eb70 (LWP 11657)):
#0  0xb5391d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb726d7d5 in do_gettime (frac=0xb1e2e020, sec=0xb1e2e018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb73404b6 in QTimerInfoList::updateCurrentTime (this=0x9f36fb4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb734080a in QTimerInfoList::timerWait (this=0x9f36fb4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb733f053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb1e2e12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb733f0ed in timerSourcePrepare (source=0x9f36f80, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb52d788c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb52d8637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb52d8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb733fb37 in QEventDispatcherGlib::processEvents (this=0x9eff940, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb73101dd in QEventLoop::processEvents (this=0xb1e2e2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb7310421 in QEventLoop::exec (this=0xb1e2e2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb721390b in QThread::exec (this=0x9eadc48) at thread/qthread.cpp:498
#14 0xb72f0e2d in QInotifyFileSystemWatcherEngine::run (this=0x9eadc48) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb72167b3 in QThreadPrivate::start (arg=0x9eadc48) at thread/qthread_unix.cpp:331
#16 0xb53bed31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5e0b0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb4844930 (LWP 11656)):
[KCrash Handler]
#7  0xb726ae11 in QtPrivate::QStringList_contains (that=0xbf991b24, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf991b24) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9e9e230) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9e9e230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf991d44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7317b7d in metacall (argv=0xbf991d44, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9e9e230) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9e9e230, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf991d44) at kernel/qmetaobject.cpp:232
#13 0xb7326a6a in QMetaObject::activate (sender=0x9ff3148, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9ff3148) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9ff3148, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf991e88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7317b7d in metacall (argv=0xbf991e88, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9ff3148) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9ff3148, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf991e88) at kernel/qmetaobject.cpp:232
#18 0xb7326a6a in QMetaObject::activate (sender=0x9e9e230, m=0x80950c0, local_signal_index=0, argv=0xbf991e88) at kernel/qobject.cpp:3278
#19 0xb77877c5 in MuonMainWindow::backendReady (this=0x9e9e230, _t1=0x9eae610) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb7787933 in MuonMainWindow::initObject (this=0x9e9e230) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9e9e230) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9e9e230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf991fb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7317b7d in metacall (argv=0xbf991fb4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9e9e230) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9e9e230, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf991fb4) at kernel/qmetaobject.cpp:232
#25 0xb7326a6a in QMetaObject::activate (sender=0x9f0efe8, m=0xb7447238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb732e375 in QSingleShotTimer::timeout (this=0x9f0efe8) at .moc/release-shared/qtimer.moc:82
#27 0xb732e42c in QSingleShotTimer::timerEvent (this=0x9f0efe8) at kernel/qtimer.cpp:308
#28 0xb7329994 in QObject::event (this=0x9f0efe8, e=0xbf9923ac) at kernel/qobject.cpp:1181
#29 0xb60f7d84 in notify_helper (e=0xbf9923ac, receiver=0x9f0efe8, this=0x9da6b48) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9da6b48, receiver=0x9f0efe8, e=0xbf9923ac) at kernel/qapplication.cpp:4458
#31 0xb60fd133 in QApplication::notify (this=0xbf9923ac, receiver=0x9f0efe8, e=0xbf9923ac) at kernel/qapplication.cpp:3886
#32 0xb6f16971 in KApplication::notify (this=0xbf9926c0, receiver=0x9f0efe8, event=0xbf9923ac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb731119e in QCoreApplication::notifyInternal (this=0xbf9926c0, receiver=0x9f0efe8, event=0xbf9923ac) at kernel/qcoreapplication.cpp:787
#34 0xb7341c10 in sendEvent (event=0xbf9923ac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9da2e34) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb733f122 in timerSourceDispatch (source=0x9da2e00) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb52d825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb52d8990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb52d8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb733fada in QEventDispatcherGlib::processEvents (this=0x9d84238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb61afe7a in QGuiEventDispatcherGlib::processEvents (this=0x9d84238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb73101dd in QEventLoop::processEvents (this=0xbf992624, flags=...) at kernel/qeventloop.cpp:149
#43 0xb7310421 in QEventLoop::exec (this=0xbf992624, flags=...) at kernel/qeventloop.cpp:201
#44 0xb731519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb60f5924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292769, bug 292748, bug 292734, bug 292671, bug 292662.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-29 13:28:06 UTC

*** This bug has been marked as a duplicate of bug 291262 ***