Bug 292748 - crash of program manager
Summary: crash of program manager
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-29 04:29 UTC by moosavy
Modified: 2012-01-29 04:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description moosavy 2012-01-29 04:29:57 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
I can't open program manager; it crashes every time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7861930 (LWP 2376))]

Thread 2 (Thread 0xb5b83b70 (LWP 2377)):
#0  0x008e8d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x006157d5 in do_gettime (frac=0xb5b83020, sec=0xb5b83018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x006e84b6 in QTimerInfoList::updateCurrentTime (this=0x9833cc4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x006e880a in QTimerInfoList::timerWait (this=0x9833cc4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x006e7053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5b8312c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x006e70ed in timerSourcePrepare (source=0x9833c90, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x014a788c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x014a8637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x014a8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x006e7b37 in QEventDispatcherGlib::processEvents (this=0x97f1458, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x006b81dd in QEventLoop::processEvents (this=0xb5b832b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x006b8421 in QEventLoop::exec (this=0xb5b832b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x005bb90b in QThread::exec (this=0x97e4b08) at thread/qthread.cpp:498
#14 0x00698e2d in QInotifyFileSystemWatcherEngine::run (this=0x97e4b08) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x005be7b3 in QThreadPrivate::start (arg=0x97e4b08) at thread/qthread_unix.cpp:331
#16 0x00f36d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00dfc0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7861930 (LWP 2376)):
[KCrash Handler]
#7  0x00612e11 in QtPrivate::QStringList_contains (that=0xbfc24944, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc24944) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x981b738) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x981b738, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc24b64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x006bfb7d in metacall (argv=0xbfc24b64, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x981b738) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x981b738, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc24b64) at kernel/qmetaobject.cpp:232
#13 0x006cea6a in QMetaObject::activate (sender=0x984d9d0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x984d9d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x984d9d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc24ca8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x006bfb7d in metacall (argv=0xbfc24ca8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x984d9d0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x984d9d0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc24ca8) at kernel/qmetaobject.cpp:232
#18 0x006cea6a in QMetaObject::activate (sender=0x981b738, m=0x80950c0, local_signal_index=0, argv=0xbfc24ca8) at kernel/qobject.cpp:3278
#19 0x00f747c5 in MuonMainWindow::backendReady (this=0x981b738, _t1=0x981e4d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00f74933 in MuonMainWindow::initObject (this=0x981b738) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x981b738) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x981b738, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc24dd4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x006bfb7d in metacall (argv=0xbfc24dd4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x981b738) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x981b738, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc24dd4) at kernel/qmetaobject.cpp:232
#25 0x006cea6a in QMetaObject::activate (sender=0x9859788, m=0x7ef238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x006d6375 in QSingleShotTimer::timeout (this=0x9859788) at .moc/release-shared/qtimer.moc:82
#27 0x006d642c in QSingleShotTimer::timerEvent (this=0x9859788) at kernel/qtimer.cpp:308
#28 0x006d1994 in QObject::event (this=0x9859788, e=0xbfc251cc) at kernel/qobject.cpp:1181
#29 0x06ac2d84 in notify_helper (e=0xbfc251cc, receiver=0x9859788, this=0x97105a8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x97105a8, receiver=0x9859788, e=0xbfc251cc) at kernel/qapplication.cpp:4458
#31 0x06ac8133 in QApplication::notify (this=0xbfc251cc, receiver=0x9859788, e=0xbfc251cc) at kernel/qapplication.cpp:3886
#32 0x00ad7971 in KApplication::notify (this=0xbfc254e0, receiver=0x9859788, event=0xbfc251cc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x006b919e in QCoreApplication::notifyInternal (this=0xbfc254e0, receiver=0x9859788, event=0xbfc251cc) at kernel/qcoreapplication.cpp:787
#34 0x006e9c10 in sendEvent (event=0xbfc251cc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9710e94) at kernel/qeventdispatcher_unix.cpp:603
#36 0x006e7122 in timerSourceDispatch (source=0x9710e60) at kernel/qeventdispatcher_glib.cpp:184
#37 0x014a825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x014a8990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x014a8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x006e7ada in QEventDispatcherGlib::processEvents (this=0x96f3238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x06b7ae7a in QGuiEventDispatcherGlib::processEvents (this=0x96f3238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x006b81dd in QEventLoop::processEvents (this=0xbfc25444, flags=...) at kernel/qeventloop.cpp:149
#43 0x006b8421 in QEventLoop::exec (this=0xbfc25444, flags=...) at kernel/qeventloop.cpp:201
#44 0x006bd19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x06ac0924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292734, bug 292671, bug 292662, bug 292651, bug 292641.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-29 04:34:36 UTC

*** This bug has been marked as a duplicate of bug 291262 ***