Bug 292769 - Muon Sotware Center
Summary: Muon Sotware Center
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-29 09:13 UTC by manjadanijel
Modified: 2012-01-29 10:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description manjadanijel 2012-01-29 09:13:11 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I ve just startet that, nothing else. And it happens all the time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0991b20780 (LWP 1725))]

Thread 2 (Thread 0x7f097d0f8700 (LWP 1729)):
#0  0x00007f098e6ea773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f098af5ff68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f098af60429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f09908a8f3e in QEventDispatcherGlib::processEvents (this=0x218cc20, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f099087ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f099087cef7 in QEventLoop::exec (this=0x7f097d0f7dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f099079427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f099085fcbf in QInotifyFileSystemWatcherEngine::run (this=0x22946f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f0990796d05 in QThreadPrivate::start (arg=0x22946f0) at thread/qthread_unix.cpp:331
#9  0x00007f098ba41efc in start_thread (arg=0x7f097d0f8700) at pthread_create.c:304
#10 0x00007f098e6f689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0991b20780 (LWP 1725)):
[KCrash Handler]
#6  0x00007f09907e4a5e in QtPrivate::QStringList_contains (that=0x7fff6ccd1b40, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff6ccd1b40) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x20c6cc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x20c6cc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6ccd2110) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f0990890eba in QMetaObject::activate (sender=0x21410a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x21410a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6ccd2270) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f0990890eba in QMetaObject::activate (sender=0x20c6cc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6ccd2270) at kernel/qobject.cpp:3278
#13 0x00007f0991706e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x2118870) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f0991706f8e in MuonMainWindow::initObject (this=0x20c6cc0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x20c6cc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x20c6cc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6ccd2340) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f0990890eba in QMetaObject::activate (sender=0x2150b60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f0990898f7f in QSingleShotTimer::timerEvent (this=0x2150b60) at kernel/qtimer.cpp:308
#19 0x00007f0990894789 in QObject::event (this=0x2150b60, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f098eeb7474 in notify_helper (e=0x7fff6ccd28b0, receiver=0x2150b60, this=0x1f6d720) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1f6d720, receiver=0x2150b60, e=0x7fff6ccd28b0) at kernel/qapplication.cpp:4458
#22 0x00007f098eebc2e1 in QApplication::notify (this=0x7fff6ccd2bb0, receiver=0x2150b60, e=0x7fff6ccd28b0) at kernel/qapplication.cpp:4365
#23 0x00007f099009c466 in KApplication::notify (this=0x7fff6ccd2bb0, receiver=0x2150b60, event=0x7fff6ccd28b0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f099087dafc in QCoreApplication::notifyInternal (this=0x7fff6ccd2bb0, receiver=0x2150b60, event=0x7fff6ccd28b0) at kernel/qcoreapplication.cpp:787
#25 0x00007f09908aad62 in sendEvent (event=0x7fff6ccd28b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1f68f70) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f09908a8538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f098af5fa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f098af60258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f098af60429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f09908a8ed6 in QEventDispatcherGlib::processEvents (this=0x1f456f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f098ef5f10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f099087ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f099087cef7 in QEventLoop::exec (this=0x7fff6ccd2b40, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f0990881789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fff6ccd2e28) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292748, bug 292734, bug 292671, bug 292662, bug 292651.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-29 10:24:06 UTC

*** This bug has been marked as a duplicate of bug 291262 ***