Bug 292671 - Muhon
Summary: Muhon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-28 09:52 UTC by sylvie
Modified: 2012-01-28 10:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sylvie 2012-01-28 09:52:22 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- Custom settings of the application:

The windows is oppening when it is crashed Please help-me§
La fenêtre de Muhon s'est ouverte; puis  s'est craché

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7763930 (LWP 2515))]

Thread 2 (Thread 0xb4010b70 (LWP 2521)):
#0  0x00d0cee1 in pthread_mutex_lock (mutex=0x8d0abbc) at forward.c:182
#1  0x064e4c13 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x00a22b37 in QEventDispatcherGlib::processEvents (this=0x8d2c868, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#3  0x009f31dd in QEventLoop::processEvents (this=0xb40102b0, flags=...) at kernel/qeventloop.cpp:149
#4  0x009f3421 in QEventLoop::exec (this=0xb40102b0, flags=...) at kernel/qeventloop.cpp:201
#5  0x008f690b in QThread::exec (this=0x8d41190) at thread/qthread.cpp:498
#6  0x009d3e2d in QInotifyFileSystemWatcherEngine::run (this=0x8d41190) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x008f97b3 in QThreadPrivate::start (arg=0x8d41190) at thread/qthread_unix.cpp:331
#8  0x00b35d31 in start_thread (arg=0xb4010b70) at pthread_create.c:304
#9  0x00cff0ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7763930 (LWP 2515)):
[KCrash Handler]
#7  0x0094de11 in QtPrivate::QStringList_contains (that=0xbfda79e4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfda79e4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8c9c720) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8c9c720, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfda7c04) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x009fab7d in metacall (argv=0xbfda7c04, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8c9c720) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8c9c720, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfda7c04) at kernel/qmetaobject.cpp:232
#13 0x00a09a6a in QMetaObject::activate (sender=0x8c5f790, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8c5f790) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8c5f790, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfda7d48) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x009fab7d in metacall (argv=0xbfda7d48, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8c5f790) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8c5f790, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfda7d48) at kernel/qmetaobject.cpp:232
#18 0x00a09a6a in QMetaObject::activate (sender=0x8c9c720, m=0x80950c0, local_signal_index=0, argv=0xbfda7d48) at kernel/qobject.cpp:3278
#19 0x00e797c5 in MuonMainWindow::backendReady (this=0x8c9c720, _t1=0x8c11d70) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00e79933 in MuonMainWindow::initObject (this=0x8c9c720) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8c9c720) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8c9c720, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfda7e74) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x009fab7d in metacall (argv=0xbfda7e74, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8c9c720) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8c9c720, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfda7e74) at kernel/qmetaobject.cpp:232
#25 0x00a09a6a in QMetaObject::activate (sender=0x8d38950, m=0xb2a238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00a11375 in QSingleShotTimer::timeout (this=0x8d38950) at .moc/release-shared/qtimer.moc:82
#27 0x00a1142c in QSingleShotTimer::timerEvent (this=0x8d38950) at kernel/qtimer.cpp:308
#28 0x00a0c994 in QObject::event (this=0x8d38950, e=0xbfda826c) at kernel/qobject.cpp:1181
#29 0x08200d84 in notify_helper (e=0xbfda826c, receiver=0x8d38950, this=0x8b9fde8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8b9fde8, receiver=0x8d38950, e=0xbfda826c) at kernel/qapplication.cpp:4458
#31 0x08206133 in QApplication::notify (this=0xbfda826c, receiver=0x8d38950, e=0xbfda826c) at kernel/qapplication.cpp:3886
#32 0x01094971 in KApplication::notify (this=0xbfda8580, receiver=0x8d38950, event=0xbfda826c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x009f419e in QCoreApplication::notifyInternal (this=0xbfda8580, receiver=0x8d38950, event=0xbfda826c) at kernel/qcoreapplication.cpp:787
#34 0x00a24c10 in sendEvent (event=0xbfda826c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8ba1ec4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00a22122 in timerSourceDispatch (source=0x8ba1e90) at kernel/qeventdispatcher_glib.cpp:184
#37 0x064e425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x064e4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x064e4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00a22ada in QEventDispatcherGlib::processEvents (this=0x8b82238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x082b8e7a in QGuiEventDispatcherGlib::processEvents (this=0x8b82238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009f31dd in QEventLoop::processEvents (this=0xbfda84e4, flags=...) at kernel/qeventloop.cpp:149
#43 0x009f3421 in QEventLoop::exec (this=0xbfda84e4, flags=...) at kernel/qeventloop.cpp:201
#44 0x009f819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x081fe924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292662, bug 292651, bug 292641, bug 292599, bug 292556.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-28 10:19:59 UTC

*** This bug has been marked as a duplicate of bug 291262 ***