Bug 292734 - Muon & Kaffeine
Summary: Muon & Kaffeine
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-28 23:22 UTC by Hugi
Modified: 2012-01-29 12:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hugi 2012-01-28 23:22:17 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Je tentais d'ouvrir le gestionnaire Muon. Le lecteur Kaffeine était également visible.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f229229e780 (LWP 2256))]

Thread 2 (Thread 0x7f227d34e700 (LWP 2260)):
#0  0x00007f228ee77773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f228b6ecf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f228b6ed429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2291035f3e in QEventDispatcherGlib::processEvents (this=0x1296390, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f2291009cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2291009ef7 in QEventLoop::exec (this=0x7f227d34ddd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f2290f2127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f2290feccbf in QInotifyFileSystemWatcherEngine::run (this=0x120a810) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2290f23d05 in QThreadPrivate::start (arg=0x120a810) at thread/qthread_unix.cpp:331
#9  0x00007f228c1ceefc in start_thread (arg=0x7f227d34e700) at pthread_create.c:304
#10 0x00007f228ee8389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f229229e780 (LWP 2256)):
[KCrash Handler]
#6  0x00007f2290f71a5e in QtPrivate::QStringList_contains (that=0x7fff0a1bfe00, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff0a1bfe00) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x11bdb80) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x11bdb80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0a1c03d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f229101deba in QMetaObject::activate (sender=0x11e1520, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x11e1520, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0a1c0530) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f229101deba in QMetaObject::activate (sender=0x11bdb80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff0a1c0530) at kernel/qobject.cpp:3278
#13 0x00007f2291e93e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1209d90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f2291e93f8e in MuonMainWindow::initObject (this=0x11bdb80) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x11bdb80) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x11bdb80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0a1c0600) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f229101deba in QMetaObject::activate (sender=0x1260130, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f2291025f7f in QSingleShotTimer::timerEvent (this=0x1260130) at kernel/qtimer.cpp:308
#19 0x00007f2291021789 in QObject::event (this=0x1260130, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f228f644474 in notify_helper (e=0x7fff0a1c0b70, receiver=0x1260130, this=0x1045860) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1045860, receiver=0x1260130, e=0x7fff0a1c0b70) at kernel/qapplication.cpp:4458
#22 0x00007f228f6492e1 in QApplication::notify (this=0x7fff0a1c0e70, receiver=0x1260130, e=0x7fff0a1c0b70) at kernel/qapplication.cpp:4365
#23 0x00007f2290829466 in KApplication::notify (this=0x7fff0a1c0e70, receiver=0x1260130, event=0x7fff0a1c0b70) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f229100aafc in QCoreApplication::notifyInternal (this=0x7fff0a1c0e70, receiver=0x1260130, event=0x7fff0a1c0b70) at kernel/qcoreapplication.cpp:787
#25 0x00007f2291037d62 in sendEvent (event=0x7fff0a1c0b70, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1049b00) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f2291035514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f228b6eca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f228b6ed258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f228b6ed429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f2291035ed6 in QEventDispatcherGlib::processEvents (this=0x10206f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f228f6ec10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f2291009cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f2291009ef7 in QEventLoop::exec (this=0x7fff0a1c0e00, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f229100e789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff0a1c10e8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292671, bug 292662, bug 292651, bug 292641, bug 292599.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-28 23:28:05 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Hugi 2012-01-29 12:48:40 UTC
Before it happened, i just updated KDE and restart my computer.