Bug 292662 - Muon se cierra doesn't open
Summary: Muon se cierra doesn't open
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-28 06:47 UTC by Guillermo
Modified: 2012-01-28 07:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillermo 2012-01-28 06:47:46 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Nothing,  I only wanted to open Muon to see new applications
I tried to do this many times,  but the same occurs

A previous action I did was to install language ṕackages for Spanish-Peru

The system changes the language.

The system runs normaly in spanish

but Muon doesn't work.

When the system was working in english Muon opened twice normaly

I hope you can help me

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77ce930 (LWP 2365))]

Thread 2 (Thread 0xb559cb70 (LWP 2369)):
#0  0x01cc3c40 in g_main_context_query () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x01cc4664 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x01cc4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00f98b37 in QEventDispatcherGlib::processEvents (this=0x91a3580, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00f691dd in QEventLoop::processEvents (this=0xb559c2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00f69421 in QEventLoop::exec (this=0xb559c2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00e6c90b in QThread::exec (this=0x908c9e8) at thread/qthread.cpp:498
#7  0x00f49e2d in QInotifyFileSystemWatcherEngine::run (this=0x908c9e8) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00e6f7b3 in QThreadPrivate::start (arg=0x908c9e8) at thread/qthread_unix.cpp:331
#9  0x0053ad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00c950ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77ce930 (LWP 2365)):
[KCrash Handler]
#7  0x00ec3e11 in QtPrivate::QStringList_contains (that=0xbffaba64, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffaba64) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x904f290) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x904f290, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffabc84) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00f70b7d in metacall (argv=0xbffabc84, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x904f290) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x904f290, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbffabc84) at kernel/qmetaobject.cpp:232
#13 0x00f7fa6a in QMetaObject::activate (sender=0x90d1e70, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x90d1e70) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x90d1e70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffabdc8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00f70b7d in metacall (argv=0xbffabdc8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x90d1e70) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x90d1e70, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbffabdc8) at kernel/qmetaobject.cpp:232
#18 0x00f7fa6a in QMetaObject::activate (sender=0x904f290, m=0x80950c0, local_signal_index=0, argv=0xbffabdc8) at kernel/qobject.cpp:3278
#19 0x0079c7c5 in MuonMainWindow::backendReady (this=0x904f290, _t1=0x9072e80) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0079c933 in MuonMainWindow::initObject (this=0x904f290) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x904f290) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x904f290, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffabef4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00f70b7d in metacall (argv=0xbffabef4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x904f290) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x904f290, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbffabef4) at kernel/qmetaobject.cpp:232
#25 0x00f7fa6a in QMetaObject::activate (sender=0x90b4948, m=0x10a0238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00f87375 in QSingleShotTimer::timeout (this=0x90b4948) at .moc/release-shared/qtimer.moc:82
#27 0x00f8742c in QSingleShotTimer::timerEvent (this=0x90b4948) at kernel/qtimer.cpp:308
#28 0x00f82994 in QObject::event (this=0x90b4948, e=0xbffac2ec) at kernel/qobject.cpp:1181
#29 0x02a5bd84 in notify_helper (e=0xbffac2ec, receiver=0x90b4948, this=0x8f51ce8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8f51ce8, receiver=0x90b4948, e=0xbffac2ec) at kernel/qapplication.cpp:4458
#31 0x02a61133 in QApplication::notify (this=0xbffac2ec, receiver=0x90b4948, e=0xbffac2ec) at kernel/qapplication.cpp:3886
#32 0x012c0971 in KApplication::notify (this=0xbffac600, receiver=0x90b4948, event=0xbffac2ec) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00f6a19e in QCoreApplication::notifyInternal (this=0xbffac600, receiver=0x90b4948, event=0xbffac2ec) at kernel/qcoreapplication.cpp:787
#34 0x00f9ac10 in sendEvent (event=0xbffac2ec, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8f58504) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00f98122 in timerSourceDispatch (source=0x8f584d0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01cc425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01cc4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01cc4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00f98ada in QEventDispatcherGlib::processEvents (this=0x8f34238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02b13e7a in QGuiEventDispatcherGlib::processEvents (this=0x8f34238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00f691dd in QEventLoop::processEvents (this=0xbffac564, flags=...) at kernel/qeventloop.cpp:149
#43 0x00f69421 in QEventLoop::exec (this=0xbffac564, flags=...) at kernel/qeventloop.cpp:201
#44 0x00f6e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02a59924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292651, bug 292641, bug 292599, bug 292556, bug 292545.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-28 07:00:47 UTC

*** This bug has been marked as a duplicate of bug 291262 ***