Bug 292651 - Muon Crashen when I open it
Summary: Muon Crashen when I open it
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-28 02:46 UTC by Mihai Petrescu
Modified: 2012-01-28 03:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mihai Petrescu 2012-01-28 02:46:18 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I was trying to open Muon to install some more software on my newly installer computer.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f773645c780 (LWP 2145))]

Thread 2 (Thread 0x7f7721a30700 (LWP 2149)):
#0  0x00007f7733022773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f772f897f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f772f898429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f77351e0f3e in QEventDispatcherGlib::processEvents (this=0xd2b8b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f77351b4cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f77351b4ef7 in QEventLoop::exec (this=0x7f7721a2fdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f77350cc27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f7735197cbf in QInotifyFileSystemWatcherEngine::run (this=0xd207a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f77350ced05 in QThreadPrivate::start (arg=0xd207a0) at thread/qthread_unix.cpp:331
#9  0x00007f7730379efc in start_thread (arg=0x7f7721a30700) at pthread_create.c:304
#10 0x00007f773302e89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f773645c780 (LWP 2145)):
[KCrash Handler]
#6  0x00007f773511ca5e in QtPrivate::QStringList_contains (that=0x7fffcd9b4460, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffcd9b4460) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xb5be00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xb5be00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcd9b4a30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f77351c8eba in QMetaObject::activate (sender=0xbc7b60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xbc7b60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcd9b4b90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f77351c8eba in QMetaObject::activate (sender=0xb5be00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffcd9b4b90) at kernel/qobject.cpp:3278
#13 0x00007f773603ee7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xbe61f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f773603ef8e in MuonMainWindow::initObject (this=0xb5be00) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xb5be00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xb5be00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcd9b4c60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f77351c8eba in QMetaObject::activate (sender=0xbed670, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f77351d0f7f in QSingleShotTimer::timerEvent (this=0xbed670) at kernel/qtimer.cpp:308
#19 0x00007f77351cc789 in QObject::event (this=0xbed670, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f77337ef474 in notify_helper (e=0x7fffcd9b51d0, receiver=0xbed670, this=0x9fb360) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x9fb360, receiver=0xbed670, e=0x7fffcd9b51d0) at kernel/qapplication.cpp:4458
#22 0x00007f77337f42e1 in QApplication::notify (this=0x7fffcd9b54d0, receiver=0xbed670, e=0x7fffcd9b51d0) at kernel/qapplication.cpp:4365
#23 0x00007f77349d4466 in KApplication::notify (this=0x7fffcd9b54d0, receiver=0xbed670, event=0x7fffcd9b51d0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f77351b5afc in QCoreApplication::notifyInternal (this=0x7fffcd9b54d0, receiver=0xbed670, event=0x7fffcd9b51d0) at kernel/qcoreapplication.cpp:787
#25 0x00007f77351e2d62 in sendEvent (event=0x7fffcd9b51d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x9f8280) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f77351e0514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f772f897a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f772f898258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f772f898429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f77351e0ed6 in QEventDispatcherGlib::processEvents (this=0x9d46f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f773389710e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f77351b4cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f77351b4ef7 in QEventLoop::exec (this=0x7fffcd9b5460, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f77351b9789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffcd9b5748) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292641, bug 292599, bug 292556, bug 292545, bug 292533.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-28 03:18:01 UTC

*** This bug has been marked as a duplicate of bug 291262 ***