Bug 292641 - problem kbuntu 11.10
Summary: problem kbuntu 11.10
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-27 23:44 UTC by ben
Modified: 2012-01-28 01:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.07 KB, text/plain)
2012-01-28 00:50 UTC, Vinicius Miranda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ben 2012-01-27 23:44:13 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
i just start to use kbuntu
no setting i do
last thing i do it's to update my system
using kbuntu 11.10

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9a33dd6780 (LWP 6311))]

Thread 2 (Thread 0x7f9a1f6e4700 (LWP 6312)):
#0  0x00007f9a309aa773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9a2d21ff68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9a2d220429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9a32b68f3e in QEventDispatcherGlib::processEvents (this=0x1206d30, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9a32b3ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9a32b3cef7 in QEventLoop::exec (this=0x7f9a1f6e3dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9a32a5427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f9a32b1fcbf in QInotifyFileSystemWatcherEngine::run (this=0x11f8d60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9a32a56d05 in QThreadPrivate::start (arg=0x11f8d60) at thread/qthread_unix.cpp:331
#9  0x00007f9a2dd01efc in start_thread (arg=0x7f9a1f6e4700) at pthread_create.c:304
#10 0x00007f9a309b689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9a33dd6780 (LWP 6311)):
[KCrash Handler]
#6  0x00007f9a32aa4a5e in QtPrivate::QStringList_contains (that=0x7fff61ae4ac0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff61ae4ac0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x118c560) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x118c560, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff61ae5090) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f9a32b50eba in QMetaObject::activate (sender=0x123b2d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x123b2d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff61ae51f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f9a32b50eba in QMetaObject::activate (sender=0x118c560, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff61ae51f0) at kernel/qobject.cpp:3278
#13 0x00007f9a339c6e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1027d50) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f9a339c6f8e in MuonMainWindow::initObject (this=0x118c560) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x118c560) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x118c560, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff61ae52c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f9a32b50eba in QMetaObject::activate (sender=0x11f7090, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f9a32b58f7f in QSingleShotTimer::timerEvent (this=0x11f7090) at kernel/qtimer.cpp:308
#19 0x00007f9a32b54789 in QObject::event (this=0x11f7090, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f9a31177474 in notify_helper (e=0x7fff61ae5830, receiver=0x11f7090, this=0x1036a90) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1036a90, receiver=0x11f7090, e=0x7fff61ae5830) at kernel/qapplication.cpp:4458
#22 0x00007f9a3117c2e1 in QApplication::notify (this=0x7fff61ae5b30, receiver=0x11f7090, e=0x7fff61ae5830) at kernel/qapplication.cpp:4365
#23 0x00007f9a3235c466 in KApplication::notify (this=0x7fff61ae5b30, receiver=0x11f7090, event=0x7fff61ae5830) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f9a32b3dafc in QCoreApplication::notifyInternal (this=0x7fff61ae5b30, receiver=0x11f7090, event=0x7fff61ae5830) at kernel/qcoreapplication.cpp:787
#25 0x00007f9a32b6ad62 in sendEvent (event=0x7fff61ae5830, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1039960) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f9a32b68514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f9a2d21fa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f9a2d220258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f9a2d220429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f9a32b68ed6 in QEventDispatcherGlib::processEvents (this=0x10116f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f9a3121f10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f9a32b3ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f9a32b3cef7 in QEventLoop::exec (this=0x7fff61ae5ac0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f9a32b41789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff61ae5da8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292599, bug 292556, bug 292545, bug 292533, bug 292498.

Reported using DrKonqi
Comment 1 Vinicius Miranda 2012-01-28 00:50:02 UTC
Created attachment 68259 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

O Muon Software Center fecha inesperadamente sempre, nao sendo nem possivel abri-lo. Nao consegui instalar nada no sistema por causa disso.

-- Backtrace (Reduced):
#6  0x00007f45419c5a5e in QtPrivate::QStringList_contains (that=0x7fffaf834be0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffaf834be0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xaec1e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xaec1e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffaf8351b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xcb5170, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffaf835310) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 2 Jekyll Wu 2012-01-28 01:16:53 UTC

*** This bug has been marked as a duplicate of bug 291262 ***