Bug 292556 - Muon program installer
Summary: Muon program installer
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-27 08:15 UTC by vii
Modified: 2012-01-27 10:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vii 2012-01-27 08:15:43 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

nothing special: Firefox, Konsole, Dolphin worked.  But Muon pakage installer works properly.
After running the program window appears for 2-3 seconds and disappears. Information on programs do not have time to load. Restarted the program several times, after a reboot too.
Kubuntu11.10 on lenovoS12(intel).

The crash can be reproduced every time.

-- Backtrace:
Application: Центр програм Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb784c930 (LWP 4919))]

Thread 2 (Thread 0xb5428b70 (LWP 4923)):
#0  0x0579edbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x0647df14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x03bb5eda in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x03bb756d in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x03bb7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00935b37 in QEventDispatcherGlib::processEvents (this=0x976ce18, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x009061dd in QEventLoop::processEvents (this=0xb54282b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00906421 in QEventLoop::exec (this=0xb54282b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0080990b in QThread::exec (this=0x9653400) at thread/qthread.cpp:498
#9  0x008e6e2d in QInotifyFileSystemWatcherEngine::run (this=0x9653400) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0080c7b3 in QThreadPrivate::start (arg=0x9653400) at thread/qthread_unix.cpp:331
#11 0x0579cd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x064700ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb784c930 (LWP 4919)):
[KCrash Handler]
#7  0x00860e11 in QtPrivate::QStringList_contains (that=0xbfd24af4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd24af4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x96199f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x96199f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd24d14) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0090db7d in metacall (argv=0xbfd24d14, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x96199f8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x96199f8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd24d14) at kernel/qmetaobject.cpp:232
#13 0x0091ca6a in QMetaObject::activate (sender=0x9675180, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9675180) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9675180, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd24e58) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0090db7d in metacall (argv=0xbfd24e58, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9675180) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9675180, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd24e58) at kernel/qmetaobject.cpp:232
#18 0x0091ca6a in QMetaObject::activate (sender=0x96199f8, m=0x80950c0, local_signal_index=0, argv=0xbfd24e58) at kernel/qobject.cpp:3278
#19 0x00eab7c5 in MuonMainWindow::backendReady (this=0x96199f8, _t1=0x9651ae8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00eab933 in MuonMainWindow::initObject (this=0x96199f8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x96199f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x96199f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd24f84) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0090db7d in metacall (argv=0xbfd24f84, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x96199f8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x96199f8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd24f84) at kernel/qmetaobject.cpp:232
#25 0x0091ca6a in QMetaObject::activate (sender=0x968ae80, m=0xa3d238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00924375 in QSingleShotTimer::timeout (this=0x968ae80) at .moc/release-shared/qtimer.moc:82
#27 0x0092442c in QSingleShotTimer::timerEvent (this=0x968ae80) at kernel/qtimer.cpp:308
#28 0x0091f994 in QObject::event (this=0x968ae80, e=0xbfd2537c) at kernel/qobject.cpp:1181
#29 0x04563d84 in notify_helper (e=0xbfd2537c, receiver=0x968ae80, this=0x9502dd8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9502dd8, receiver=0x968ae80, e=0xbfd2537c) at kernel/qapplication.cpp:4458
#31 0x04569133 in QApplication::notify (this=0xbfd2537c, receiver=0x968ae80, e=0xbfd2537c) at kernel/qapplication.cpp:3886
#32 0x00c29971 in KApplication::notify (this=0xbfd25690, receiver=0x968ae80, event=0xbfd2537c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0090719e in QCoreApplication::notifyInternal (this=0xbfd25690, receiver=0x968ae80, event=0xbfd2537c) at kernel/qcoreapplication.cpp:787
#34 0x00937c10 in sendEvent (event=0xbfd2537c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x94fd30c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00935122 in timerSourceDispatch (source=0x94fd2d8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x03bb725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x03bb7990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03bb7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00935ada in QEventDispatcherGlib::processEvents (this=0x94de238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0461be7a in QGuiEventDispatcherGlib::processEvents (this=0x94de238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009061dd in QEventLoop::processEvents (this=0xbfd255f4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00906421 in QEventLoop::exec (this=0xbfd255f4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0090b19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x04561924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292545, bug 292533, bug 292498, bug 292487, bug 292469.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-27 10:00:51 UTC

*** This bug has been marked as a duplicate of bug 291262 ***