Bug 292545 - Muon wont start
Summary: Muon wont start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-27 02:19 UTC by Josh
Modified: 2012-01-27 03:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josh 2012-01-27 02:19:23 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I was doing nothing. I started my computer and went directly to Muon Software Center to look for some more software. 

- Unusual behavior I noticed: Muon will not start up.

- Custom settings of the application: None.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb787d930 (LWP 2393))]

Thread 2 (Thread 0xb557eb70 (LWP 2396)):
#0  0x00fbbd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x004977d5 in do_gettime (frac=0xb557e020, sec=0xb557e018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x0056a4b6 in QTimerInfoList::updateCurrentTime (this=0x9628eec) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0056a80a in QTimerInfoList::timerWait (this=0x9628eec, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00569053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb557e12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x005690ed in timerSourcePrepare (source=0x9628eb8, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x076f688c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x076f7637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x076f7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00569b37 in QEventDispatcherGlib::processEvents (this=0x9517420, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x0053a1dd in QEventLoop::processEvents (this=0xb557e2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x0053a421 in QEventLoop::exec (this=0xb557e2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0043d90b in QThread::exec (this=0x9623700) at thread/qthread.cpp:498
#14 0x0051ae2d in QInotifyFileSystemWatcherEngine::run (this=0x9623700) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x004407b3 in QThreadPrivate::start (arg=0x9623700) at thread/qthread_unix.cpp:331
#16 0x00ae5d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x008740ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb787d930 (LWP 2393)):
[KCrash Handler]
#7  0x00494e11 in QtPrivate::QStringList_contains (that=0xbf891b04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf891b04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x94cf000) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x94cf000, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf891d24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00541b7d in metacall (argv=0xbf891d24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x94cf000) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x94cf000, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf891d24) at kernel/qmetaobject.cpp:232
#13 0x00550a6a in QMetaObject::activate (sender=0x94baed0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x94baed0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x94baed0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf891e68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00541b7d in metacall (argv=0xbf891e68, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x94baed0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x94baed0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf891e68) at kernel/qmetaobject.cpp:232
#18 0x00550a6a in QMetaObject::activate (sender=0x94cf000, m=0x80950c0, local_signal_index=0, argv=0xbf891e68) at kernel/qobject.cpp:3278
#19 0x0096d7c5 in MuonMainWindow::backendReady (this=0x94cf000, _t1=0x9532440) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0096d933 in MuonMainWindow::initObject (this=0x94cf000) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x94cf000) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x94cf000, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf891f94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00541b7d in metacall (argv=0xbf891f94, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x94cf000) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x94cf000, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf891f94) at kernel/qmetaobject.cpp:232
#25 0x00550a6a in QMetaObject::activate (sender=0x9539668, m=0x671238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00558375 in QSingleShotTimer::timeout (this=0x9539668) at .moc/release-shared/qtimer.moc:82
#27 0x0055842c in QSingleShotTimer::timerEvent (this=0x9539668) at kernel/qtimer.cpp:308
#28 0x00553994 in QObject::event (this=0x9539668, e=0xbf89238c) at kernel/qobject.cpp:1181
#29 0x01a0ad84 in notify_helper (e=0xbf89238c, receiver=0x9539668, this=0x93e12a0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x93e12a0, receiver=0x9539668, e=0xbf89238c) at kernel/qapplication.cpp:4458
#31 0x01a10133 in QApplication::notify (this=0xbf89238c, receiver=0x9539668, e=0xbf89238c) at kernel/qapplication.cpp:3886
#32 0x011d9971 in KApplication::notify (this=0xbf8926a0, receiver=0x9539668, event=0xbf89238c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0053b19e in QCoreApplication::notifyInternal (this=0xbf8926a0, receiver=0x9539668, event=0xbf89238c) at kernel/qcoreapplication.cpp:787
#34 0x0056bc10 in sendEvent (event=0xbf89238c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x93e4934) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00569155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x93e4968) at kernel/qeventdispatcher_glib.cpp:231
#38 0x076f725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x076f7990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x076f7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x00569ada in QEventDispatcherGlib::processEvents (this=0x93bf238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0x01ac2e7a in QGuiEventDispatcherGlib::processEvents (this=0x93bf238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x0053a1dd in QEventLoop::processEvents (this=0xbf892604, flags=...) at kernel/qeventloop.cpp:149
#44 0x0053a421 in QEventLoop::exec (this=0xbf892604, flags=...) at kernel/qeventloop.cpp:201
#45 0x0053f19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0x01a08924 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292533, bug 292498, bug 292487, bug 292469, bug 292464.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-27 03:29:54 UTC

*** This bug has been marked as a duplicate of bug 291262 ***