Bug 292498 - Muon Software Centre crashes on launch
Summary: Muon Software Centre crashes on launch
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 19:03 UTC by Ian David Burrell
Modified: 2012-01-26 21:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian David Burrell 2012-01-26 19:03:59 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: launching application, appeared briefly, unpopulated then went straight to crash reporting assistant.

- Unusual behavior I noticed: none

- Custom settings of the application: none

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d5930 (LWP 3152))]

Thread 2 (Thread 0xb59afb70 (LWP 3156)):
#0  0x09029b63 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0x08ffbf28 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x051f0f1f in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x051f18f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x051f1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x005c6b37 in QEventDispatcherGlib::processEvents (this=0x9578b60, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x005971dd in QEventLoop::processEvents (this=0xb59af2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00597421 in QEventLoop::exec (this=0xb59af2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0049a90b in QThread::exec (this=0x952c938) at thread/qthread.cpp:498
#9  0x00577e2d in QInotifyFileSystemWatcherEngine::run (this=0x952c938) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0049d7b3 in QThreadPrivate::start (arg=0x952c938) at thread/qthread_unix.cpp:331
#11 0x00b93d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x08fee0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77d5930 (LWP 3152)):
[KCrash Handler]
#7  0x004f1e11 in QtPrivate::QStringList_contains (that=0xbfaf1394, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfaf1394) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x94e4dc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x94e4dc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfaf15b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0059eb7d in metacall (argv=0xbfaf15b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x94e4dc0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x94e4dc0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfaf15b4) at kernel/qmetaobject.cpp:232
#13 0x005ada6a in QMetaObject::activate (sender=0x9552358, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9552358) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9552358, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfaf16f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0059eb7d in metacall (argv=0xbfaf16f8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9552358) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9552358, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfaf16f8) at kernel/qmetaobject.cpp:232
#18 0x005ada6a in QMetaObject::activate (sender=0x94e4dc0, m=0x80950c0, local_signal_index=0, argv=0xbfaf16f8) at kernel/qobject.cpp:3278
#19 0x00bc17c5 in MuonMainWindow::backendReady (this=0x94e4dc0, _t1=0x9549230) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00bc1933 in MuonMainWindow::initObject (this=0x94e4dc0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x94e4dc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x94e4dc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfaf1824) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0059eb7d in metacall (argv=0xbfaf1824, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x94e4dc0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x94e4dc0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfaf1824) at kernel/qmetaobject.cpp:232
#25 0x005ada6a in QMetaObject::activate (sender=0x95525b0, m=0x6ce238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x005b5375 in QSingleShotTimer::timeout (this=0x95525b0) at .moc/release-shared/qtimer.moc:82
#27 0x005b542c in QSingleShotTimer::timerEvent (this=0x95525b0) at kernel/qtimer.cpp:308
#28 0x005b0994 in QObject::event (this=0x95525b0, e=0xbfaf1c1c) at kernel/qobject.cpp:1181
#29 0x01186d84 in notify_helper (e=0xbfaf1c1c, receiver=0x95525b0, this=0x93fd498) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x93fd498, receiver=0x95525b0, e=0xbfaf1c1c) at kernel/qapplication.cpp:4458
#31 0x0118c133 in QApplication::notify (this=0xbfaf1c1c, receiver=0x95525b0, e=0xbfaf1c1c) at kernel/qapplication.cpp:3886
#32 0x00ddc971 in KApplication::notify (this=0xbfaf1f30, receiver=0x95525b0, event=0xbfaf1c1c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0059819e in QCoreApplication::notifyInternal (this=0xbfaf1f30, receiver=0x95525b0, event=0xbfaf1c1c) at kernel/qcoreapplication.cpp:787
#34 0x005c8c10 in sendEvent (event=0xbfaf1c1c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x93ff874) at kernel/qeventdispatcher_unix.cpp:603
#36 0x005c6122 in timerSourceDispatch (source=0x93ff840) at kernel/qeventdispatcher_glib.cpp:184
#37 0x051f125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x051f1990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x051f1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x005c6ada in QEventDispatcherGlib::processEvents (this=0x93db238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0123ee7a in QGuiEventDispatcherGlib::processEvents (this=0x93db238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005971dd in QEventLoop::processEvents (this=0xbfaf1e94, flags=...) at kernel/qeventloop.cpp:149
#43 0x00597421 in QEventLoop::exec (this=0xbfaf1e94, flags=...) at kernel/qeventloop.cpp:201
#44 0x0059c19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01184924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292487, bug 292469, bug 292464, bug 292458, bug 292457.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-26 21:49:53 UTC

*** This bug has been marked as a duplicate of bug 291262 ***