Bug 292533 - muon software center crashed
Summary: muon software center crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 22:57 UTC by odetoyin
Modified: 2012-01-26 23:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description odetoyin 2012-01-26 22:57:38 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: surfing the net with firefox. I tried to open muon software center to install application and it crashed.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7862930 (LWP 11476))]

Thread 2 (Thread 0xb5b6ab70 (LWP 11477)):
#0  0x006a5d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x002f17d5 in do_gettime (frac=0xb5b6a020, sec=0xb5b6a018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x003c44b6 in QTimerInfoList::updateCurrentTime (this=0x9fc238c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x003c480a in QTimerInfoList::timerWait (this=0x9fc238c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x003c3053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5b6a12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x003c30ed in timerSourcePrepare (source=0x9fc2358, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0143788c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01438637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01438c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x003c3b37 in QEventDispatcherGlib::processEvents (this=0x9fcf188, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x003941dd in QEventLoop::processEvents (this=0xb5b6a2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00394421 in QEventLoop::exec (this=0xb5b6a2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0029790b in QThread::exec (this=0x9f6dbc8) at thread/qthread.cpp:498
#14 0x00374e2d in QInotifyFileSystemWatcherEngine::run (this=0x9f6dbc8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0029a7b3 in QThreadPrivate::start (arg=0x9f6dbc8) at thread/qthread_unix.cpp:331
#16 0x00660d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x007c50ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7862930 (LWP 11476)):
[KCrash Handler]
#7  0x002eee11 in QtPrivate::QStringList_contains (that=0xbf9f46c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9f46c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9f63aa8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9f63aa8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9f48e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0039bb7d in metacall (argv=0xbf9f48e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9f63aa8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9f63aa8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9f48e4) at kernel/qmetaobject.cpp:232
#13 0x003aaa6a in QMetaObject::activate (sender=0x9fb4a60, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9fb4a60) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9fb4a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9f4a28) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0039bb7d in metacall (argv=0xbf9f4a28, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9fb4a60) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9fb4a60, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9f4a28) at kernel/qmetaobject.cpp:232
#18 0x003aaa6a in QMetaObject::activate (sender=0x9f63aa8, m=0x80950c0, local_signal_index=0, argv=0xbf9f4a28) at kernel/qobject.cpp:3278
#19 0x009ac7c5 in MuonMainWindow::backendReady (this=0x9f63aa8, _t1=0x9f6ff98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x009ac933 in MuonMainWindow::initObject (this=0x9f63aa8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9f63aa8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9f63aa8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9f4b54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0039bb7d in metacall (argv=0xbf9f4b54, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9f63aa8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9f63aa8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9f4b54) at kernel/qmetaobject.cpp:232
#25 0x003aaa6a in QMetaObject::activate (sender=0x9fcb488, m=0x4cb238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x003b2375 in QSingleShotTimer::timeout (this=0x9fcb488) at .moc/release-shared/qtimer.moc:82
#27 0x003b242c in QSingleShotTimer::timerEvent (this=0x9fcb488) at kernel/qtimer.cpp:308
#28 0x003ad994 in QObject::event (this=0x9fcb488, e=0xbf9f4f4c) at kernel/qobject.cpp:1181
#29 0x0196cd84 in notify_helper (e=0xbf9f4f4c, receiver=0x9fcb488, this=0x9e6f538) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9e6f538, receiver=0x9fcb488, e=0xbf9f4f4c) at kernel/qapplication.cpp:4458
#31 0x01972133 in QApplication::notify (this=0xbf9f4f4c, receiver=0x9fcb488, e=0xbf9f4f4c) at kernel/qapplication.cpp:3886
#32 0x00fba971 in KApplication::notify (this=0xbf9f5260, receiver=0x9fcb488, event=0xbf9f4f4c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0039519e in QCoreApplication::notifyInternal (this=0xbf9f5260, receiver=0x9fcb488, event=0xbf9f4f4c) at kernel/qcoreapplication.cpp:787
#34 0x003c5c10 in sendEvent (event=0xbf9f4f4c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9e70554) at kernel/qeventdispatcher_unix.cpp:603
#36 0x003c3122 in timerSourceDispatch (source=0x9e70520) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0143825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01438990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01438c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x003c3ada in QEventDispatcherGlib::processEvents (this=0x9e52238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01a24e7a in QGuiEventDispatcherGlib::processEvents (this=0x9e52238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x003941dd in QEventLoop::processEvents (this=0xbf9f51c4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00394421 in QEventLoop::exec (this=0xbf9f51c4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0039919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0196a924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292498, bug 292487, bug 292469, bug 292464, bug 292458.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-26 23:22:01 UTC

*** This bug has been marked as a duplicate of bug 291262 ***