Bug 292487 - Muon Software Center Crash on launch
Summary: Muon Software Center Crash on launch
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 17:45 UTC by David
Modified: 2012-01-27 00:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.27 KB, text/plain)
2012-01-27 00:52 UTC, CornerstoneJay
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2012-01-26 17:45:42 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Fresh install of Kubuntu 11.10 x64 on Acer extensa 4420 
I started Muon Software Center and it never loads anything useful, it just goes straight to a segmentation fault.

Muon Update Manager also had an issue, when doing a software upgrade it stopped responding at 56% I had to use dpkg --configure -a to repair the upgrade. 

- Custom settings of the application:
no customizations, just fresh install.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5d0759b780 (LWP 2090))]

Thread 2 (Thread 0x7f5cf2e9c700 (LWP 2091)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f5cf2e9baf0 in ?? ()
#2  0x00007fffd1bc17e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f5d0759b780 (LWP 2090)):
[KCrash Handler]
#6  0x00007f5d0625ba5e in QtPrivate::QStringList_contains (that=0x7fffd1b93550, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffd1b93550) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1255210) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1255210, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd1b93b20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f5d06307eba in QMetaObject::activate (sender=0x13288d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x13288d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd1b93c80) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f5d06307eba in QMetaObject::activate (sender=0x1255210, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd1b93c80) at kernel/qobject.cpp:3278
#13 0x00007f5d0717de7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x12ca510) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f5d0717df8e in MuonMainWindow::initObject (this=0x1255210) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1255210) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1255210, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd1b93d50) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f5d06307eba in QMetaObject::activate (sender=0x12f2cc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f5d0630ff7f in QSingleShotTimer::timerEvent (this=0x12f2cc0) at kernel/qtimer.cpp:308
#19 0x00007f5d0630b789 in QObject::event (this=0x12f2cc0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f5d0492e474 in notify_helper (e=0x7fffd1b942c0, receiver=0x12f2cc0, this=0x10f4ed0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x10f4ed0, receiver=0x12f2cc0, e=0x7fffd1b942c0) at kernel/qapplication.cpp:4458
#22 0x00007f5d049332e1 in QApplication::notify (this=0x7fffd1b945c0, receiver=0x12f2cc0, e=0x7fffd1b942c0) at kernel/qapplication.cpp:4365
#23 0x00007f5d05b13466 in KApplication::notify (this=0x7fffd1b945c0, receiver=0x12f2cc0, event=0x7fffd1b942c0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f5d062f4afc in QCoreApplication::notifyInternal (this=0x7fffd1b945c0, receiver=0x12f2cc0, event=0x7fffd1b942c0) at kernel/qcoreapplication.cpp:787
#25 0x00007f5d06321d62 in sendEvent (event=0x7fffd1b942c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x10f1e80) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f5d0631f514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f5d009d6a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f5d009d7258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f5d009d7429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f5d0631fed6 in QEventDispatcherGlib::processEvents (this=0x10cc6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f5d049d610e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f5d062f3cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f5d062f3ef7 in QEventLoop::exec (this=0x7fffd1b94550, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f5d062f8789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffd1b94838) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292469, bug 292464, bug 292458, bug 292457, bug 292456.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-26 17:55:34 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 CornerstoneJay 2012-01-27 00:52:44 UTC
Created attachment 68217 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
Installing fresh KDE 11.10 x64 on HP8540P  Muon crashed on start and went shortly to debugger.

Further package manager for Muon worked to provide updats but stopped 63% and I had to use terminal of apt-get -update, dpkg --configure -a to finish the job of Muon.

-- Backtrace (Reduced):
#6  0x00007f2d096a4a5e in QtPrivate::QStringList_contains (that=0x7fff88dd6620, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff88dd6620) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xa084c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xa084c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff88dd6bf0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xbe2880, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff88dd6d50) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109