Bug 292469 - muon crash all time
Summary: muon crash all time
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 15:20 UTC by rafaeldb
Modified: 2012-01-26 15:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rafaeldb 2012-01-26 15:20:47 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
it's not possible to open muon, always crash

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f83c12c8780 (LWP 3032))]

Thread 2 (Thread 0x7f83ac591700 (LWP 3036)):
#0  0x00007f83bde8e773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f83ba703f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f83ba704429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f83c004cf3e in QEventDispatcherGlib::processEvents (this=0x7f83a40008b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f83c0020cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f83c0020ef7 in QEventLoop::exec (this=0x7f83ac590dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f83bff3827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f83c0003cbf in QInotifyFileSystemWatcherEngine::run (this=0x19f55b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f83bff3ad05 in QThreadPrivate::start (arg=0x19f55b0) at thread/qthread_unix.cpp:331
#9  0x00007f83bb1e5efc in start_thread (arg=0x7f83ac591700) at pthread_create.c:304
#10 0x00007f83bde9a89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f83c12c8780 (LWP 3032)):
[KCrash Handler]
#6  0x00007f83bff88a5e in QtPrivate::QStringList_contains (that=0x7fffd7d4bd00, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffd7d4bd00) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x19bbcc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x19bbcc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd7d4c2d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f83c0034eba in QMetaObject::activate (sender=0x19ce840, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x19ce840, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd7d4c430) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f83c0034eba in QMetaObject::activate (sender=0x19bbcc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd7d4c430) at kernel/qobject.cpp:3278
#13 0x00007f83c0eaae7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x19cc9f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f83c0eaaf8e in MuonMainWindow::initObject (this=0x19bbcc0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x19bbcc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x19bbcc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd7d4c500) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f83c0034eba in QMetaObject::activate (sender=0x1a13540, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f83c003cf7f in QSingleShotTimer::timerEvent (this=0x1a13540) at kernel/qtimer.cpp:308
#19 0x00007f83c0038789 in QObject::event (this=0x1a13540, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f83be65b474 in notify_helper (e=0x7fffd7d4ca70, receiver=0x1a13540, this=0x1830420) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1830420, receiver=0x1a13540, e=0x7fffd7d4ca70) at kernel/qapplication.cpp:4458
#22 0x00007f83be6602e1 in QApplication::notify (this=0x7fffd7d4cd70, receiver=0x1a13540, e=0x7fffd7d4ca70) at kernel/qapplication.cpp:4365
#23 0x00007f83bf840466 in KApplication::notify (this=0x7fffd7d4cd70, receiver=0x1a13540, event=0x7fffd7d4ca70) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f83c0021afc in QCoreApplication::notifyInternal (this=0x7fffd7d4cd70, receiver=0x1a13540, event=0x7fffd7d4ca70) at kernel/qcoreapplication.cpp:787
#25 0x00007f83c004ed62 in sendEvent (event=0x7fffd7d4ca70, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x182e680) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f83c004c514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f83ba703a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f83ba704258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f83ba704429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f83c004ced6 in QEventDispatcherGlib::processEvents (this=0x18086f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f83be70310e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f83c0020cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f83c0020ef7 in QEventLoop::exec (this=0x7fffd7d4cd00, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f83c0025789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffd7d4cfe8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 292456.

Possible duplicates by query: bug 292464, bug 292458, bug 292457, bug 292456, bug 292450.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-01-26 15:25:42 UTC

*** This bug has been marked as a duplicate of bug 291262 ***