Bug 292458 - Moun crash everytime i try to start it
Summary: Moun crash everytime i try to start it
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 13:01 UTC by wazausky
Modified: 2012-01-26 13:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wazausky 2012-01-26 13:01:07 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

whenever i try to start moun it crashes, i have try to update de system but it still crash

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78a9930 (LWP 2769))]

Thread 2 (Thread 0xb56f0b70 (LWP 2773)):
#0  0x009c9d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x004787d5 in do_gettime (frac=0xb56f0020, sec=0xb56f0018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x0054b4b6 in QTimerInfoList::updateCurrentTime (this=0x8ff7cd4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0054b80a in QTimerInfoList::timerWait (this=0x8ff7cd4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0054a053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb56f012c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0054a0ed in timerSourcePrepare (source=0x8ff7ca0, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x060c588c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x060c6637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x060c6c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0054ab37 in QEventDispatcherGlib::processEvents (this=0x8f2f270, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x0051b1dd in QEventLoop::processEvents (this=0xb56f02b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x0051b421 in QEventLoop::exec (this=0xb56f02b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0041e90b in QThread::exec (this=0x8ee0e08) at thread/qthread.cpp:498
#14 0x004fbe2d in QInotifyFileSystemWatcherEngine::run (this=0x8ee0e08) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x004217b3 in QThreadPrivate::start (arg=0x8ee0e08) at thread/qthread_unix.cpp:331
#16 0x00887d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00f080ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78a9930 (LWP 2769)):
[KCrash Handler]
#7  0x00475e11 in QtPrivate::QStringList_contains (that=0xbfb959d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb959d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8e95da0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8e95da0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb95bf4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00522b7d in metacall (argv=0xbfb95bf4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8e95da0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8e95da0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb95bf4) at kernel/qmetaobject.cpp:232
#13 0x00531a6a in QMetaObject::activate (sender=0x8f01908, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8f01908) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8f01908, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb95d38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00522b7d in metacall (argv=0xbfb95d38, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8f01908) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8f01908, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb95d38) at kernel/qmetaobject.cpp:232
#18 0x00531a6a in QMetaObject::activate (sender=0x8e95da0, m=0x80950c0, local_signal_index=0, argv=0xbfb95d38) at kernel/qobject.cpp:3278
#19 0x006d87c5 in MuonMainWindow::backendReady (this=0x8e95da0, _t1=0x8ea70a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x006d8933 in MuonMainWindow::initObject (this=0x8e95da0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8e95da0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8e95da0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb95e64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00522b7d in metacall (argv=0xbfb95e64, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8e95da0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8e95da0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb95e64) at kernel/qmetaobject.cpp:232
#25 0x00531a6a in QMetaObject::activate (sender=0x8efffb0, m=0x652238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00539375 in QSingleShotTimer::timeout (this=0x8efffb0) at .moc/release-shared/qtimer.moc:82
#27 0x0053942c in QSingleShotTimer::timerEvent (this=0x8efffb0) at kernel/qtimer.cpp:308
#28 0x00534994 in QObject::event (this=0x8efffb0, e=0xbfb9625c) at kernel/qobject.cpp:1181
#29 0x0167fd54 in notify_helper (e=0xbfb9625c, receiver=0x8efffb0, this=0x8d9ae70) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8d9ae70, receiver=0x8efffb0, e=0xbfb9625c) at kernel/qapplication.cpp:4458
#31 0x01685103 in QApplication::notify (this=0xbfb9625c, receiver=0x8efffb0, e=0xbfb9625c) at kernel/qapplication.cpp:3886
#32 0x011db971 in KApplication::notify (this=0xbfb96570, receiver=0x8efffb0, event=0xbfb9625c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0051c19e in QCoreApplication::notifyInternal (this=0xbfb96570, receiver=0x8efffb0, event=0xbfb9625c) at kernel/qcoreapplication.cpp:787
#34 0x0054cc10 in sendEvent (event=0xbfb9625c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8d9dd94) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0054a122 in timerSourceDispatch (source=0x8d9dd60) at kernel/qeventdispatcher_glib.cpp:184
#37 0x060c625f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x060c6990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x060c6c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0054aada in QEventDispatcherGlib::processEvents (this=0x8d7d238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01737e3a in QGuiEventDispatcherGlib::processEvents (this=0x8d7d238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0051b1dd in QEventLoop::processEvents (this=0xbfb964d4, flags=...) at kernel/qeventloop.cpp:149
#43 0x0051b421 in QEventLoop::exec (this=0xbfb964d4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0052019d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0167d8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292457, bug 292456, bug 292450, bug 292448, bug 292443.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-26 13:13:37 UTC

*** This bug has been marked as a duplicate of bug 291262 ***