Bug 292448 - Software Centre crash on start
Summary: Software Centre crash on start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 10:53 UTC by ltfullert
Modified: 2012-01-26 10:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ltfullert 2012-01-26 10:53:32 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Software Centre crashes when tring to start it.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9e73f5f780 (LWP 2248))]

Thread 2 (Thread 0x7f9e5f6c5700 (LWP 2249)):
#0  0x00007f9e70b2c773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9e6d3a1f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9e6d3a2429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9e72ce9f3e in QEventDispatcherGlib::processEvents (this=0x239c430, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9e72cbdcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e72cbdef7 in QEventLoop::exec (this=0x7f9e5f6c4dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9e72bd527f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f9e72ca0cbf in QInotifyFileSystemWatcherEngine::run (this=0x246a340) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9e72bd7d05 in QThreadPrivate::start (arg=0x246a340) at thread/qthread_unix.cpp:331
#9  0x00007f9e6de83efc in start_thread (arg=0x7f9e5f6c5700) at pthread_create.c:304
#10 0x00007f9e70b3889d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9e73f5f780 (LWP 2248)):
[KCrash Handler]
#6  0x00007f9e72c25a5e in QtPrivate::QStringList_contains (that=0x7fff0dacc3a0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff0dacc3a0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x245ea20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x245ea20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0dacc970) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f9e72cd1eba in QMetaObject::activate (sender=0x24d01b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x24d01b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0daccad0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f9e72cd1eba in QMetaObject::activate (sender=0x245ea20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff0daccad0) at kernel/qobject.cpp:3278
#13 0x00007f9e73b47e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x2503620) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f9e73b47f8e in MuonMainWindow::initObject (this=0x245ea20) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x245ea20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x245ea20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0daccba0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f9e72cd1eba in QMetaObject::activate (sender=0x24ed360, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f9e72cd9f7f in QSingleShotTimer::timerEvent (this=0x24ed360) at kernel/qtimer.cpp:308
#19 0x00007f9e72cd5789 in QObject::event (this=0x24ed360, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f9e712f9424 in notify_helper (e=0x7fff0dacd110, receiver=0x24ed360, this=0x2305790) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x2305790, receiver=0x24ed360, e=0x7fff0dacd110) at kernel/qapplication.cpp:4458
#22 0x00007f9e712fe291 in QApplication::notify (this=0x7fff0dacd410, receiver=0x24ed360, e=0x7fff0dacd110) at kernel/qapplication.cpp:4365
#23 0x00007f9e724dd466 in KApplication::notify (this=0x7fff0dacd410, receiver=0x24ed360, event=0x7fff0dacd110) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f9e72cbeafc in QCoreApplication::notifyInternal (this=0x7fff0dacd410, receiver=0x24ed360, event=0x7fff0dacd110) at kernel/qcoreapplication.cpp:787
#25 0x00007f9e72cebd62 in sendEvent (event=0x7fff0dacd110, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x2308ed0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f9e72ce9514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f9e6d3a1a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f9e6d3a2258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f9e6d3a2429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f9e72ce9ed6 in QEventDispatcherGlib::processEvents (this=0x22e06f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f9e713a107e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f9e72cbdcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f9e72cbdef7 in QEventLoop::exec (this=0x7fff0dacd3a0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f9e72cc2789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff0dacd688) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292443, bug 292374, bug 292363, bug 292349, bug 292340.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-26 10:56:39 UTC

*** This bug has been marked as a duplicate of bug 291262 ***