Bug 292456 - Muon software center close all the time
Summary: Muon software center close all the time
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 12:35 UTC by jonny amrques
Modified: 2012-01-26 12:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-01-26 12:35:45 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I just run Muon software cente, then it jusj close himself.

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7856930 (LWP 1825))]

Thread 2 (Thread 0xb595ab70 (LWP 1826)):
#0  0x00cc6d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x002147d5 in do_gettime (frac=0xb595a020, sec=0xb595a018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x002e74b6 in QTimerInfoList::updateCurrentTime (this=0x9b1636c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x002e780a in QTimerInfoList::timerWait (this=0x9b1636c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x002e6053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb595a12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x002e60ed in timerSourcePrepare (source=0x9b16338, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01cf088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01cf1637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01cf1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x002e6b37 in QEventDispatcherGlib::processEvents (this=0x9adc208, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x002b71dd in QEventLoop::processEvents (this=0xb595a2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x002b7421 in QEventLoop::exec (this=0xb595a2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x001ba90b in QThread::exec (this=0x9a98d30) at thread/qthread.cpp:498
#14 0x00297e2d in QInotifyFileSystemWatcherEngine::run (this=0x9a98d30) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x001bd7b3 in QThreadPrivate::start (arg=0x9a98d30) at thread/qthread_unix.cpp:331
#16 0x005b2d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x06df40ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7856930 (LWP 1825)):
[KCrash Handler]
#7  0x00211e11 in QtPrivate::QStringList_contains (that=0xbff858f4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff858f4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9a9afc8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9a9afc8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff85b14) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x002beb7d in metacall (argv=0xbff85b14, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9a9afc8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9a9afc8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbff85b14) at kernel/qmetaobject.cpp:232
#13 0x002cda6a in QMetaObject::activate (sender=0x9b13c18, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9b13c18) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9b13c18, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff85c58) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x002beb7d in metacall (argv=0xbff85c58, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9b13c18) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9b13c18, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbff85c58) at kernel/qmetaobject.cpp:232
#18 0x002cda6a in QMetaObject::activate (sender=0x9a9afc8, m=0x80950c0, local_signal_index=0, argv=0xbff85c58) at kernel/qobject.cpp:3278
#19 0x004287c5 in MuonMainWindow::backendReady (this=0x9a9afc8, _t1=0x9a2b3c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00428933 in MuonMainWindow::initObject (this=0x9a9afc8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9a9afc8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9a9afc8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff85d84) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x002beb7d in metacall (argv=0xbff85d84, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9a9afc8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9a9afc8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbff85d84) at kernel/qmetaobject.cpp:232
#25 0x002cda6a in QMetaObject::activate (sender=0x9adf4d8, m=0x3ee238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x002d5375 in QSingleShotTimer::timeout (this=0x9adf4d8) at .moc/release-shared/qtimer.moc:82
#27 0x002d542c in QSingleShotTimer::timerEvent (this=0x9adf4d8) at kernel/qtimer.cpp:308
#28 0x002d0994 in QObject::event (this=0x9adf4d8, e=0xbff8617c) at kernel/qobject.cpp:1181
#29 0x0111ed84 in notify_helper (e=0xbff8617c, receiver=0x9adf4d8, this=0x99d4e60) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x99d4e60, receiver=0x9adf4d8, e=0xbff8617c) at kernel/qapplication.cpp:4458
#31 0x01124133 in QApplication::notify (this=0xbff8617c, receiver=0x9adf4d8, e=0xbff8617c) at kernel/qapplication.cpp:3886
#32 0x00a5b971 in KApplication::notify (this=0xbff86490, receiver=0x9adf4d8, event=0xbff8617c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x002b819e in QCoreApplication::notifyInternal (this=0xbff86490, receiver=0x9adf4d8, event=0xbff8617c) at kernel/qcoreapplication.cpp:787
#34 0x002e8c10 in sendEvent (event=0xbff8617c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x99d0b3c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002e6122 in timerSourceDispatch (source=0x99d0b08) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01cf125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01cf1990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01cf1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x002e6ada in QEventDispatcherGlib::processEvents (this=0x99b2238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x011d6e7a in QGuiEventDispatcherGlib::processEvents (this=0x99b2238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x002b71dd in QEventLoop::processEvents (this=0xbff863f4, flags=...) at kernel/qeventloop.cpp:149
#43 0x002b7421 in QEventLoop::exec (this=0xbff863f4, flags=...) at kernel/qeventloop.cpp:201
#44 0x002bc19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0111c924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292450, bug 292448, bug 292443, bug 292374, bug 292363.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-26 12:46:23 UTC

*** This bug has been marked as a duplicate of bug 291262 ***