Bug 292443 - Muon Software Center crash
Summary: Muon Software Center crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 09:03 UTC by mla505
Modified: 2012-01-26 09:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mla505 2012-01-26 09:03:35 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I was updating kubuntu 11.10 when the installation hung at 52%, I am running kubuntu as a guest with Virtualbox on a Win XP SP 3 system. After waiting 10+ hours for the update to complete I finally turned off the virtual machine and since then Muon Software Center crashes everytime I open it.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb771a930 (LWP 3554))]

Thread 2 (Thread 0xb58cfb70 (LWP 3558)):
#0  0x0162aed2 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x0162c56d in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0162cc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00b04b37 in QEventDispatcherGlib::processEvents (this=0x8e8e280, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00ad51dd in QEventLoop::processEvents (this=0xb58cf2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00ad5421 in QEventLoop::exec (this=0xb58cf2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x009d890b in QThread::exec (this=0x8fcc948) at thread/qthread.cpp:498
#7  0x00ab5e2d in QInotifyFileSystemWatcherEngine::run (this=0x8fcc948) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x009db7b3 in QThreadPrivate::start (arg=0x8fcc948) at thread/qthread_unix.cpp:331
#9  0x0091fd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x006740ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb771a930 (LWP 3554)):
[KCrash Handler]
#7  0x00a2fe11 in QtPrivate::QStringList_contains (that=0xbff93054, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff93054) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8e75790) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8e75790, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff93274) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00adcb7d in metacall (argv=0xbff93274, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8e75790) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8e75790, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbff93274) at kernel/qmetaobject.cpp:232
#13 0x00aeba6a in QMetaObject::activate (sender=0x8f01680, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8f01680) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8f01680, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff933b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00adcb7d in metacall (argv=0xbff933b8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8f01680) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8f01680, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbff933b8) at kernel/qmetaobject.cpp:232
#18 0x00aeba6a in QMetaObject::activate (sender=0x8e75790, m=0x80950c0, local_signal_index=0, argv=0xbff933b8) at kernel/qobject.cpp:3278
#19 0x007cc7c5 in MuonMainWindow::backendReady (this=0x8e75790, _t1=0x8effe48) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x007cc933 in MuonMainWindow::initObject (this=0x8e75790) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8e75790) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8e75790, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff934e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00adcb7d in metacall (argv=0xbff934e4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8e75790) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8e75790, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbff934e4) at kernel/qmetaobject.cpp:232
#25 0x00aeba6a in QMetaObject::activate (sender=0x8ee13c8, m=0xc0c238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00af3375 in QSingleShotTimer::timeout (this=0x8ee13c8) at .moc/release-shared/qtimer.moc:82
#27 0x00af342c in QSingleShotTimer::timerEvent (this=0x8ee13c8) at kernel/qtimer.cpp:308
#28 0x00aee994 in QObject::event (this=0x8ee13c8, e=0xbff938dc) at kernel/qobject.cpp:1181
#29 0x02ff8d84 in notify_helper (e=0xbff938dc, receiver=0x8ee13c8, this=0x8d8d8d0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8d8d8d0, receiver=0x8ee13c8, e=0xbff938dc) at kernel/qapplication.cpp:4458
#31 0x02ffe133 in QApplication::notify (this=0xbff938dc, receiver=0x8ee13c8, e=0xbff938dc) at kernel/qapplication.cpp:3886
#32 0x011dc971 in KApplication::notify (this=0xbff93bf0, receiver=0x8ee13c8, event=0xbff938dc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00ad619e in QCoreApplication::notifyInternal (this=0xbff93bf0, receiver=0x8ee13c8, event=0xbff938dc) at kernel/qcoreapplication.cpp:787
#34 0x00b06c10 in sendEvent (event=0xbff938dc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8d8926c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00b04122 in timerSourceDispatch (source=0x8d89238) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0162c25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0162c990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0162cc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00b04ada in QEventDispatcherGlib::processEvents (this=0x8d6b238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x030b0e7a in QGuiEventDispatcherGlib::processEvents (this=0x8d6b238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00ad51dd in QEventLoop::processEvents (this=0xbff93b54, flags=...) at kernel/qeventloop.cpp:149
#43 0x00ad5421 in QEventLoop::exec (this=0xbff93b54, flags=...) at kernel/qeventloop.cpp:201
#44 0x00ada19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02ff6924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292374, bug 292363, bug 292349, bug 292340, bug 292325.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-26 09:07:59 UTC

*** This bug has been marked as a duplicate of bug 291262 ***