Bug 292450 - Muon crashed
Summary: Muon crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 11:03 UTC by cazelles.bruno
Modified: 2012-01-26 11:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cazelles.bruno 2012-01-26 11:03:28 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: nothing in particular, except launching muon, which crashed as it was launched.
I believe there was another problem, since I had Mozilla Firefox running before launching Muon, but it had "disappeared" : it seemed that it had crashed too, but when I wanted to run it again, I got a message saying that it was already running...

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7772930 (LWP 4464))]

Thread 2 (Thread 0xb56dbb70 (LWP 4468)):
#0  0x00cd1d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x008d97d5 in do_gettime (frac=0xb56db020, sec=0xb56db018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x009ac4b6 in QTimerInfoList::updateCurrentTime (this=0x8cd431c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x009ac80a in QTimerInfoList::timerWait (this=0x8cd431c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x009ab053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb56db12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x009ab0ed in timerSourcePrepare (source=0x8cd42e8, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x025d188c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x025d2637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x025d2c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x009abb37 in QEventDispatcherGlib::processEvents (this=0x8bd2a50, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x0097c1dd in QEventLoop::processEvents (this=0xb56db2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x0097c421 in QEventLoop::exec (this=0xb56db2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0087f90b in QThread::exec (this=0x8cd00c8) at thread/qthread.cpp:498
#14 0x0095ce2d in QInotifyFileSystemWatcherEngine::run (this=0x8cd00c8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x008827b3 in QThreadPrivate::start (arg=0x8cd00c8) at thread/qthread_unix.cpp:331
#16 0x00c58d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00b8a0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7772930 (LWP 4464)):
[KCrash Handler]
#7  0x008d6e11 in QtPrivate::QStringList_contains (that=0xbf998bd4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf998bd4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8b8eab0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8b8eab0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf998df4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00983b7d in metacall (argv=0xbf998df4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8b8eab0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8b8eab0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf998df4) at kernel/qmetaobject.cpp:232
#13 0x00992a6a in QMetaObject::activate (sender=0x8be32b0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8be32b0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8be32b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf998f38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00983b7d in metacall (argv=0xbf998f38, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8be32b0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8be32b0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf998f38) at kernel/qmetaobject.cpp:232
#18 0x00992a6a in QMetaObject::activate (sender=0x8b8eab0, m=0x80950c0, local_signal_index=0, argv=0xbf998f38) at kernel/qobject.cpp:3278
#19 0x005d47c5 in MuonMainWindow::backendReady (this=0x8b8eab0, _t1=0x8bd7fe0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x005d4933 in MuonMainWindow::initObject (this=0x8b8eab0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8b8eab0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8b8eab0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf999064) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00983b7d in metacall (argv=0xbf999064, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8b8eab0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8b8eab0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf999064) at kernel/qmetaobject.cpp:232
#25 0x00992a6a in QMetaObject::activate (sender=0x8be9ca8, m=0xab3238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0099a375 in QSingleShotTimer::timeout (this=0x8be9ca8) at .moc/release-shared/qtimer.moc:82
#27 0x0099a42c in QSingleShotTimer::timerEvent (this=0x8be9ca8) at kernel/qtimer.cpp:308
#28 0x00995994 in QObject::event (this=0x8be9ca8, e=0xbf99945c) at kernel/qobject.cpp:1181
#29 0x072f1d84 in notify_helper (e=0xbf99945c, receiver=0x8be9ca8, this=0x8a78218) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8a78218, receiver=0x8be9ca8, e=0xbf99945c) at kernel/qapplication.cpp:4458
#31 0x072f7133 in QApplication::notify (this=0xbf99945c, receiver=0x8be9ca8, e=0xbf99945c) at kernel/qapplication.cpp:3886
#32 0x00f52971 in KApplication::notify (this=0xbf999770, receiver=0x8be9ca8, event=0xbf99945c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0097d19e in QCoreApplication::notifyInternal (this=0xbf999770, receiver=0x8be9ca8, event=0xbf99945c) at kernel/qcoreapplication.cpp:787
#34 0x009adc10 in sendEvent (event=0xbf99945c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8a7b304) at kernel/qeventdispatcher_unix.cpp:603
#36 0x009ab122 in timerSourceDispatch (source=0x8a7b2d0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x025d225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x025d2990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x025d2c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x009abada in QEventDispatcherGlib::processEvents (this=0x8a56238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x073a9e7a in QGuiEventDispatcherGlib::processEvents (this=0x8a56238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0097c1dd in QEventLoop::processEvents (this=0xbf9996d4, flags=...) at kernel/qeventloop.cpp:149
#43 0x0097c421 in QEventLoop::exec (this=0xbf9996d4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0098119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x072ef924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292448, bug 292443, bug 292374, bug 292363, bug 292349.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-26 11:09:56 UTC

*** This bug has been marked as a duplicate of bug 291262 ***