Bug 292457 - moun crash at launch
Summary: moun crash at launch
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 12:56 UTC by wazausky
Modified: 2012-01-26 12:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wazausky 2012-01-26 12:56:10 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Just crash when y try to start moun and I had various aplications opened like thunderbird and kopete

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7767930 (LWP 2220))]

Thread 2 (Thread 0xb5734b70 (LWP 2222)):
#0  0x008d1d50 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x084a1f54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x02bcef1f in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x02bcf8f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x02bcfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0054ab37 in QEventDispatcherGlib::processEvents (this=0x9283b50, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x0051b1dd in QEventLoop::processEvents (this=0xb57342b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x0051b421 in QEventLoop::exec (this=0xb57342b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0041e90b in QThread::exec (this=0x9275358) at thread/qthread.cpp:498
#9  0x004fbe2d in QInotifyFileSystemWatcherEngine::run (this=0x9275358) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x004217b3 in QThreadPrivate::start (arg=0x9275358) at thread/qthread_unix.cpp:331
#11 0x008ced31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x084940ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7767930 (LWP 2220)):
[KCrash Handler]
#7  0x00475e11 in QtPrivate::QStringList_contains (that=0xbf9e7504, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9e7504) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9221120) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9221120, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e7724) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00522b7d in metacall (argv=0xbf9e7724, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9221120) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9221120, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9e7724) at kernel/qmetaobject.cpp:232
#13 0x00531a6a in QMetaObject::activate (sender=0x9283a90, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9283a90) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9283a90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e7868) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00522b7d in metacall (argv=0xbf9e7868, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9283a90) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9283a90, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9e7868) at kernel/qmetaobject.cpp:232
#18 0x00531a6a in QMetaObject::activate (sender=0x9221120, m=0x80950c0, local_signal_index=0, argv=0xbf9e7868) at kernel/qobject.cpp:3278
#19 0x0090f7c5 in MuonMainWindow::backendReady (this=0x9221120, _t1=0x923a7f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0090f933 in MuonMainWindow::initObject (this=0x9221120) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9221120) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9221120, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e7994) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00522b7d in metacall (argv=0xbf9e7994, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9221120) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9221120, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9e7994) at kernel/qmetaobject.cpp:232
#25 0x00531a6a in QMetaObject::activate (sender=0x928d418, m=0x652238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00539375 in QSingleShotTimer::timeout (this=0x928d418) at .moc/release-shared/qtimer.moc:82
#27 0x0053942c in QSingleShotTimer::timerEvent (this=0x928d418) at kernel/qtimer.cpp:308
#28 0x00534994 in QObject::event (this=0x928d418, e=0xbf9e7d8c) at kernel/qobject.cpp:1181
#29 0x051c3d54 in notify_helper (e=0xbf9e7d8c, receiver=0x928d418, this=0x9128eb8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9128eb8, receiver=0x928d418, e=0xbf9e7d8c) at kernel/qapplication.cpp:4458
#31 0x051c9103 in QApplication::notify (this=0xbf9e7d8c, receiver=0x928d418, e=0xbf9e7d8c) at kernel/qapplication.cpp:3886
#32 0x010b1971 in KApplication::notify (this=0xbf9e80a0, receiver=0x928d418, event=0xbf9e7d8c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0051c19e in QCoreApplication::notifyInternal (this=0xbf9e80a0, receiver=0x928d418, event=0xbf9e7d8c) at kernel/qcoreapplication.cpp:787
#34 0x0054cc10 in sendEvent (event=0xbf9e7d8c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x912599c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0054a122 in timerSourceDispatch (source=0x9125968) at kernel/qeventdispatcher_glib.cpp:184
#37 0x02bcf25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x02bcf990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02bcfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0054aada in QEventDispatcherGlib::processEvents (this=0x9107238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0527be3a in QGuiEventDispatcherGlib::processEvents (this=0x9107238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0051b1dd in QEventLoop::processEvents (this=0xbf9e8004, flags=...) at kernel/qeventloop.cpp:149
#43 0x0051b421 in QEventLoop::exec (this=0xbf9e8004, flags=...) at kernel/qeventloop.cpp:201
#44 0x0052019d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x051c18f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292456, bug 292450, bug 292448, bug 292443, bug 292374.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-26 12:57:26 UTC

*** This bug has been marked as a duplicate of bug 291262 ***