Bug 292374 - Please debug it
Summary: Please debug it
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-25 09:13 UTC by Eugen
Modified: 2012-01-25 09:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugen 2012-01-25 09:13:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Muon installer always crash when i try opening his. I think it last updates effect.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7774930 (LWP 1874))]

Thread 2 (Thread 0xb5644b70 (LWP 1878)):
#0  0x00625da8 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00a70f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x048bd70b in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x048be637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x048bec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00ce4b37 in QEventDispatcherGlib::processEvents (this=0x83f3cc0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00cb51dd in QEventLoop::processEvents (this=0xb56442b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00cb5421 in QEventLoop::exec (this=0xb56442b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00bb890b in QThread::exec (this=0x83eec00) at thread/qthread.cpp:498
#9  0x00c95e2d in QInotifyFileSystemWatcherEngine::run (this=0x83eec00) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00bbb7b3 in QThreadPrivate::start (arg=0x83eec00) at thread/qthread_unix.cpp:331
#11 0x00623d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00a630ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7774930 (LWP 1874)):
[KCrash Handler]
#7  0x00c0fe11 in QtPrivate::QStringList_contains (that=0xbfe9d5b4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe9d5b4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x83a2740) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x83a2740, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe9d7d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00cbcb7d in metacall (argv=0xbfe9d7d4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x83a2740) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x83a2740, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe9d7d4) at kernel/qmetaobject.cpp:232
#13 0x00ccba6a in QMetaObject::activate (sender=0x8413c58, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8413c58) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8413c58, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe9d918) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00cbcb7d in metacall (argv=0xbfe9d918, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8413c58) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8413c58, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe9d918) at kernel/qmetaobject.cpp:232
#18 0x00ccba6a in QMetaObject::activate (sender=0x83a2740, m=0x80950c0, local_signal_index=0, argv=0xbfe9d918) at kernel/qobject.cpp:3278
#19 0x005d57c5 in MuonMainWindow::backendReady (this=0x83a2740, _t1=0x83fe7e0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x005d5933 in MuonMainWindow::initObject (this=0x83a2740) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x83a2740) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x83a2740, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe9da44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00cbcb7d in metacall (argv=0xbfe9da44, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x83a2740) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x83a2740, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe9da44) at kernel/qmetaobject.cpp:232
#25 0x00ccba6a in QMetaObject::activate (sender=0x8429f30, m=0xdec238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00cd3375 in QSingleShotTimer::timeout (this=0x8429f30) at .moc/release-shared/qtimer.moc:82
#27 0x00cd342c in QSingleShotTimer::timerEvent (this=0x8429f30) at kernel/qtimer.cpp:308
#28 0x00cce994 in QObject::event (this=0x8429f30, e=0xbfe9de3c) at kernel/qobject.cpp:1181
#29 0x058b2d54 in notify_helper (e=0xbfe9de3c, receiver=0x8429f30, this=0x8287848) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8287848, receiver=0x8429f30, e=0xbfe9de3c) at kernel/qapplication.cpp:4458
#31 0x058b8103 in QApplication::notify (this=0xbfe9de3c, receiver=0x8429f30, e=0xbfe9de3c) at kernel/qapplication.cpp:3886
#32 0x00fd8971 in KApplication::notify (this=0xbfe9e150, receiver=0x8429f30, event=0xbfe9de3c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00cb619e in QCoreApplication::notifyInternal (this=0xbfe9e150, receiver=0x8429f30, event=0xbfe9de3c) at kernel/qcoreapplication.cpp:787
#34 0x00ce6c10 in sendEvent (event=0xbfe9de3c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x828412c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00ce4122 in timerSourceDispatch (source=0x82840f8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x048be25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x048be990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x048bec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00ce4ada in QEventDispatcherGlib::processEvents (this=0x8264220, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0596ae3a in QGuiEventDispatcherGlib::processEvents (this=0x8264220, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00cb51dd in QEventLoop::processEvents (this=0xbfe9e0b4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00cb5421 in QEventLoop::exec (this=0xbfe9e0b4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00cba19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x058b08f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292363, bug 292349, bug 292340, bug 292325, bug 292322.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-25 09:16:58 UTC

*** This bug has been marked as a duplicate of bug 291262 ***