Bug 292363 - software center don't start
Summary: software center don't start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-24 22:41 UTC by eraldomenini
Modified: 2012-01-25 00:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eraldomenini 2012-01-24 22:41:21 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
when clic for start ,it in 3 sec died

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb774a930 (LWP 2014))]

Thread 2 (Thread 0xb4370b70 (LWP 2019)):
#0  0x02dfe723 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x02dfec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x00d21b37 in QEventDispatcherGlib::processEvents (this=0x91c1bd0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00cf21dd in QEventLoop::processEvents (this=0xb43702b0, flags=...) at kernel/qeventloop.cpp:149
#4  0x00cf2421 in QEventLoop::exec (this=0xb43702b0, flags=...) at kernel/qeventloop.cpp:201
#5  0x00bf590b in QThread::exec (this=0x917fb58) at thread/qthread.cpp:498
#6  0x00cd2e2d in QInotifyFileSystemWatcherEngine::run (this=0x917fb58) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00bf87b3 in QThreadPrivate::start (arg=0x917fb58) at thread/qthread_unix.cpp:331
#8  0x009f3d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0x002960ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb774a930 (LWP 2014)):
[KCrash Handler]
#7  0x00c4ce11 in QtPrivate::QStringList_contains (that=0xbf9ea644, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9ea644) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x912f570) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x912f570, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9ea864) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00cf9b7d in metacall (argv=0xbf9ea864, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x912f570) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x912f570, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9ea864) at kernel/qmetaobject.cpp:232
#13 0x00d08a6a in QMetaObject::activate (sender=0x90a2d58, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x90a2d58) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x90a2d58, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9ea9a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00cf9b7d in metacall (argv=0xbf9ea9a8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x90a2d58) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x90a2d58, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9ea9a8) at kernel/qmetaobject.cpp:232
#18 0x00d08a6a in QMetaObject::activate (sender=0x912f570, m=0x80950c0, local_signal_index=0, argv=0xbf9ea9a8) at kernel/qobject.cpp:3278
#19 0x001287c5 in MuonMainWindow::backendReady (this=0x912f570, _t1=0x9131eb8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00128933 in MuonMainWindow::initObject (this=0x912f570) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x912f570) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x912f570, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9eaad4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00cf9b7d in metacall (argv=0xbf9eaad4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x912f570) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x912f570, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9eaad4) at kernel/qmetaobject.cpp:232
#25 0x00d08a6a in QMetaObject::activate (sender=0x918cb48, m=0xe29238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00d10375 in QSingleShotTimer::timeout (this=0x918cb48) at .moc/release-shared/qtimer.moc:82
#27 0x00d1042c in QSingleShotTimer::timerEvent (this=0x918cb48) at kernel/qtimer.cpp:308
#28 0x00d0b994 in QObject::event (this=0x918cb48, e=0xbf9eaecc) at kernel/qobject.cpp:1181
#29 0x06534d54 in notify_helper (e=0xbf9eaecc, receiver=0x918cb48, this=0x90502a0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x90502a0, receiver=0x918cb48, e=0xbf9eaecc) at kernel/qapplication.cpp:4458
#31 0x0653a103 in QApplication::notify (this=0xbf9eaecc, receiver=0x918cb48, e=0xbf9eaecc) at kernel/qapplication.cpp:3886
#32 0x01015971 in KApplication::notify (this=0xbf9eb1e0, receiver=0x918cb48, event=0xbf9eaecc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00cf319e in QCoreApplication::notifyInternal (this=0xbf9eb1e0, receiver=0x918cb48, event=0xbf9eaecc) at kernel/qcoreapplication.cpp:787
#34 0x00d23c10 in sendEvent (event=0xbf9eaecc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x90528ec) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00d21122 in timerSourceDispatch (source=0x90528b8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x02dfe25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x02dfe990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02dfec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00d21ada in QEventDispatcherGlib::processEvents (this=0x9032238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x065ece3a in QGuiEventDispatcherGlib::processEvents (this=0x9032238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00cf21dd in QEventLoop::processEvents (this=0xbf9eb144, flags=...) at kernel/qeventloop.cpp:149
#43 0x00cf2421 in QEventLoop::exec (this=0xbf9eb144, flags=...) at kernel/qeventloop.cpp:201
#44 0x00cf719d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x065328f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292349, bug 292340, bug 292325, bug 292322, bug 292321.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-25 00:26:02 UTC

*** This bug has been marked as a duplicate of bug 291262 ***