Bug 292349 - muon crashed
Summary: muon crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-24 18:37 UTC by Arthur
Modified: 2012-01-24 21:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arthur 2012-01-24 18:37:30 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I update, upgrade and reboot system. And open muon.
Opened applicatioons: standarted and yakuake.

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb782b930 (LWP 2565))]

Thread 2 (Thread 0xb5546b70 (LWP 2566)):
#0  0x0124bee8 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#1  0x0881b723 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0881bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00a7ab37 in QEventDispatcherGlib::processEvents (this=0x8c41790, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00a4b1dd in QEventLoop::processEvents (this=0xb55462b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00a4b421 in QEventLoop::exec (this=0xb55462b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0094e90b in QThread::exec (this=0x8c75bd8) at thread/qthread.cpp:498
#7  0x00a2be2d in QInotifyFileSystemWatcherEngine::run (this=0x8c75bd8) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x009517b3 in QThreadPrivate::start (arg=0x8c75bd8) at thread/qthread_unix.cpp:331
#9  0x00ca3d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x0123e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb782b930 (LWP 2565)):
[KCrash Handler]
#7  0x009a5e11 in QtPrivate::QStringList_contains (that=0xbffa25d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffa25d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8c37fe8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8c37fe8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffa27f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00a52b7d in metacall (argv=0xbffa27f4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8c37fe8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8c37fe8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbffa27f4) at kernel/qmetaobject.cpp:232
#13 0x00a61a6a in QMetaObject::activate (sender=0x8c935d0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8c935d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8c935d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffa2938) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00a52b7d in metacall (argv=0xbffa2938, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8c935d0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8c935d0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbffa2938) at kernel/qmetaobject.cpp:232
#18 0x00a61a6a in QMetaObject::activate (sender=0x8c37fe8, m=0x80950c0, local_signal_index=0, argv=0xbffa2938) at kernel/qobject.cpp:3278
#19 0x005dc7c5 in MuonMainWindow::backendReady (this=0x8c37fe8, _t1=0x8c5b738) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x005dc933 in MuonMainWindow::initObject (this=0x8c37fe8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8c37fe8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8c37fe8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffa2a64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00a52b7d in metacall (argv=0xbffa2a64, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8c37fe8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8c37fe8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbffa2a64) at kernel/qmetaobject.cpp:232
#25 0x00a61a6a in QMetaObject::activate (sender=0x8cbcd88, m=0xb82238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00a69375 in QSingleShotTimer::timeout (this=0x8cbcd88) at .moc/release-shared/qtimer.moc:82
#27 0x00a6942c in QSingleShotTimer::timerEvent (this=0x8cbcd88) at kernel/qtimer.cpp:308
#28 0x00a64994 in QObject::event (this=0x8cbcd88, e=0xbffa2e5c) at kernel/qobject.cpp:1181
#29 0x05bfad54 in notify_helper (e=0xbffa2e5c, receiver=0x8cbcd88, this=0x8b51da8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8b51da8, receiver=0x8cbcd88, e=0xbffa2e5c) at kernel/qapplication.cpp:4458
#31 0x05c00103 in QApplication::notify (this=0xbffa2e5c, receiver=0x8cbcd88, e=0xbffa2e5c) at kernel/qapplication.cpp:3886
#32 0x00ea2971 in KApplication::notify (this=0xbffa3170, receiver=0x8cbcd88, event=0xbffa2e5c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00a4c19e in QCoreApplication::notifyInternal (this=0xbffa3170, receiver=0x8cbcd88, event=0xbffa2e5c) at kernel/qcoreapplication.cpp:787
#34 0x00a7cc10 in sendEvent (event=0xbffa2e5c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8b4c53c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00a7a122 in timerSourceDispatch (source=0x8b4c508) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0881b25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0881b990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0881bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00a7aada in QEventDispatcherGlib::processEvents (this=0x8b2d238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05cb2e3a in QGuiEventDispatcherGlib::processEvents (this=0x8b2d238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00a4b1dd in QEventLoop::processEvents (this=0xbffa30d4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00a4b421 in QEventLoop::exec (this=0xbffa30d4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00a5019d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05bf88f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 292325.

Possible duplicates by query: bug 292340, bug 292325, bug 292322, bug 292321, bug 292320.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-24 21:12:45 UTC

*** This bug has been marked as a duplicate of bug 291262 ***