Bug 292340 - Application 'muon-installer' crashing
Summary: Application 'muon-installer' crashing
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-24 17:16 UTC by Brian Dofka
Modified: 2012-01-25 17:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.84 KB, text/plain)
2012-01-25 17:17 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Dofka 2012-01-24 17:16:10 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
finished booting, 1st application to run. Happens everytime on this machine. in english tho

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78b9930 (LWP 2139))]

Thread 2 (Thread 0xb5755b70 (LWP 2143)):
#0  0x00312d44 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x01dd5f54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x09302f1f in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x093038f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x09303c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00d87b37 in QEventDispatcherGlib::processEvents (this=0x9e1d3f8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00d581dd in QEventLoop::processEvents (this=0xb57552b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00d58421 in QEventLoop::exec (this=0xb57552b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00c5b90b in QThread::exec (this=0x9eda2e0) at thread/qthread.cpp:498
#9  0x00d38e2d in QInotifyFileSystemWatcherEngine::run (this=0x9eda2e0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00c5e7b3 in QThreadPrivate::start (arg=0x9eda2e0) at thread/qthread_unix.cpp:331
#11 0x0030fd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x01dc80ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78b9930 (LWP 2139)):
[KCrash Handler]
#7  0x00cb2e11 in QtPrivate::QStringList_contains (that=0xbfdf6704, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfdf6704) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9d85700) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9d85700, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdf6924) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00d5fb7d in metacall (argv=0xbfdf6924, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9d85700) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9d85700, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfdf6924) at kernel/qmetaobject.cpp:232
#13 0x00d6ea6a in QMetaObject::activate (sender=0x9df3c90, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9df3c90) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9df3c90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdf6a68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00d5fb7d in metacall (argv=0xbfdf6a68, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9df3c90) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9df3c90, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfdf6a68) at kernel/qmetaobject.cpp:232
#18 0x00d6ea6a in QMetaObject::activate (sender=0x9d85700, m=0x80950c0, local_signal_index=0, argv=0xbfdf6a68) at kernel/qobject.cpp:3278
#19 0x00f317c5 in MuonMainWindow::backendReady (this=0x9d85700, _t1=0x9d86f68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00f31933 in MuonMainWindow::initObject (this=0x9d85700) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9d85700) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9d85700, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdf6b94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00d5fb7d in metacall (argv=0xbfdf6b94, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9d85700) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9d85700, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfdf6b94) at kernel/qmetaobject.cpp:232
#25 0x00d6ea6a in QMetaObject::activate (sender=0x9df6388, m=0xe8f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00d76375 in QSingleShotTimer::timeout (this=0x9df6388) at .moc/release-shared/qtimer.moc:82
#27 0x00d7642c in QSingleShotTimer::timerEvent (this=0x9df6388) at kernel/qtimer.cpp:308
#28 0x00d71994 in QObject::event (this=0x9df6388, e=0xbfdf6f8c) at kernel/qobject.cpp:1181
#29 0x02569d54 in notify_helper (e=0xbfdf6f8c, receiver=0x9df6388, this=0x9c75818) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9c75818, receiver=0x9df6388, e=0xbfdf6f8c) at kernel/qapplication.cpp:4458
#31 0x0256f103 in QApplication::notify (this=0xbfdf6f8c, receiver=0x9df6388, e=0xbfdf6f8c) at kernel/qapplication.cpp:3886
#32 0x0114c681 in KApplication::notify (this=0xbfdf72a0, receiver=0x9df6388, event=0xbfdf6f8c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00d5919e in QCoreApplication::notifyInternal (this=0xbfdf72a0, receiver=0x9df6388, event=0xbfdf6f8c) at kernel/qcoreapplication.cpp:787
#34 0x00d89c10 in sendEvent (event=0xbfdf6f8c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9c7cd34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00d87122 in timerSourceDispatch (source=0x9c7cd00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0930325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x09303990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x09303c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00d87ada in QEventDispatcherGlib::processEvents (this=0x9c58238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02621e3a in QGuiEventDispatcherGlib::processEvents (this=0x9c58238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00d581dd in QEventLoop::processEvents (this=0xbfdf7204, flags=...) at kernel/qeventloop.cpp:149
#43 0x00d58421 in QEventLoop::exec (this=0xbfdf7204, flags=...) at kernel/qeventloop.cpp:201
#44 0x00d5d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x025678f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292325, bug 292322, bug 292321, bug 292320, bug 292311.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-24 17:26:37 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Michael 2012-01-25 17:17:49 UTC
Created attachment 68165 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
"starting the software center..."
- Unusual behavior I noticed:
"software center (muon-installer) crashes in few seconds after launchung"

-- Backtrace (Reduced):
#7  0x00d0ce11 in QtPrivate::QStringList_contains (that=0xbfe48344, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe48344) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x92bb928) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x92bb928, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe48564) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00db9b7d in metacall (argv=0xbfe48564, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x92bb928) at kernel/qmetaobject.cpp:237