Bug 292325 - Muon crashed
Summary: Muon crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-24 14:00 UTC by w.whitemouse
Modified: 2012-01-24 14:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description w.whitemouse 2012-01-24 14:00:35 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Reboot system and start Muon. It's happend always. First incident occurred after an upgrade

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f287f086780 (LWP 1943))]

Thread 2 (Thread 0x7f286a30f700 (LWP 1952)):
#0  0x00007f287bc54773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f28784c9f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f28784ca429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f287de11f3e in QEventDispatcherGlib::processEvents (this=0x1744890, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f287dde5cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f287dde5ef7 in QEventLoop::exec (this=0x7f286a30edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f287dcfd27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f287ddc8cbf in QInotifyFileSystemWatcherEngine::run (this=0x16cb1a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f287dcffd05 in QThreadPrivate::start (arg=0x16cb1a0) at thread/qthread_unix.cpp:331
#9  0x00007f2878fabefc in start_thread (arg=0x7f286a30f700) at pthread_create.c:304
#10 0x00007f287bc6089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f287f086780 (LWP 1943)):
[KCrash Handler]
#6  0x00007f287dd4da5e in QtPrivate::QStringList_contains (that=0x7fffb1c17e70, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffb1c17e70) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x16789e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x16789e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb1c18440) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f287ddf9eba in QMetaObject::activate (sender=0x1714190, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1714190, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb1c185a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f287ddf9eba in QMetaObject::activate (sender=0x16789e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffb1c185a0) at kernel/qobject.cpp:3278
#13 0x00007f287ec6fe7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1653840) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f287ec6ff8e in MuonMainWindow::initObject (this=0x16789e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x16789e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x16789e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb1c18670) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f287ddf9eba in QMetaObject::activate (sender=0x1720670, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f287de01f7f in QSingleShotTimer::timerEvent (this=0x1720670) at kernel/qtimer.cpp:308
#19 0x00007f287ddfd789 in QObject::event (this=0x1720670, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f287c421424 in notify_helper (e=0x7fffb1c18be0, receiver=0x1720670, this=0x14fa720) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x14fa720, receiver=0x1720670, e=0x7fffb1c18be0) at kernel/qapplication.cpp:4458
#22 0x00007f287c426291 in QApplication::notify (this=0x7fffb1c18ee0, receiver=0x1720670, e=0x7fffb1c18be0) at kernel/qapplication.cpp:4365
#23 0x00007f287d605466 in KApplication::notify (this=0x7fffb1c18ee0, receiver=0x1720670, event=0x7fffb1c18be0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f287dde6afc in QCoreApplication::notifyInternal (this=0x7fffb1c18ee0, receiver=0x1720670, event=0x7fffb1c18be0) at kernel/qcoreapplication.cpp:787
#25 0x00007f287de13d62 in sendEvent (event=0x7fffb1c18be0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x14f8670) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f287de11538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f28784c9a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f28784ca258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f28784ca429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f287de11ed6 in QEventDispatcherGlib::processEvents (this=0x14d26f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f287c4c907e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f287dde5cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f287dde5ef7 in QEventLoop::exec (this=0x7fffb1c18e70, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f287ddea789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fffb1c19158) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292322, bug 292321, bug 292320, bug 292311, bug 292276.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-24 14:47:08 UTC

*** This bug has been marked as a duplicate of bug 291262 ***