Bug 292078 - Muon crash on startup
Summary: Muon crash on startup
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 23:23 UTC by Cristian M. Barbe
Modified: 2012-01-21 02:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian M. Barbe 2012-01-20 23:23:07 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- Custom settings of the application:
muon crash on startup every time... is impossible to me start this aplication to install new software, this crash ever. 

This is a Kubuntu 11.10 fresh install

p.d: sorry for my english

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76e5930 (LWP 3295))]

Thread 2 (Thread 0xb553bb70 (LWP 3299)):
#0  0x00ad3ef7 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#1  0x03558723 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x03558c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00551b37 in QEventDispatcherGlib::processEvents (this=0xb4c00468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x005221dd in QEventLoop::processEvents (this=0xb553b2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00522421 in QEventLoop::exec (this=0xb553b2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0042590b in QThread::exec (this=0x9e05300) at thread/qthread.cpp:498
#7  0x00502e2d in QInotifyFileSystemWatcherEngine::run (this=0x9e05300) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x004287b3 in QThreadPrivate::start (arg=0x9e05300) at thread/qthread_unix.cpp:331
#9  0x00664d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00ac60ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76e5930 (LWP 3295)):
[KCrash Handler]
#7  0x0047ce11 in QtPrivate::QStringList_contains (that=0xbfb1aaf4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb1aaf4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9cba680) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9cba680, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb1ad14) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00529b7d in metacall (argv=0xbfb1ad14, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9cba680) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9cba680, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb1ad14) at kernel/qmetaobject.cpp:232
#13 0x00538a6a in QMetaObject::activate (sender=0x9c5ca08, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9c5ca08) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9c5ca08, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb1ae58) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00529b7d in metacall (argv=0xbfb1ae58, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9c5ca08) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9c5ca08, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb1ae58) at kernel/qmetaobject.cpp:232
#18 0x00538a6a in QMetaObject::activate (sender=0x9cba680, m=0x80950c0, local_signal_index=0, argv=0xbfb1ae58) at kernel/qobject.cpp:3278
#19 0x003897c5 in MuonMainWindow::backendReady (this=0x9cba680, _t1=0x9d0bef8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00389933 in MuonMainWindow::initObject (this=0x9cba680) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9cba680) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9cba680, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb1af84) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00529b7d in metacall (argv=0xbfb1af84, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9cba680) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9cba680, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb1af84) at kernel/qmetaobject.cpp:232
#25 0x00538a6a in QMetaObject::activate (sender=0x9d1c0a8, m=0x659238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00540375 in QSingleShotTimer::timeout (this=0x9d1c0a8) at .moc/release-shared/qtimer.moc:82
#27 0x0054042c in QSingleShotTimer::timerEvent (this=0x9d1c0a8) at kernel/qtimer.cpp:308
#28 0x0053b994 in QObject::event (this=0x9d1c0a8, e=0xbfb1b37c) at kernel/qobject.cpp:1181
#29 0x054aed54 in notify_helper (e=0xbfb1b37c, receiver=0x9d1c0a8, this=0x9bbb898) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9bbb898, receiver=0x9d1c0a8, e=0xbfb1b37c) at kernel/qapplication.cpp:4458
#31 0x054b4103 in QApplication::notify (this=0xbfb1b37c, receiver=0x9d1c0a8, e=0xbfb1b37c) at kernel/qapplication.cpp:3886
#32 0x00f85681 in KApplication::notify (this=0xbfb1b690, receiver=0x9d1c0a8, event=0xbfb1b37c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0052319e in QCoreApplication::notifyInternal (this=0xbfb1b690, receiver=0x9d1c0a8, event=0xbfb1b37c) at kernel/qcoreapplication.cpp:787
#34 0x00553c10 in sendEvent (event=0xbfb1b37c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9bc2c34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00551155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x9bc2c68) at kernel/qeventdispatcher_glib.cpp:231
#38 0x0355825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03558990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x03558c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x00551ada in QEventDispatcherGlib::processEvents (this=0x9b9e238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0x05566e3a in QGuiEventDispatcherGlib::processEvents (this=0x9b9e238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x005221dd in QEventLoop::processEvents (this=0xbfb1b5f4, flags=...) at kernel/qeventloop.cpp:149
#44 0x00522421 in QEventLoop::exec (this=0xbfb1b5f4, flags=...) at kernel/qeventloop.cpp:201
#45 0x0052719d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0x054ac8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292074, bug 292054, bug 292031, bug 292025, bug 292023.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-21 02:32:31 UTC

*** This bug has been marked as a duplicate of bug 291262 ***