Bug 292023 - Immediately crushed after app startup.
Summary: Immediately crushed after app startup.
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 09:35 UTC by Petr Svoboda
Modified: 2012-01-20 09:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Svoboda 2012-01-20 09:35:38 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: logged into.
Note: installation of Linux is without swap file.

The crash can be reproduced every time.

-- Backtrace:
Application: Centrum softwaru Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f006b48e780 (LWP 1886))]

Thread 2 (Thread 0x7f0056961700 (LWP 1890)):
#0  0x00007f0068058773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f00648cdf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f00648ce429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f006a215f3e in QEventDispatcherGlib::processEvents (this=0xbac0c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f006a1e9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f006a1e9ef7 in QEventLoop::exec (this=0x7f0056960dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f006a10127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f006a1cccbf in QInotifyFileSystemWatcherEngine::run (this=0xa26f20) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f006a103d05 in QThreadPrivate::start (arg=0xa26f20) at thread/qthread_unix.cpp:331
#9  0x00007f00653afefc in start_thread (arg=0x7f0056961700) at pthread_create.c:304
#10 0x00007f006806489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f006b48e780 (LWP 1886)):
[KCrash Handler]
#6  0x00007f006a151a5e in QtPrivate::QStringList_contains (that=0x7fffab78c050, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffab78c050) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x9b1f70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x9b1f70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffab78c620) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f006a1fdeba in QMetaObject::activate (sender=0xa4a6c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xa4a6c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffab78c780) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f006a1fdeba in QMetaObject::activate (sender=0x9b1f70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffab78c780) at kernel/qobject.cpp:3278
#13 0x00007f006b070e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xa5f380) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f006b070f8e in MuonMainWindow::initObject (this=0x9b1f70) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x9b1f70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x9b1f70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffab78c850) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f006a1fdeba in QMetaObject::activate (sender=0xa69d70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f006a205f7f in QSingleShotTimer::timerEvent (this=0xa69d70) at kernel/qtimer.cpp:308
#19 0x00007f006a201789 in QObject::event (this=0xa69d70, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f0068825424 in notify_helper (e=0x7fffab78cdc0, receiver=0xa69d70, this=0x85af00) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x85af00, receiver=0xa69d70, e=0x7fffab78cdc0) at kernel/qapplication.cpp:4458
#22 0x00007f006882a291 in QApplication::notify (this=0x7fffab78d0c0, receiver=0xa69d70, e=0x7fffab78cdc0) at kernel/qapplication.cpp:4365
#23 0x00007f0069a09126 in KApplication::notify (this=0x7fffab78d0c0, receiver=0xa69d70, event=0x7fffab78cdc0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f006a1eaafc in QCoreApplication::notifyInternal (this=0x7fffab78d0c0, receiver=0xa69d70, event=0x7fffab78cdc0) at kernel/qcoreapplication.cpp:787
#25 0x00007f006a217d62 in sendEvent (event=0x7fffab78cdc0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x858950) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f006a215514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f00648cda5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f00648ce258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f00648ce429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f006a215ed6 in QEventDispatcherGlib::processEvents (this=0x8326f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f00688cd07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f006a1e9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f006a1e9ef7 in QEventLoop::exec (this=0x7fffab78d050, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f006a1ee789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffab78d338) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292006, bug 292000, bug 291996, bug 291979, bug 291975.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-20 09:39:46 UTC

*** This bug has been marked as a duplicate of bug 291262 ***