Bug 292031 - crashreport muoncentre
Summary: crashreport muoncentre
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 13:15 UTC by leo
Modified: 2012-01-20 13:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description leo 2012-01-20 13:15:47 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:opening muon software centre, at that same moment muon software centre crashed and was closed.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon softwarecentrum (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb778b930 (LWP 3333))]

Thread 2 (Thread 0xb5882b70 (LWP 3334)):
#0  0x0094bd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x006eb7d5 in do_gettime (frac=0xb5882020, sec=0xb5882018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x007be4b6 in QTimerInfoList::updateCurrentTime (this=0x9cb65f4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x007be80a in QTimerInfoList::timerWait (this=0x9cb65f4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x007bd053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb588212c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x007bd0ed in timerSourcePrepare (source=0x9cb65c0, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01dde88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01ddf637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01ddfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x007bdb37 in QEventDispatcherGlib::processEvents (this=0x9c1dd18, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x0078e1dd in QEventLoop::processEvents (this=0xb58822b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x0078e421 in QEventLoop::exec (this=0xb58822b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0069190b in QThread::exec (this=0x9c2c6d8) at thread/qthread.cpp:498
#14 0x0076ee2d in QInotifyFileSystemWatcherEngine::run (this=0x9c2c6d8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x006947b3 in QThreadPrivate::start (arg=0x9c2c6d8) at thread/qthread_unix.cpp:331
#16 0x0034bd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0045a0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb778b930 (LWP 3333)):
[KCrash Handler]
#7  0x006e8e11 in QtPrivate::QStringList_contains (that=0xbfc9ac04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc9ac04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9c27eb8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9c27eb8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc9ae24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00795b7d in metacall (argv=0xbfc9ae24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9c27eb8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9c27eb8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc9ae24) at kernel/qmetaobject.cpp:232
#13 0x007a4a6a in QMetaObject::activate (sender=0x9c87328, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9c87328) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9c87328, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc9af68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00795b7d in metacall (argv=0xbfc9af68, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9c87328) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9c87328, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc9af68) at kernel/qmetaobject.cpp:232
#18 0x007a4a6a in QMetaObject::activate (sender=0x9c27eb8, m=0x80950c0, local_signal_index=0, argv=0xbfc9af68) at kernel/qobject.cpp:3278
#19 0x00f367c5 in MuonMainWindow::backendReady (this=0x9c27eb8, _t1=0x9c7e570) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00f36933 in MuonMainWindow::initObject (this=0x9c27eb8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9c27eb8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9c27eb8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc9b094) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00795b7d in metacall (argv=0xbfc9b094, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9c27eb8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9c27eb8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc9b094) at kernel/qmetaobject.cpp:232
#25 0x007a4a6a in QMetaObject::activate (sender=0x9c8bfc0, m=0x8c5238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x007ac375 in QSingleShotTimer::timeout (this=0x9c8bfc0) at .moc/release-shared/qtimer.moc:82
#27 0x007ac42c in QSingleShotTimer::timerEvent (this=0x9c8bfc0) at kernel/qtimer.cpp:308
#28 0x007a7994 in QObject::event (this=0x9c8bfc0, e=0xbfc9b48c) at kernel/qobject.cpp:1181
#29 0x020eed54 in notify_helper (e=0xbfc9b48c, receiver=0x9c8bfc0, this=0x9b30940) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9b30940, receiver=0x9c8bfc0, e=0xbfc9b48c) at kernel/qapplication.cpp:4458
#31 0x020f4103 in QApplication::notify (this=0xbfc9b48c, receiver=0x9c8bfc0, e=0xbfc9b48c) at kernel/qapplication.cpp:3886
#32 0x01151681 in KApplication::notify (this=0xbfc9b7a0, receiver=0x9c8bfc0, event=0xbfc9b48c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0078f19e in QCoreApplication::notifyInternal (this=0xbfc9b7a0, receiver=0x9c8bfc0, event=0xbfc9b48c) at kernel/qcoreapplication.cpp:787
#34 0x007bfc10 in sendEvent (event=0xbfc9b48c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9b2ce34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x007bd122 in timerSourceDispatch (source=0x9b2ce00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01ddf25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01ddf990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01ddfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x007bdada in QEventDispatcherGlib::processEvents (this=0x9b0e238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x021a6e3a in QGuiEventDispatcherGlib::processEvents (this=0x9b0e238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0078e1dd in QEventLoop::processEvents (this=0xbfc9b704, flags=...) at kernel/qeventloop.cpp:149
#43 0x0078e421 in QEventLoop::exec (this=0xbfc9b704, flags=...) at kernel/qeventloop.cpp:201
#44 0x0079319d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x020ec8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292025, bug 292023, bug 292006, bug 292000, bug 291996.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-20 13:20:49 UTC

*** This bug has been marked as a duplicate of bug 291262 ***