Bug 292025 - Muon software center immediately open, show crash
Summary: Muon software center immediately open, show crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 10:05 UTC by Paolo Torresan
Modified: 2012-01-20 10:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Torresan 2012-01-20 10:05:28 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- Custom settings of the application:

Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f82dcfdc780 (LWP 1807))]

Thread 2 (Thread 0x7f82c8610700 (LWP 1808)):
#0  0x00007f82d9bb4773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f82d6429f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f82d642a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f82dbd71f3e in QEventDispatcherGlib::processEvents (this=0x1984b30, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f82dbd45cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f82dbd45ef7 in QEventLoop::exec (this=0x7f82c860fdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f82dbc5d27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f82dbd28cbf in QInotifyFileSystemWatcherEngine::run (this=0x1943b90) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f82dbc5fd05 in QThreadPrivate::start (arg=0x1943b90) at thread/qthread_unix.cpp:331
#9  0x00007f82d6f0befc in start_thread (arg=0x7f82c8610700) at pthread_create.c:304
#10 0x00007f82d9bc089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f82dcfdc780 (LWP 1807)):
[KCrash Handler]
#6  0x00007f82dbcada5e in QtPrivate::QStringList_contains (that=0x7fff5a6ef940, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff5a6ef940) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x18ef5d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x18ef5d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5a6eff10) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f82dbd59eba in QMetaObject::activate (sender=0x19b2270, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x19b2270, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5a6f0070) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f82dbd59eba in QMetaObject::activate (sender=0x18ef5d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff5a6f0070) at kernel/qobject.cpp:3278
#13 0x00007f82dcbcce7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x18eb1f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f82dcbccf8e in MuonMainWindow::initObject (this=0x18ef5d0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x18ef5d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x18ef5d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5a6f0140) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f82dbd59eba in QMetaObject::activate (sender=0x1955460, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f82dbd61f7f in QSingleShotTimer::timerEvent (this=0x1955460) at kernel/qtimer.cpp:308
#19 0x00007f82dbd5d789 in QObject::event (this=0x1955460, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f82da381424 in notify_helper (e=0x7fff5a6f06b0, receiver=0x1955460, this=0x1778b30) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1778b30, receiver=0x1955460, e=0x7fff5a6f06b0) at kernel/qapplication.cpp:4458
#22 0x00007f82da386291 in QApplication::notify (this=0x7fff5a6f09b0, receiver=0x1955460, e=0x7fff5a6f06b0) at kernel/qapplication.cpp:4365
#23 0x00007f82db565126 in KApplication::notify (this=0x7fff5a6f09b0, receiver=0x1955460, event=0x7fff5a6f06b0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f82dbd46afc in QCoreApplication::notifyInternal (this=0x7fff5a6f09b0, receiver=0x1955460, event=0x7fff5a6f06b0) at kernel/qcoreapplication.cpp:787
#25 0x00007f82dbd73d62 in sendEvent (event=0x7fff5a6f06b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x177bba0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f82dbd71514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f82d6429a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f82d642a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f82d642a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f82dbd71ed6 in QEventDispatcherGlib::processEvents (this=0x17536f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f82da42907e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f82dbd45cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f82dbd45ef7 in QEventLoop::exec (this=0x7fff5a6f0940, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f82dbd4a789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff5a6f0c28) at /build/buildd/muon-1.2.1/installer/main.cpp:61

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f11b5121780 (LWP 1824))]

Thread 2 (Thread 0x7f11a05c4700 (LWP 1828)):
#0  0x00007f11b1cf9773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f11ae56ef68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f11ae56f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f11b3eb6f3e in QEventDispatcherGlib::processEvents (this=0x11ebaf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f11b3e8acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f11b3e8aef7 in QEventLoop::exec (this=0x7f11a05c3dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f11b3da227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f11b3e6dcbf in QInotifyFileSystemWatcherEngine::run (this=0x1069840) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f11b3da4d05 in QThreadPrivate::start (arg=0x1069840) at thread/qthread_unix.cpp:331
#9  0x00007f11af050efc in start_thread (arg=0x7f11a05c4700) at pthread_create.c:304
#10 0x00007f11b1d0589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f11b5121780 (LWP 1824)):
[KCrash Handler]
#6  0x00007f11b3df2a5e in QtPrivate::QStringList_contains (that=0x7ffff6bd7180, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7ffff6bd7180) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x101c7f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x101c7f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff6bd7750) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f11b3e9eeba in QMetaObject::activate (sender=0x101a1c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x101a1c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff6bd78b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f11b3e9eeba in QMetaObject::activate (sender=0x101c7f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff6bd78b0) at kernel/qobject.cpp:3278
#13 0x00007f11b4d11e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xfd5430) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f11b4d11f8e in MuonMainWindow::initObject (this=0x101c7f0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x101c7f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x101c7f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff6bd7980) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f11b3e9eeba in QMetaObject::activate (sender=0x10b1c40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f11b3ea6f7f in QSingleShotTimer::timerEvent (this=0x10b1c40) at kernel/qtimer.cpp:308
#19 0x00007f11b3ea2789 in QObject::event (this=0x10b1c40, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f11b24c6424 in notify_helper (e=0x7ffff6bd7ef0, receiver=0x10b1c40, this=0xea5b30) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xea5b30, receiver=0x10b1c40, e=0x7ffff6bd7ef0) at kernel/qapplication.cpp:4458
#22 0x00007f11b24cb291 in QApplication::notify (this=0x7ffff6bd81f0, receiver=0x10b1c40, e=0x7ffff6bd7ef0) at kernel/qapplication.cpp:4365
#23 0x00007f11b36aa126 in KApplication::notify (this=0x7ffff6bd81f0, receiver=0x10b1c40, event=0x7ffff6bd7ef0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f11b3e8bafc in QCoreApplication::notifyInternal (this=0x7ffff6bd81f0, receiver=0x10b1c40, event=0x7ffff6bd7ef0) at kernel/qcoreapplication.cpp:787
#25 0x00007f11b3eb8d62 in sendEvent (event=0x7ffff6bd7ef0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xea8ba0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f11b3eb6514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f11ae56ea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f11ae56f258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f11ae56f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f11b3eb6ed6 in QEventDispatcherGlib::processEvents (this=0xe806f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f11b256e07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f11b3e8acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f11b3e8aef7 in QEventLoop::exec (this=0x7ffff6bd8180, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f11b3e8f789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7ffff6bd8468) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291852.

Possible duplicates by query: bug 292023, bug 292006, bug 292000, bug 291996, bug 291979.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-20 10:08:18 UTC

*** This bug has been marked as a duplicate of bug 291262 ***